Next Generation Emulation banner

1 - 20 of 34 Posts

·
Banned
Joined
·
23,263 Posts
Emulators themselves should also be a sub category.
 

·
Registered
Joined
·
9,504 Posts
Discussion Starter #3
Emulators themselves should also be a sub category.
I was thinking of that at first, but the amount of entries each emulator will have does not justify the extra clutter. Basically, each emulator will have the latest stable release for download, and a newer unstable version for download (if applicable).

For example:

ePSXe 1.7.0 is the current stable
ePSXe 1.8.0 beta is released. Since it's an unstable release, we will keep the download link of ePSXe 1.7.0 for people who need to downgrade
ePSXe 1.8.0 final is released. ePSXe 1.7.0 entry will be replaced with this new version. The beta will be deleted
 

·
Banned
Joined
·
23,263 Posts
having to scroll down from the categories list to find the emulators is more untidy, imo.
 

·
Banned
Joined
·
23,263 Posts
That's great. Some more emulators and all would be cool. But I think there's no need to posting beta versions of emulators. It's a waste of time. Plugins would be very useful here. Nice work!!

Speak for yourself dude :p
 

·
Registered Anime Hater
Joined
·
8,674 Posts
Great idea! Now we'll have one place where all emulators and their plug-ins will be available for download. No need to Google and go to different websites!
 

·
Registered Anime Hater
Joined
·
8,674 Posts
Originally posted by Silenus
Is this running now.
Because it says I do not have permission to access this page. p
I got that error when opening the page a day ago, but now it's working fine.
 

·
Registered
Joined
·
5,977 Posts
I was thinking of that at first, but the amount of entries each emulator will have does not justify the extra clutter. Basically, each emulator will have the latest stable release for download, and a newer unstable version for download (if applicable).

For example:

ePSXe 1.7.0 is the current stable
ePSXe 1.8.0 beta is released. Since it's an unstable release, we will keep the download link of ePSXe 1.7.0 for people who need to downgrade
ePSXe 1.8.0 final is released. ePSXe 1.7.0 entry will be replaced with this new version. The beta will be deleted
I'm not sure about space limitations on the server, but it makes sense to me that you might want to keep old version there, if not only for archival purposes, there is also the possibility of a certain game working great with 1.7.0 and having a bug and 1.8.0, or something like this.

You could move all the old downloads to a archive category...
 

·
Is this thing on?
Joined
·
2,121 Posts
Nice one!

Just as what BigIg said, I recommend keeping some revisions in a separate category. This should enable users to fall back on the previous version should ever a fatal bug prevents it from running certain games during emulation.
 

·
-
Joined
·
113 Posts
I like archives with old releases that may have disappeared from the original site. Every release of every PSX emulator etc. would be a reason to download from ngemu.
 
1 - 20 of 34 Posts
Top