Next Generation Emulation banner

1 - 20 of 229 Posts

·
CoLD InSiDE
Joined
·
2,615 Posts
Discussion Starter #1
:p

Simply Amazing.
 

·
Canadian Spaceman
Joined
·
8,767 Posts
It is indeed just as good as the first one. I am playing on "Hard" and I cant get past one URL race. Ive done every stage 1 race I could find but this one URL is impossible! My car (Miata) has all the upgrades possible atm but it just cant keep up >_<

Edit: My car, and the race im stuck on is outlined in blue.
Edit2: Woot :D I beat it finally, kinda helped by being placed iat the start of the line instead of the back ;)
 

·
CoLD InSiDE
Joined
·
2,615 Posts
Discussion Starter #3
Im awaiting, how Gamespot rates it.
 

·
Premium Member
Joined
·
21,977 Posts
mine runs pretty slow..but even so, it's extremely playable and very fun. i played for at least 6 hours today (first day i got it) :D

check out the screenshot. kind of a close race, eh?

btw, is there a button to take screenshots? i took that one with print screen..
 

·
Registered
Joined
·
7,330 Posts
Slow on your rig hushy? Man, the 5600 must really suck. oO Runs absolutely velvety on mine, with everything set to max @ 1024x768.
 

·
CoLD InSiDE
Joined
·
2,615 Posts
Discussion Starter #6
Im having lags myself, some of'em are so worse, that I decide not to play the game for an hour or so, but what the hell. The game is so cool, that once u start, u won't move for hours.
 

·
Registered
Joined
·
5,776 Posts
I doubt it it does run that smooth on ur system with everything maxed cooliscool. That contrast thingy was a real fps eater even on my card
 

·
Canadian Spaceman
Joined
·
8,767 Posts
Lets see some more cars :D

2xAA iirc.
 

·
Registered
Joined
·
7,330 Posts
Metalmurphy said:
I doubt it it does run that smooth on ur system with everything maxed cooliscool. That contrast thingy was a real fps eater even on my card
I have that off, I don't like the effect.. too dark on my system. That's more of a preference option. Your CPU/RAM sucks so bad it's probably holding the game back even with that videocard.

I assure you it's running perfectly with all maxed though.
 

·
Premium Member
Joined
·
21,977 Posts
cooliscool said:
Slow on your rig hushy? Man, the 5600 must really suck. oO Runs absolutely velvety on mine, with everything set to max @ 1024x768.
well i havent changed any "advanced" options, i just have it at 800x600. i get 15 (****loads of action going on) to 40 (light action). mostly hovers around 30. is there some option that's making it go ass slow? (i would guess a DX9 effect or something, like specular in Halo). the 5600 is not bad with games normally, and i do have it slightly OCed (370/561, from 325/500) so...

btw chris (eternal11) came over yesterday, i didnt bother to check what his FPS are though. he plays it in 800x600 though, just like every other game he plays :???:
 

·
Premium Member
Joined
·
12,032 Posts
I'll post some shots later. Haven't started career mode yet. Damn this game is fun so far though :D
 

·
Canadian Spaceman
Joined
·
8,767 Posts
CpU MasteR said:
All you mother ****ers bow down to your master
Psssht! :p
 

·
Registered
Joined
·
48 Posts
This game is pretty fun.. but I hate how they included lame SUVs and spinning rims.. but I guess I shouldn't be surprised. Another thing I don't like is that you have to add all of that tacky stuff just to progress in the game. In the original, I was just happy with just a few mods.. but now I guess a clown car is expected of you in order to finish the game.
 

·
CoLD InSiDE
Joined
·
2,615 Posts
Discussion Starter #17
Im totally not impressed by the SUV's sorry.
 

·
Registered
Joined
·
331 Posts
my civic, ill show my is300 later once i get all the visuals done since i've just been putting all the money into the performance upgrades.

edit: ok added my is300.

edit of the edit: new is300, painted the rims and added some decals.
 

·
Registered
Joined
·
5,776 Posts
Haha thats gotta be the ugliest car i've ever seen ;)
 
1 - 20 of 229 Posts
Top