Next Generation Emulation banner

1 - 16 of 16 Posts

·
Registered
Joined
·
12 Posts
Discussion Starter #1
Hello,

After looking through previous threads on this game and being unable to find a solution in them, I decided to post this thread asking for help.

In the Misadventures of Tron Bonne, i've been having a few problems, which i've been able to fix, unfortunately, only one has stumped me. After wading through initial problems with access menus, sound problems and the like, i've been stopped by the game freezing after the first boss fight with Glyde. The problem starts immediately after his robot's eyes glow red in the cutscene after you beat him, the game semi-freezes. The music track continues to play, but the actual cutscene doesn't progress. If I hit start to skip the cutscene, however, it simply goes to a white screen, and fails to progress also. Here's my current graphics config.

Plugin: Pete's D3D Driver 1.1.76
Author: Pete Bernert
GFX card: RADEON 9800 PRO

Resolution/Color:
- 640x480 Window mode

Textures:
- R4G4B4A4
- Filtering: 0
- Hi-Res textures: 0
- VRam size: 0 MBytes

Framerate:
- FPS limit: on
- Frame skipping: off
- FPS limit: 60.0

Compatibility:
- Offscreen drawing: 1
- Framebuffer texture: 0
- Framebuffer access: 4
- Alpha multipass: on
- Mask bit: off
- Advanced blending: none

Misc:
- Scanlines: off [0]
- Unfiltered FB: on
- Dithering: off
- Screen smoothing: off
- Full vram: on
- Game fixes: off [00000000]

I'm not entirely sure what the problem could be. If anyone could help, then thanks, as i've wanted to play this game for a long time now.
 

·
Premium Member
Joined
·
21,977 Posts
it's a plugin. in fact, i would not recommend D3D at all---OpenGL or OpenGL2 for your card. but, to test it, try getting Peops software plugin, available here.
 

·
Registered
Joined
·
12 Posts
Discussion Starter #7
Playing off of ISO, and i've used save states, although i've done the quick beginning section several times through without to test it out, and it ends up the same every time.
 

·
Premium Member
Joined
·
5,155 Posts
Try to run the game from Cd,

Btw: while using savestates always have a memory card save just in case, sometimes games
may not work right because of the savestates, though I see you have started over without savestates so that is not a problem.
 

·
Registered
Joined
·
12 Posts
Discussion Starter #9
Alright, after a little more experimentation, i've isolated exactly what the problem is.

After you beat up the first boss, a text box should appear accompanying his animation, but for some reason on my setup, it doesn't. I found that out going through with some options that had made it so the actual character voices were disabled, so it ran through fine, but whenever I have speech enabled, it just hangs there and doesn't display the character text. Not sure how much this will help, but that's exactly where and what it is.
 

·
Premium Member
Joined
·
5,155 Posts
So the game doesn't work if you have speech enabled, that also happens in the pSX, right?
Could be the faulty ISO, as I said try to run the game from cd (with subchannel reading enabled).
 

·
Registered
Joined
·
12 Posts
Discussion Starter #11
Also happens in pSX, yes, and I tried running from CD to no avail. May just have to ebay the actual game, which isn't really a bad thing, since it's really one of my favorite PSX era games.
 

·
Premium Member
Joined
·
5,155 Posts
Hm... Try this (if that doesn't help i dunno, you will have to play without voices):

Make an image with Alcohol120% with Playstation profile and .ccd option,
use Mooby2 cd disk image driver cd plugin and "enable subchannels", "Play one CDDA track and stop" with CDDA volume bar to the max.
 

·
Registered
Joined
·
22 Posts
I suffer from the exact same problem. It mostly occurs for me with voiced dialog sequences in the Digger mission. even holding down triangle to skip the speech doesn't help prevent it from locking up the text.

I've tried altering all sound plugins, and even video ones. None of them fixed the problem. I've also used the actual CD, and 3 seperate copies of an ISO; One made by Nero, another by alcohol, and another grabbed from emule in case my physical copy was damaged in some case. All variations failed to fix it, so it wasn't my copy of the game that was the problem either.

I believe it's the emulator itself. Even the big listing in the sticky post says the game has some trouble with it. So I have a feeling we may be forced to wait for a new version to come out before we can play this great game, because I've run out of ideas on what else it can be
 

·
Registered
Joined
·
3 Posts
Almost the same problem!

I have a similar problem! After I defeat de "Intro Boss", it starts a cutscene in wich Glide flys over me shooting a laser and Teasel screams. At that poit, the screen turns white and the game freezes. I'm playing from an ISO without savestates. Please help me! What do I do?????
 

·
Registered
Joined
·
326 Posts
Hey Folks. If you are still getting with those freezing issues at this game. I recomend on to use the Spu ePSXe core. It will no pain for everybody. And i can tell about this; i already finished this game using the ePSXe 1.80 version years in the past, and it worked like a charm. Those problems came along with the sound plugin instead from the graphics issues.
 
1 - 16 of 16 Posts
Top