Next Generation Emulation banner

1 - 13 of 13 Posts

·
Registered
Joined
·
11 Posts
Discussion Starter · #1 · (Edited)
Hi I'm very new at this and wondering if "perfect" emulation is possible. I'm running a p4 with 512mb ram and gforce4 gfx card. I'm trying to play Xenogears, it's playable but minorly slowsdown. I'm using epsx 1.60 and can't keep a steady frame rate. I have to limit the framerate to 60 or else it goes to fast. The framerate generally goes 59.9, 54.9, 52.9, 48.8, 59.9... I've tried using many plugins and different setting every five minutes. No matter if I choose fast or nice, the slowdown is the same. Any suggestions? I've mostly been using OpenGL 1.76, Peops latest for video and Eternal SPu for sound. What resolution should I use?
 

·
Registered
Joined
·
231 Posts
use ePSXe 1.5.2
maybe try using something like Nero DriveSpeed? cd access spinup/down can casue some minour slowdows, especially when loading or rendering a new area/screen/character/etc?

PS- i like how you loosely use the term "perfect"
i truly believe there will be a day the creators of ePSXe will get all games running perfectly- to me, perfect is getting all the games running with *minour* little glitches.

if you want a perfect emulator, go buy a real PSX. all games are 100% gaurenteed to work.
 

·
Premium Member
Joined
·
6,341 Posts
Do you have a lot of programs running in the background? I've noticed that if I leave [email protected] running in the background on my computer, it causes hiccups in ePSXe every few seconds. Does the framerate still dip to those levels when you turn off the framelimiter? Have you tried using ePSXe 1.5.2?
 

·
Registered
Joined
·
11 Posts
Discussion Starter · #4 ·
I'm using an ISO that I ripped from own bought game. The only thing I have running in the background is bittorrent, does that make a difference. I used to epsx 1.52 to try Chrono Cross, but it was the same thing really. All the FMV and anime scenes run beautifully too.
 

·
Premium Member
bsnes, ePSXe
Joined
·
21,979 Posts
update your videocard drivers. you should have no problem running it. what graphics settings are you using?
 

·
Registered
Joined
·
11 Posts
Discussion Starter · #6 ·
I have the latest driver, it is an older video card though gforce4 4200ti. I just don't understand why I can run it at 80fps no problem (except it goes way too fast) but I can't keep a steady 60fps.

Current gfx settings: I've tried many many others.
Plugin: Pete's OpenGL Driver 1.1.76
Author: Pete Bernert
Card vendor: NVIDIA Corporation
GFX card: GeForce4 Ti 4200/AGP/SSE2

Resolution/Color:
- 800x600 Fullscreen - NO desktop changing [32 Bit]
- Keep psx aspect ratio: off

Textures:
- R8G8B8A8
- Filtering: 0
- Hi-Res textures: 0
- VRam size: 0 MBytes

Framerate:
- FPS limitation: on
- Frame skipping: off
- FPS limit: Auto

Compatibility:
- Offscreen drawing: 3
- Framebuffer texture: 2
- Framebuffer access: 0
- Alpha multipass: on
- Mask bit: on
- Advanced blending: on

Misc:
- Scanlines: off
- Line mode: off
- Unfiltered FB: off
- 15 bit FB: off
- Dithering: off
- Screen smoothing: off
- Screen cushion: off
- Game fixes: off [00001000]
 

·
Is this thing on?
Joined
·
2,121 Posts
It will largely depend on the processor speed.
However, obtaining framerates @ 59.9, 54.9, 52.9, 48.8 or 59.9 is pretty normal.
 

·
Registered
Joined
·
111 Posts
I don't see any reason why you couldn't just limit your FPS to 45. That will eliminate any inconsistencies in the frame rate and still give your absolutely smooth gameplay. Also, this value will still be above and beyond the FPS normally achieved on a regular PSX console.
 

·
Premium Member
Joined
·
3,093 Posts
Not in this scenario. PSX games sync speed with framerate, wich means they are supposed to generate exactly 50 frames every second in PAL games, and 59.9 in NTSC ones. If you limit the numbers to something like 24, you'll be running at around ~50% the speed you are supposed to be playing, so the game would go horribly slow.

Try changing framebuffer texture to 0, and access to 4.
 

·
Premium Member
bsnes, ePSXe
Joined
·
21,979 Posts
try playing off an ISO, or better configure your CD plugin. this happens with incorrect CD configs, when you limit the FPS it's quite dodgy but when you unlimit FPS it goes through the roof.
 

·
Registered
Joined
·
11 Posts
Discussion Starter · #12 ·
Well it plays well enough, so maybe I should stop whining. But it's the sound that bothers me when the frame rate dips down. I am using an ISO btw.
 

·
Premium Member
bsnes, ePSXe
Joined
·
21,979 Posts
use Eternal 1.41 at default settings with teh FF8 sound fix (if you arent already). what drivers are you using for the 4200/
 
1 - 13 of 13 Posts
Top