Next Generation Emulation banner
1 - 17 of 17 Posts

·
Read Only
Joined
·
9 Posts
Discussion Starter · #1 · (Edited)
Hi.

I'm new to ePSXe and I have just downloaded vers. 1.6.0. I would like to play Metal Gear Solid through this emulator. I have the following plugins:

  • Pete's OpenGL2 Driver 2.6
  • P.E.Op.S. PSX CDR 1.4

These are the current settings for my gpu:

Resolution/Color:
- 640x480 Window mode
- Internal X resolution: 1
- Internal Y resolution: 1
- Keep psx aspect ratio: off
- No render-to-texture: off

- Filtering: 0
- Hi-Res textures: 0
- TexWin pixel shader: off
- VRam size: 0 MBytes

Framerate:
- FPS limitation: on
- Frame skipping: on
- FPS limit: Auto

Compatibility:
- Offscreen drawing: 1
- Framebuffer effects: 2
- Framebuffer uploads: 1

Misc:
- Scanlines: off
- Mdec filter: on
- Screen filtering: on
- Shader effects: 0/1
- Flicker-fix border size: 0
- GF4/XP crash fix: off
- Game fixes: off [00000000]

However, with these settings, I find that it runs slightly slower than usual speed. Are these the best configuration settings for my PC? My PC specs are:

Processor: Intel Pentium III, ~1.0GHz
Memory: 256MB RAM
Page File: 251MB used, 750MB available
DirectX Version: DirectX 9.0c (4.09.0000.0904)
Card name: NVIDIA GeForce2 MX/MX 400
Manufacturer: NVIDIA
Chip type: GeForce2 MX/MX 400

Also, I found the default spu ok so i did not add a plugin for it, but if there are any better ones, please feel free to add your suggestions.

Regards,
Tom
 

·
Registered
Joined
·
654 Posts
Suggest you use sssPSX instead of ePSXe.
Suggest you upgrade your GPU plugin to 2.7

If you turn on FPS display (Hit DEL while playing), do you see the framerate numbers stay below 59.9 for more than a fraction of a second? If so, your GPU plugin is using more juice than your CPU and gfx card have. The only thing I see that you could do in that case would be to turn off screen filtering. If the numbers don't dip, then you've got a timing problem and switching to sssPSX might help.

BTW, you can find my config here: http://forums.ngemu.com/plugin-ques...19-awesome-config-mgs-opengl2.html#post888789


Dan
 

·
Premium Member
bsnes, ePSXe
Joined
·
23,380 Posts
ok your computer is pretty crappy, not to mention i dont recommend playing MGS with OGL2 anyway.

use OpenGL, and under compatibility, try 2/2/0 and make sure you have the PC FPS special game fix on
 

·
Read Only
Joined
·
9 Posts
Discussion Starter · #11 ·
Ok, thanks for your advice guys, it took some time testing out all the functions, and I've managed to get a decent sound and now with a constant game speed (however, it's now a little too fast, but heh!). Here's my setup:

Plugin: Pete's OpenGL Driver 1.1.76
Author: Pete Bernert
Card vendor: NVIDIA Corporation
GFX card: GeForce2 MX/AGP/SSE

Resolution/Color:
- 640x480 Window mode
[32 Bit]- Keep psx aspect ratio: off

Textures:
- R8G8B8A8
- Filtering: 0
- Hi-Res textures: 0
- VRam size: 0 MBytes

Framerate:
- FPS limitation: on
- Frame skipping: on
- FPS limit: Auto

Compatibility:
- Offscreen drawing: 2
- Framebuffer texture: 2
- Framebuffer access: 0
- Alpha multipass: on
- Mask bit: off
- Advanced blending: on

Misc:
- Scanlines: off
- Line mode: off
- Unfiltered FB: off
- 15 bit FB: off
- Dithering: off
- Screen smoothing: off
- Screen cushion: off
- Game fixes: on [00000080]

********************************************

Plugin: Eternal SPU 1.4

Audio device:
- Direct Sound
- Buffer size: 64

Audio out method:
- SPUasync
- Async mode: Smooth

Special game fix:
- Update before accessing registeer: off
- SPU IRQ-Wait CPU action: on
- SPU IRQ-Force interruption flag7: off

Misc:
- Show realtime config window: off
- Wait for XA buffer is free: off
- Cache VAG decode: off
- Fine tune: 0
- Rec option: REG write: on, DMA write: on
- Reverb: Neill's


Again, thanks.
Tom
 

·
Read Only
Joined
·
9 Posts
Discussion Starter · #13 ·
Ok, I looked at my settings and changed my spu's buffer size to 30, like urs (mine was originally 64), but has no noticeable effect so i changed it back. I checked my framerate when running it and it's at a constant 25! I think this is as close as I can get considering how crap my pc is!

Thanks for all your help man :thumb:
Tom
 
1 - 17 of 17 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top