Next Generation Emulation banner

1 - 7 of 7 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1 (Edited)
:Video:

Plugin: Pete's OpenGL2 Driver 2.6
Author: Pete Bernert
Card vendor: NVIDIA Corporation
GFX card: GeForce FX 5500/PCI/SSE2 (256Mb)

Resolution/Color:
- 1024x768 Fullscreen - NO desktop changing
- Internal X resolution: 2
- Internal Y resolution: 2
- Keep psx aspect ratio: off
- No render-to-texture: off

- Filtering: 0
- Hi-Res textures: 0
- TexWin pixel shader: off
- VRam size: 128 MBytes

Framerate:
- FPS limitation: on
- Frame skipping: off
- FPS limit: 60

Compatibility:
- Offscreen drawing: 1
- Framebuffer effects: 2
- Framebuffer uploads: 1

Misc:
- Scanlines: on [0]
- Mdec filter: on
- Screen filtering: on
- Shader effects: 0/1
- Flicker-fix border size: 0
- GF4/XP crash fix: off
- Game fixes: on [00001000] (Odd/even bit hack)


:Audio:

Eternal SPU Plugin 1.41
- Enable Sound: on
- Enable CDDA Sound: on
- Enable XA sound: on
- Enable SPU IRQ hack: off

Audio Device:
- DirectSound
- Bugger size: 35

Audio out method:
- SPUasync
- Async mode: Smooth

Misc:
- Show realtime config window: Off
- Wait for XA buffer is free: On
- Cache VAG decode: off
- Fine tune: 0
- Reverb: Neill's

Special game fix:
- Update before accessing register: off
- Wait CPU action: on
- Force interruption flag7: off


My current PC configuration:

ePSXe v.1.5.2

2.6GHz Intel Celeron
256Mb DDR RAM

Realtek AC97 Audio

52x32x52 CD-RW
DL DVD-RAM RW/CD-RW

:--------------:

So, with all that out of the way, on to the problem at hand. Nearest as I can figure, this is the only problem with Metal Gear Solid that I'm having on ePSXe so far. I have the NTSC original PSX disc set, 2 CDs, I have regular CD copies I've made, and I've tried an Image resource from Hard Disk. So far, nothing has fixed this problem.

At certain points in the game, four that I've counted so far:

- After selecting a Memory Card to load from
- Switching to CODEC screen (select)
- Reaching a goal in VR training
- Before any "blur" effect in a cut-scene

At these points, the game will lock up temporarily, 5-10 seconds, at which point the visual freezes, and the audio loops the last half-second it had processed (think broken record player, etc). After these ten seconds are up, the game resumes as normal, until it runs into another one of these events.

I've tried the P.E.Op.S audio driver as well, with similar settings to no avail. I've tried different special game fixes, removing the one fix I have on, have tried scanlines off, automatic FPS limit detection, etc, etc. All to no productive end.

I haven't tried switching video drivers altogether, mostly because I don't recall having any driver that has supported MGS as well as the OpenGL2 has, save for the current problem.

I mean, I guess it isn't any huge deal. It's more just an annoyance, since whenever it happens, I'm not really in any point that the temporary freeze could get me killed, but I'd rather not play through the game with it. So call me picky.

So, any help would be appreciated. If you require any further information, please just let me know. I'll try my best to provide what I can.

Also, sorry if this has been brought up somewhere before. I checked around as best I could, but didn't find any topics related specifically/generally to my problem... If it has been posted elsewhere, and has a solution there, let me know.

Thanks alot. ^_^
 

·
Premium Member
Joined
·
3,093 Posts
a 5500 isn't a very strong card, maybe you should try lowering the internal x or y resolution (or both). Anyway, it's weird to me that you have this problem. Are your sound drivers up to date? Also, try with psxeven.
 

·
Registered
Joined
·
5 Posts
Discussion Starter #3
Lowering the resolution did very little, and any benefit was offset by the graphic loss, which in my opinion, is worse than the jumping.

I'm aware my card isn't top-market, but surely it should be powerful enough to support Metal Gear Solid on ePSXe. I can run the PC Halo at full video capability without any problem. >_>

I'm aware that emulation and PC ports are entirely different... But the card itself, I think, is powerful enough to support most any video requirement.
 

·
Premium Member
Joined
·
26,303 Posts
The OpenGL2.x plugin eats a hell of a lot more graphics power than Halo PC. I could run Halo happily on my old geForce 3. That card hated OpenGL2.x

Things to try:
  • Lowering the internal X/Y resoloution. 2 isn't really as effective anyway unless you are running in 1280x960 (as IIRC that's what it upsamples it to)
  • Enable 'No render-to-texture'. This can increase performance on lesser powered cards
However, your problem doesn't appear to be the raw speed, but rather the settings. From what I gather, Framebuffer effects pause before starting. Setting Framebuffer Uploads to 2 should solve this problem, but will put more stress on yuor machine accross the board.
Basicaly, instead of waiting for FB effects to be called and initialising appropriate settings when detected, these settings will emulate FB effects all the time, removing the lag associated with them.
 

·
Registered
Joined
·
5 Posts
Discussion Starter #6 (Edited)
I lowered the Internal Resolution on both X and Y to 1, and enabled the No Render To Texture feature. I also did set the Frambuffer Upload to 2, and it seems to have helped with the cut-scenes.

Now, however, whenever it has to load a new area, (Ie: Vent shafts, outdoors from indoors, etc) it skips a few times, much like previously. This might just be a loading issue with the CD, I'm not sure, I'll try an image file and see if it helps. Most of the other small glitches are livable.

Thanks alot, guys. I'll keep you updated. :p
 
1 - 7 of 7 Posts
Top