Next Generation Emulation banner

1 - 20 of 30 Posts

·
PS2 PAL[v9], PS3Slim PAL
Joined
·
5,370 Posts
Discussion Starter #1
as in topic... installed it, but... i can't see anything in game (no textures? or one color textures) had anyone simmilar problem? I've dx9.0c instaled and forceware 61 :/ my pc specs below (signature)

please help and... thx in advance
 

·
Registered
Joined
·
1,117 Posts
yep i have this problem too, try using older drivers because as always the companies are trying to "optimize" their drivers for new benchmarks and new games (mostly benchmarks), so they forget the old games, if you wanna play this game so bad get a PS2 or use older drivers.
 
S

·
Guest
Joined
·
0 Posts
with old drivers, there was a different issue....Raziel had a solution for that; lower the graphic quality a little; who knows, might work with these new drivers as well.
 

·
Super Moderator
Joined
·
6,283 Posts
Actually, this bug was introduced in the 60.xx drivers, it works correctly with older releases, if you want to see something with the 6x.xx drivers, you have to set the model quality on the minimal setting.

I did a bug report to nvidia and they replied that they'd fix it in a future release, so it'll get fixed eventually.

Oh, and it seems it only affects FX cards.
 

·
Registered
Joined
·
5,442 Posts
Got the game few days ago. Finished it recently. There was one particular version of forcewares that didnt gave correct textures but the rest work fine on my mx440SE.(Currently using 53.03)
 

·
PS2 PAL[v9], PS3Slim PAL
Joined
·
5,370 Posts
Discussion Starter #6
shame on me that I fogured it out so late with so much experimenting ;), I've messed up in gfx card settings and also in MGS2S setting and... it works :D posting my current CFG (gonna tweake it more anyway)

thx for your help guys

but I have another issue, maybe not because of the game, but it complicates it a little bit, I've a 1 day old instalation of my win XP, then when I install my psx to pc usb adapter connect dual shock I can't access the 'game controllers' in control panel, also MGS2 doesn't want to start :/ gonna think about it

EDIT: still on forceware 61.xx the newes 68.xx make my pc reboot infinitely oO (!!!WTF!!!!)
 

·
Irregular User
Joined
·
3,186 Posts
try downloading RivaTuner (www.guru3d.com)
install it and disable the Pixel Shaders in the DirectX tab
with the Pixel shaders disabled, the game will run fine even with all the graphics options on,in my case the shadows are showing now and some of the missing special effects are present.
BTW, remember to put back the pixel shaders back on if yer not playing MGS2.
 

·
PS2 PAL[v9], PS3Slim PAL
Joined
·
5,370 Posts
Discussion Starter #8
good idea, thx viperxtreme gonna try to tweake it that way :) btw, isn't it funny that MGS2S with those pixel shaders ennabled looks like a game (p.s. one) which is running on a gfx card that doesn't support p.s. :D
 

·
InnarX
Joined
·
2,756 Posts
Dude, what the hell are you talking about?

tw, isn't it funny that MGS2S with those pixel shaders ennabled looks like a game (p.s. one) which is running on a gfx card that doesn't support p.s.

If you're refering to your GeForce FX 5200...it does have pixel shaders.....anyway, glad to see it's working...b.t.w, you might wanna try installing the patch for the game (even try the ATi Patch and experiment with that).

r2rX :p
 

·
PS2 PAL[v9], PS3Slim PAL
Joined
·
5,370 Posts
Discussion Starter #11
ready2rumbelX said:
Dude, what the hell are you talking about?

If you're refering to your GeForce FX 5200...it does have pixel shaders.....anyway, glad to see it's working...b.t.w, you might wanna try installing the patch for the game (even try the ATi Patch and experiment with that).

r2rX :p
yes I know that it has pixel shaders but that bug makes MGS2S look like NFS:underground run on TNT2 card :p

3x3cUt0r try those setting which I've posted earlier, maybe it will work (still playing with those, Pixel shader enabled) :) good luck
 

·
Registered
Joined
·
7,836 Posts
Hey, sorry to revive this thread,
but I started playing it yesterday and got the problem too, I'm using the 78.** drivers. The pixel shaders trick works, but when I want to switch back to
pixel shader 3, it asks for reboot (also, I believed it cancelled my softmod :s)

Is there any way to do this with reboot? Reloading the driver also works, but not everytime :s
 

·
Registered
Joined
·
7,836 Posts
Disabling shaders work instantly, but re-enabling them requires a reboot, or reloading the driver (which is much faster)... anyways, I just found out that putting Model Detail to level 2/4 fixed the bug, though it doesn't look as good.

Konami just sucks at making ports. SH2 was the best they made, SH3 had some minor issues with menus, SH4 was horribly ported... now MGS2, that doesn't
even have an Exit button in the game menu. To quit, you must press Esc,
then it's supposed to minimize the game so the "Are you sure you wanna close?" box appears on the desktop... they just didn't bother checking if minimizing the game worked fine :( (it works only 1 time out of 5 with me :p)
 

·
Registered
Joined
·
24 Posts
There is a way to fix this what you need to do is the following:

1. Install MGS2.
2. Install the ATI 2.0 patch.
3. Find the files mgs2.exe and mgs2_sse.exe within the directory where the game was installed.
4. Backup a copy of each of these original files!
5. Open mgs2.exe with a hex editor... Frhed is a nice free utility that will suffice for this job: http://www.kibria.de/frhed.html
6. Look for the string RADEON, which starts at the following offset: 0x5f6e44.
7. Replace RADEON with ALL-IN. Don’t add or subtract anything else
8. Save the file.
9. Repeat steps 5-8 for mgs2_sse.exe. Note: this might not be necessary; on my system, Metal Gear seems to only use mgs2.exe… also, the hex offset will be different, but it’s easy to find by analogy.


Right, now you will need to follow the instructions but do a couple of things differently. At point 6&7 instead of replacing "RADEON" with "ALL-IN", replace it with "GeForc". Note the capital G and F and no e on the end. Near (right next) to where it now says GeForc, there will be the string "GeForce" (this starts at 0x5f6e4c in mgs2.exe and 0x5fd83c in mgs2_sse.exe). Replace "GeForce" with anything else as long as it has the same number of letters. The game will now use the Radeon graphics path on a geforce card and looks a hell of a lot better (tested on a GF 6800).
 

·
Pilgrim
Joined
·
9,687 Posts
Hey thanks for the info.
Will try that, 'cause I had the same problem and had to uninstall the game.

But, can you post screenshots of your game with your GF 6800, I would like to know how does it look to you.
 

·
Registered
Joined
·
7,836 Posts
Oh thx, I'll try ASAP, though it's lame that users must patch games themselves :p

EDIT: It works, but I don't see a difference in graphics with models now set to high... weird :p
 

·
Premium Member
Joined
·
8,586 Posts
Raziel said:
Oh, and it seems it only affects FX cards.
It also affects newer Nvidia cards as well. (6800/7800) Setting model quality to "low" clears it up and makes the game playable, but the water(sea) rendering is all screwed up and shadows hasn't worked in the game for the longest time.

I remember the game worked perfectly before on my fx5900ultra. But since I got my 6800ultra, the game has never worked(looked) totally correct.
 
1 - 20 of 30 Posts
Top