Next Generation Emulation banner

1 - 5 of 5 Posts

·
Registered
Joined
·
454 Posts
Discussion Starter #1
I just ripped Mario Kart Wii and it has a problem. When it loads, it stays on a black screen, plays some weird sounds and just sits there. It doesn't freeze, the fps still run, but none of the keys make it pass that screen. Please help me.

Thanks in advance,
~Why-Fi

EDIT: I followed the instuction on the official thread, disabled Progressive scan and passed that. Now it asks me for saving, and it can not save, so he stops there. I know I need a save. If someone could give me a full save (every character/stage) for Mario Kart Wii PAL I would appreciate. I could rip it, but my save isn't full save (not everything unlocked) so it's better if someone gave me. Yes, I had one full save before, but I deleted it, so don't be afraid: you won't spoil any gameplay for me.

Thanks in advance,
~Why-Fi
 

·
Mario Kart WII user**
Joined
·
107 Posts

·
Registered
Joined
·
454 Posts
Discussion Starter #3 (Edited)
Ok, thanks, I didn't look well, I looked again to John Peterson's thread and took his save. I thought the save was NTSC, but it is PAL, so I used it. Thanks, anyway.

Mario Kart Wii runs excellent, only a black square on what should be the map and full speed most of the time (except on big landscapes). There are some problems though:

- Music doesn't play after 3rd lap announcement and some sounds don't play or get cut (power-up rolette, for example);
- Commands are extremely unresponsive, and are missing the mini-turbo jump and the airborne stunts (on emulated wiimote, I don't have the proper device to connect my real Wiimote to the computer).
 

·
Mario Kart WII user**
Joined
·
107 Posts
on real wiimote this run fine.
but 15 or 20 min this no work(wiimote) (no panic or message error)
 

·
Registered
Joined
·
454 Posts
Discussion Starter #5
It's ok.

Wow, this is the first Wii game that runs at 100% speed for me (40fps). It runs great, yet unresponsive with the keys and the sounds. But the only problems this game has are the square thingy (not really important), sound-related problems and controller-related problems (that could be fixed if I had the bluetooth thingy to connect my Wiimote).

One interesting thing, idleskip seems to have come back in rev 1500, it was disabled in previous revs for some reason. This helps with speed a lot.

Another thing, John says the game is playable with the GC controller if using njoy, but that doesn't allow keyboard commands. If someone can tell me if there is any way for njoy to support keyboard, please tell me. ;)

Thanks in advance,
~Why-Fi

P. S.: Soon you'll be getting some screenshots either here or on the SVN Shots thread. Yay! :D
 
1 - 5 of 5 Posts
Top