Next Generation Emulation banner
Status
Not open for further replies.
1 - 14 of 14 Posts

·
Registered
Joined
·
26 Posts
Discussion Starter · #1 · (Edited)
k so first off heres my setup : AMD dual core CPU + 2gb RAM + ATI radeon 1950pro (256mb VRAM) inc. pixel shader 3.0 support

so any grafix prob cant come from MY setup :p


ok now the prob is simple :
Ecco the Dolphin (defender of the future) launches without problem & framerate is smooth (so thats not the problem :D)
BUT it has horrible graphics glitches that make the game almost unplayable

btw I use nullPVR, not chankast plugin ;)

heres the prob : basically there are "discolored squares" that appear wherever edge of water touches solid object, of when theres splashes :eek: for lack of better words I include pics :

http://img15.imageshack.us/img15/1293/89926697.jpg (upper right : where water touches the rocks)

http://img24.imageshack.us/img24/9641/50945899.jpg

http://img8.imageshack.us/img8/4928/12889182.jpg

http://img8.imageshack.us/img8/1715/60184089.jpg

now Ecco is on nullDC list of compatible game (green), so this is also to warn u folks :
this is not true, Ecco is NOT fully compatible with nullDC
other games could be similarly affected as well ;)


oh yeah 1 more thing : this prob is definitely nullDC-related because Chankast does NOT have that particular bug ;) (water is rendered 100% fine)
however Chankast has other grafix bugs with that game (like almost zero draw distance) that are even worse, so I dont use Chankast :eek:
I also tried various windows Direct3D settings as well as updating my drivers (like that ever helps :rolleyes:)

edit> and yeah I tried all the emulator video settings inc. strip/triangle/whatever settings too


so basicaly there are no emulators that play Ecco 100% correctly so far :(
which is a pity, becoz Ecco is one of the most popular DC games :( :(





PS. this is an extremely strange problem as most of the water does seem to render fine. the bugs are severe enough to make game unplayable though

Im also convinced that this is not supernatural problem so theres got to be rational explanation to this and Im confident the nullDC developers can figure it out :D
 

·
Registered
Joined
·
26 Posts
Discussion Starter · #5 · (Edited)
Did you try changing sorting option? Try per Triangle, then Per Strip.
yup (even turning it off)

trust me if Im posting here then it mean Ive explored every nook & cranny I could think of, every video option in Windows or in the emu itself. fiddled with various cpu settings too

this has to be a nullDC problem since even Chankast - a far more primitive emulator - doesnt have the glitch (not that particular one anyway) ;)

I also updated my video drivers (though everyone knows thats just a "formality" which never helps) and even tried replacing nullDCs plugin .dll with that of an older version (nullDC didnt recognize the old file)



the squares invariably appear right @ start of game (1st pic in my post, opening cutscene)

btw I dunno if this could help but during that scene the glitch doesnt appear immediately (it only appears about 1 second after the cutscene begins)



any idea what this sort of thing is due to? how come those squares only appear in some spots but the rest of water looks intact?
(also Eccos bubbles look normal when they rise but then they become squares when they hit water surface)



/!\ one more thing : I said Chankast doesnt have that particular glitch, however the glitch still appears in nullDC even if I switch to the Chankast plugin!!!!!! /!\
 

·
Premium Member
Joined
·
2,299 Posts
Dunno, this kind of problems generally occur because of limits that have to do with Z-Buffering.

Try using a different Z-Buffer mode and changing paletted textures. Try various combinations.

Also, make sure you're using the latest version of nullDC (v1.0.3).
 

·
Registered
Joined
·
26 Posts
Discussion Starter · #7 ·
I am using 1.0.3 ;)

I tried various options inc. for the buffer thing from slowest to fastest settings, no avail (also if its got something to do with "depth" how come most of the water renders ok & only some spots are messed up ?)

but theres no "palette" option in the emu iirc
unless u mean in Windows
but if it were a Windows prob then Chankast would also have the same glitch right ? yet it doesn't
 

·
Premium Member
Joined
·
2,299 Posts
Well, depth management is tricky and lots of things can go wrong. Depending on what each game does some parts of it might look wrong while the rest game looks OK or the whole game might be messed apart from a few spots.

nullPVR has an option that lets you choose how paletted textures are going to be handled (static, versioned, dynamic point and dynamic full). Try switching between them on all Z-Buffering modes. A specific combination might fix the issue, or might not... who knows. :p
 

·
Registered
Joined
·
26 Posts
Discussion Starter · #9 ·
nullPVR has an option that lets you choose how paletted textures are going to be handled (static, versioned, dynamic point and dynamic full). Try switching between them on all Z-Buffering modes. A specific combination might fix the issue, or might not... who knows. :p
ok that setting
yeah tried that too (all settings from dynamic-full to static) as well as all the buffer settings

not sure if I tried all the combos tho (with like 5 settings for each that would be many combos to try :()
 

·
Registered
Joined
·
4 Posts
need help here im pulling me hair out ok i got a few cdi's of ecco but none seem to work i just the the spinning disc screen like when u play music iv tried all region bios settings ect i think its a bad dump so i downloaded a few more but every one i try i get the same no matter wot bios i use or wot version of the cdi of the game still get the same effects the spinning disc screen and all my other games work strait away :(
 

·
Standing by...
Joined
·
59 Posts
You hijacked another person's thread and admitted to downloading illegal copies of the related game. I really don't think I need to clarify where I'm going with this.

Pulverizor, have you tried previous versions of the emulator? Perhaps you may have better luck with BETA 1.6.
 

·
Snuff the rooster
Joined
·
87 Posts
Not to hijack this lol,but I also see some related problem to the one he is having,albeit its in Shenmue tho and it happens on the trees,they appear to be very squared in the foliage.Any ideas?
 
1 - 14 of 14 Posts
Status
Not open for further replies.
Top