Next Generation Emulation banner

1 - 10 of 10 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter #1
Just playing some more and I have realized that fullscreen mode doesn't work. It changes my desktop resolution, but it doen't center on in epsxe nor make it cover the whole screen.. I am using XFree86 4.3.0 on Debian sid.

Thanks, any tips are welcome.
-r
 

·
Registered
Joined
·
9,504 Posts
Try and set the same resolution and color depth in the plugin as you have on your X server. For example, if your X server resolution is 1024x768 and 32 bit color, then set that the same for the fullscreen plugin options. This saves the hassle of X resetting the monitor to go to a lower resolution and possibly screwing stuff up.

btw, what plugin and video card are you using?
 

·
Registered
Joined
·
7 Posts
Discussion Starter #3
Yeah setting the res to the same as the X server would indeed fix it but it takes a hell of alot more time rendering it for 1280x1024 than say 640x480.

I've tried Pete's Soft plugin, and the XGL2 plugin.. Same problem. I have a GF4 MX440 64M. Yeah, it sucks but it's what I got. :)
 

·
Registered
Joined
·
9,504 Posts
well that's good your not a total n00b if you got Debian installed with a window manager :p

did you install the NVIDIA GLX drivers correctly?
 

·
Registered
Joined
·
7 Posts
Discussion Starter #5
Haha, far from it :)
I'm a developer, and an in-progress debian devel :)

Anyways, yeah, NVIDIA GLX is all setup. Glxgears runs as expected.. I got Mupen64 running fine, with fullscreening and working support for my joystick.. I could care a lil less about the fullscreening issue right now :) I just wish my joystick wouldn't be so sensitive (referencing another post you gave me advice on)

Thanks :)
 

·
Registered
Joined
·
38 Posts
Why the hell do you use XFree86 for? Why not just stick with the trad Xorg? Mucho mucho more stable and faster than XFree, though not always faster.
I am using Xorg 6.8.99 from CVS and fluxbox. Lightweight and fast.
But I guess I'm not to teach you the basics of *NIX. Rather, you could teach me some. But also, wth are you doing on SID? I had it, but it was WAAAAY too unstable. Even after some good config tweaks...
For now, I'm just sticking with my Gentoo & Woody 3.0R3
;P
 

·
Premium Member
Joined
·
3,093 Posts
Please, do not revive old threads just to promote your preferred software. It is seen as bad practice on this forum.
 

·
Registered
Joined
·
1,168 Posts
The emu can only switch to 640x480 if you have a corresponding "Modes" line in your XF86Config[-4] file.

Code:
Section "Screen"
    Identifier "screen1"
    Device "device1"
    Monitor "monitor1"
    DefaultColorDepth 24

...
    Subsection "Display"
        Depth 24
        Virtual 1280 1024
        Modes "1280x1024" "1024x768" "800x600" "640x480"
    EndSubsection
...
EndSection
 

·
Registered
Joined
·
1 Posts
Fullscreen mode only works correctly if your desktop is the same resolution that is set for the plugin. To work around this, you can write a script to change your resolution to the required setting for using epsxe and then change it back automatically when you quit.

I have my desktop at 1280x1024 and want to use epsxe at 800x600 in fullscreen. I selected 800x600 fullscreen in the plugin configuration and then I use the following script to run epsxe.

Code:
#!/bin/sh

xrandr -s 800x600
/path/to/epsxe "[email protected]"
xrandr -s 1280x1024
WARNING: By using this script incorrectly, it is theoretically possible to damage your monitor by selecting a resolution that it cannot display. Please read the xrandr man page!

Hope this helps everyone with this problem.
 

·
Wind, Life, Eternity
Joined
·
1,331 Posts
Um... funny how there's already a "do not revive old thread" post in this thread.
Anyway, maybe your info is of help (unlike the other reviver), but I don't know linux :p
 
1 - 10 of 10 Posts
Top