Next Generation Emulation banner
1 - 20 of 20 Posts

·
Registered
Joined
·
17 Posts
Discussion Starter · #1 ·
Hey guys, I need some help figuring out how to fix my problem. And I have looked at every dragoon topic I can find. Basically my sound is glitchy where right before the attack ends it cuts off or is replaced with another sound a little late. And sometimes at the same time the video goes black temporarily. Also when engaging in battle, the part where the screen is supposed to shift down like sand goes completely black until the battle begins. There is alot of other stuff but I can't think of it at the top of my head.

The thing that is irritating me the most is during the scene where Dart is fighting Kongol for the first time, I finish the fight and dart is about to get finished off and Rose in dragoon form hits him a couple of times. During this entire seen I get no sound and no music. I know how its supposed to be because I own the game, just to scracthed up to play with it. I've used every setting I've seen that supposidely makes it better but nothing has worked. Right now I'm just using default settings for sound ePSXe SPU core 1.5.2. first three options checked. And video Pete's D3D Driver 1.76

If there are any details anybody would like to know to solve this problem please ask. This is driving me insane, I just want to play the game the way its supposed to be.
 

·
Emu Author
Joined
·
616 Posts
first, your pc specs would help, second i recommend using eternal spu plugin, also just covering bases based on my experiences, if using pec by any chance, during cut scenes, turn it off, i have some games where sound cuts out when pec is enabled. also with eternal, try a buffer size of 22, works great for me.
 

·
Registered
Joined
·
17 Posts
Discussion Starter · #3 ·
my pc specs? I use a Power Spec computer with NVIDIA GeForce FX 5500 game card. Not sure what other specs i'm supposed to put.

Also I've already tried many plugins and settings. eternal was one of them, I believe I tried two versions. What is pec? is that an option on the sound's configuration menu? I'll try the buffer 22 on eternal.

Tried eternal with buffer 22. No change.
 

·
No sir, I don't like it.
Joined
·
7,022 Posts
Use Eternal SPU for sound and set the buffer size to 40.

Use Pete's OpenGL2 for graphics and set the frame buffer options to 1,3,2.
 

·
Banned
Joined
·
35,081 Posts
use 1.7.0 and the opengl 1.7x plugin.
 

·
Registered
Joined
·
17 Posts
Discussion Starter · #10 ·
Okay I've tried masta's settings, and all the sounds and video's worked during the battle!!! I don't know about the shifting sand of the screen part when you enter battle but this is a start. Unfortunatly during the short video of Dart's transformation gave no sound at all again. I'll dowload 1.7.0 now, hope I can find it.
 

·
Registered
Joined
·
17 Posts
Discussion Starter · #12 · (Edited)
Thanks, I had just found that particular address right before you listed it for me lol.

Wow I downloaded 1.7.0 and it worked wonders!!! The whole scene now works. Unfortunatly the video blacked out once during the scene, and during the battle it blacks out alittle bit and the sound cuts off again. And when they are just standing around talking the sound cuts off also. But this is still great though. I did this under default settings with cdrom: epsxe CDR WNT/W2K core 1.7.0 (for some reason my epsxe CDR ESPI core 1.7.0 had an error running WINASPI32.DLL), video: Pete's D3D Driver 1.76,
sound: espxe SPU core 1.7.0

I'm about to retry masta's settings again, it may make a difference. If his don't work I'll try squalls setting.

Nope masta's settings made it much worse. alot slower and it cut down on sound and music. How do I get to squalls setting of opengl 1.7x plugin?
 

·
No sir, I don't like it.
Joined
·
7,022 Posts
Link

Follow the link and download Pete's OpenGL and P.E.Op.S. OpenGL.

Also, there's a special game fix for Legend of Dragoon listed as 'LoD' under the special game fixes section of the OpenGL2 plugin. Might want to try turning it on.
 

·
Registered
Joined
·
17 Posts
Discussion Starter · #14 ·
Oh boy its almost fixed. But it still glitches in places. When anyone finishes a combo it kind of lags and the screen gets stuck inbetween the second and third attack then it goes on and finishes the combo and they say it out loud. Also during the scene with kongol and rose it goes black with P.E.Op.S. Open GL and with Pete's OpenGL it stays stuck on one part of the scene for a second but you can tell there is something going on behind it.
 

·
Registered
Joined
·
19 Posts
Hey I had the same issue with the sound cutting out during the cut scene at the first Dart/Kongol battle. I was using pec too, on epsxe 1.6.0. My regular sound after the cut scene was cut out too. I just went asap and saved to memcard, exited emu and reloaded and everything was back to normal.

The same thing happens after the Lenus/Regole battle at the end of disc 2. Same behavior after the battle, same solution.

I have epsxe 1.7.0 now, so if the issue happens again on 1.6.0 I'll try it on 1.7.0. I can't do it now because my only saves are disc 3 or later.
 

·
Registered
Joined
·
3 Posts
Hello, Just signed on because this was the only thread covering my problem. My video and sound are fine EXCEPT for the cutting out of the "voiced" addition name, if it kills the enemy then it gets cut off (e.g. Dart kills an enemy with Crush Dance, but all he says is "crus" and gets cut off by the "monster dieing" sound.

I am using both version 1.6 and 1.7, and have used ALL the settings and plugins suggested here, but to no avail, even the settings nad destroyer said worked for him, do not work for me.

I have no video problems, just this one sound issue. currently using openGL, and eternal 1.41 as my plugins. I have even tried other versions of the file (using an .iso, also tried .bin, and mounting the image but to no avail).

My comp runs Vista Home Premium 32bit, 2.4Ghz AMD Phenom, ATI Radeon HD 4850 graphics card, but crappy realtek audio (I updated the drivers).

Any advice is welcome.
 

·
Registered
Joined
·
19 Posts
@Sain: I don't have that problem, my LoD emulates perfectly except for those 2 spots where the sound cuts out (Dart/Kongol @ Hoax, Lenus/Regole @ underwater cavern).
My sound settings are:

Eternal SPU 1.41

DirectSound, buffer size = 64
SPUasync, async mode = smooth
Show realtime config window: UNchecked
Wait for XA buffer free: grayed out and CHECKED
Cache VAG decode: UNchecked
fine tune = 0
Reverb: neill's
Special game fix:
Update before accessing register: CHECKED
SPU IRQ - wait CPU action: CHECKED
SPU IRQ - force interrupt flag 7: CHECKED

Try that and see if it helps. As a rule of thumb, I've found that most fixes needed to make FF games work right are needed by LoD as well.

Hope that helps.
 

·
Registered
Joined
·
18 Posts
holy balls i'm glad i found this thread and a handful of others like it. My sound started cutting out around the third disc, where the voiced additions they'd be all choppy and say half the attack, like "Burning ru--". Noteably, right after dragoon lenus dies the sound is completely gone. I luckily saved to memcard right before it.

When I had to restart my game, I used frameskipping to blow past a lot of boring talking I already saw to catch back up to where I was. It only made the problems worse and happen much sooner. From all the posts I've read, I can see that actually can cause problems with the spus.

Can anyone sort of explain the mechanics behind that? WHY does it do that?

btw, I cleaned out my registry for ePSXe and switched to PEOps DSound Audio Driver 1.09a. and aside from the sound quality being a little lower, everything works fine. I'd like to use the newer versions as someone posted the links to them but both say the file is no longer there <_<.
 
1 - 20 of 20 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top