Next Generation Emulation banner

Legend of the Dragoon hellllpppppppppa

2136 Views 14 Replies 9 Participants Last post by  Beramode
how do I Play Legend of the dragoon with EPSXE i've tried almost everything even with petes plugin', even with the "alphapass" can you help pleaseeee
1 - 15 of 15 Posts
Hey, stop whining, geez
Do a search on the boards under Legend of Dragoon or Lod and you will find your answer.
Software rendering does just fine. (You have to disable frame-skipping). Problem is, not many people who have those mega-fantastic-superb-awesome 3D accelerators like it... I actually do because it's more true to the actual PSX, but that's the only thing I can actually use with my system ;)
what version of the bios are you using? version 1000 and 1001 doesn't work well with LoD, make sure you have a PSX with 7001 and use a gameshark or dexdreive to make a image of it, no illegal copies, right :0
finally i get in.....yeesh....i duno wut i did but my hotmail's was banned.. and dragoon works with epsxe my graphic plugin is kazzuya Spftware driver(beta) 1.6 ...

my comp-> win98(soon XP), p3 500mhz, 256mb ram, creat 3d blaster savage4
In order to get worknig legend of dragon, you need to use the correct bios for every country version. It means 1001/7001/7501 .. for US version, 1000/7000/7500 for JAP version (not sure about it ;), 1002/7002/7502 for PAL version.

whoa!! Its one of the epsxe authors themselves!! Now you gotta say wow to that.. Not only do they make one helluva psx emu, they help people with problems too!!

BTW.. Thank you, calb and the rest of the epsxe team..
pls. be specific w/ ur prob and some 1 mght try & help you.:)
I'm having trouble with Legend of Dragoon (US version) also. I'm using the 7001 bios. The screen goes black, and that's about it. With the 7502 bios I got the Sony screen to come up before it stopped working. ~_~ I've searched through the other threads about Legend of Dragoon and tried the suggestions there, but none of them seem to be working for me.

I'm using a pIII 450, 128MB RAM, Win2000, NVIDIA GeForce 2 MX 400 and Pete's OpenGL Driver 1.53 for ePSXe's video driver. Any suggestions?
make sure your CD drive in epsxe is set up properly, make sure you specify the actual letter of your CD drive, sounds like thats your prob
I have it set to my D drive with the ePSXe CDR WNT/W2K Core 1.4.0 cd-rom plug-in. I don't know if I need to change my plugin or not (worked great for FF9), but I am using the D drive.
Okay, I tried that and tried playing with the configuration of it and got the same result each time. Still just a black screen.
have you tried ripping the CD and using it as a iso yet?
1 - 15 of 15 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.