Next Generation Emulation banner
1 - 1 of 1 Posts

· Extra Large Member
936 Posts
Discussion Starter · #1 ·
All of a sudden my other keyboard started spewing out "8"s every time I hit , or ' or l or a few other keys (but not every key, and not when I hit the actual 8 key). I plugged in an old keyboard and that worked fine. I then plugged the faulty one back in and it's still doing it. I have tried tapping the 8 keys (both the normal one and the one on the numpad), to no effect. It is acting like the 8 key is stuck, but it isn't. Any ideas what's going on?

Note: I suspect it's connected to the 8 key in the numpad. It first started when I used that key. I tried turning off numlock, but that just changed the problem (I suspect it started sending the "up" signal instead of the 8 signal).

Any suggestions as to how to get the keyboard working? It's only a month old. I already tried popping the 8 keys off and looking for dust or debris, but there was nothing.
1 - 1 of 1 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.