Next Generation Emulation banner

1 - 20 of 25 Posts

·
Premium Member
Joined
·
21,977 Posts
Discussion Starter #1
i can easily use japanese in Firefox, MSN messenger, MS Word, etc., but i cant in Winamp or Explorer (i.e. file names). is there any reason for this? anything i can do? i have US English operating system and i have the language bar set to japanese.

whenever i type a japanese file name i just get those squares, like an invalid character. my guess is that it's not specifying what font for Windows to use when i'm typing in japanese. is there somewhere i need to set "default japanese font" in XP that i've overlooked?
 

·
Registered
Joined
·
254 Posts
I knew that in winamp japanese is't showed at all, but i can normally use japanese filenames in explorer (see screenshot).
I don't know if you've ever heard of this program (i fonud it some weeks ago, never knew of its esistence,but it would just be me :D ): applocale. It lets you run japanese software without setting the OS language to Japanese :thumb:,it can be useful.

-DeathPenalty
 

·
Premium Member
Joined
·
21,977 Posts
Discussion Starter #3
hmm, that's not exactly what im looking for...im looking for something that will display a japanese font when i type. example, your folders have Tahoma as the english and a nice looking font as the japanese...i can get it to only do one or the other. see the pic for an example; the japanese text looks decent (just MS Mincho...the fonts that i want to use wont show up in the XP list oO ) but of course the english versions of it suck...and it wont show up in the title. i can either have it looking like that, or i can have it only in english :|
 

·
Wind, Life, Eternity
Joined
·
1,331 Posts
Maybe you should set system language back to English. Most programs (including Firefox, MSN messenger, MS Word) works with other languages even if your system language is set to English (messenger has minor problems though).
 

·
Registered
Joined
·
1,577 Posts
Hushy: Qute is available now y'know. ;)
 

·
Premium Member
Joined
·
21,977 Posts
Discussion Starter #6
WindHydra said:
Maybe you should set system language back to English. Most programs (including Firefox, MSN messenger, MS Word) works with other languages even if your system language is set to English (messenger has minor problems though).
my OS is in English :p my problem is that i want to have japanese characters in my filenames.

scottlc: the regular Firefox skin looks just fine, thanks, it's clean and simple already ;)
 

·
Wind, Life, Eternity
Joined
·
1,331 Posts
Did you try using a default theme? Maybe the fonts used by your theme doesn't support other languages.
 

·
Premium Member
Joined
·
21,977 Posts
Discussion Starter #10
well you have to install the japanese language pack, for one ;) www.microsoft.com has it somewhere, you also need your XP disc IIRC...you probably have to mess with the language settings in Firefox too, i dont know, i dont want to mess with it now because it already works
 

·
Registered
Joined
·
1,577 Posts
hushypushy said:
well you have to install the japanese language pack, for one ;) www.microsoft.com has it somewhere, you also need your XP disc IIRC...you probably have to mess with the language settings in Firefox too, i dont know, i dont want to mess with it now because it already works
Once you enable asian language support in Windows, Firefox needs no additional setup.
 

·
Premium Member
Joined
·
6,338 Posts
Have you tried setting the unicode language setting to Japanese?
 

·
Registered
Joined
·
254 Posts
Are you sure your OS language is set to english? i see in your address bar the "\" character is not displayed correctly (well, you have some "¥"),and that happens to me ONLY when i set the language to japanese.
I can use both thaoma and japanese fonts without changing my default language, just by selecting japanese input metod in the language bar, then if i want to type some english words i just switch the imput back to english,that's all.
If i want to use some programs which need the os to be set to japanese i just use the program that i suggested you before,no need to change lnguage.
Try to go back to english default language, your english characters will go back to normal and you'll be able to type nice japanese fonts as well!try it.

-DeathPenalty
 

·
Registered
Joined
·
1,449 Posts
Go into control panel -->"Regional and language options".
Under "Regional Options" make sure the language is set to English.
Under Languages, check "Install files for East Asian languages." You may need to restart you computer.
Under "Advanced" make sure that "language for non-unicode programs" is set for Japanese.

After you do these things and restart your computer, you should now have the language bar on your destop or taskbar. Whenever you want to type in Japanese, press alt-shift, then select which alphabet you want to use (ie hiragana, katakana, etc) from the language bar. こにちわ
 

·
Premium Member
Joined
·
21,977 Posts
Discussion Starter #17
The Captain, that is perfect. everything works perfectly now, well winamp is having problems with the fonts, ill get that straightened out otherwise. どもうありがとうございます!
 

·
Premium Member
Joined
·
21,977 Posts
Discussion Starter #19
well, my system already is/was in english. what did it was the checkbox to install east asian languages.
 

·
Banned
Joined
·
177 Posts
I heard the Japanese OS can use English fonts alot easier than the English OS. Anyway I think 3rd party software will be needed "without hacking" if you are to display in explorer like you want.
 
1 - 20 of 25 Posts
Top