Next Generation Emulation banner

21 - 33 of 33 Posts

·
Fluffy Animal Admirer
Joined
·
3,398 Posts
WHAT? I never played H.H. in a real n64... whats wrong with it?
PJ64 has audio skipping issues every twenty or seconds, and in between these frames, the speed is perfect. Mystical Ninja 64 however, can run perfect with Glide64.
 

·
The Soul Reaving Gentleman
Joined
·
65 Posts
What about this?

http://www.emutalk.net/threads/53546-sneak-peek-pj64-1-6-1-hmmm

And this?


I remember Gent was working on Project64 1.6.1, but all of that seems dead now.

What happened?
Sorry to dredge up an old post but i thought i would reply to this. We suffered a huge blow back in 2012 where we lost all source and files due to a major server accident. This took everything we did with it sadly. Well lessons were learnt, work started rebuilding and our new website is http://project64.emulation64.com.

Sorry to post under this new account, but i have lost the email that the Gent account was under and could not retrieve my pass. If a Admin would find fit to assist me with that? that would be amazing.
 

·
Fluffy Animal Admirer
Joined
·
3,398 Posts

·
...
Joined
·
374 Posts
I COMMAND YOU TO RISE, RISE, RISE...

For those interested in a more recent version of this emulator, you can get one here.

Or use my own build with Visual Studio Community 2015.3:
Portable_Project64_v2.4.0-692-gf20dca31.7z

Code:
Size:  1902018 bytes

CRC32:  36307b12
MD5:  8421240cdd9d80a7b9308ffc6a665517
SHA1:  c7df43daf032599c8c222de11e85a2c283e93641
TIGER:  0199c8e7fb969cd379c900a30a3605ec5c0266074d61210f
SHA256:  f880d7528e2f5a29efa6d15888e070df81509417a6bdf81de056d74c4ef601a2
SHA512:  4c670ae000a6bec89f766f3fd6fbf4811ab6d435fcef5442ece3e93b41e26b2b0df0556623fe392970e160c98efe4b97ef069987f916df662fa2e33ebca9a59b
The emulator out of the box is crap, to change that I recommend the WIPs of angrylion's RDP Plus and GLideN64. Both are unfriendly to toasters...
 

·
Registered
Joined
·
2,167 Posts
u3L05 vh9jV, your build is ummm. a little unstable...geometry issues, donkey kong walks backwards then endless loops between almost starting and back (no matter which video plugin)...granted it is probably bugs in the source and not your build per-say


***EDIT***
May 23rd official build works fine
 

·
Registered
Joined
·
2,167 Posts
and whoa, this thing is hard to build with VS 2017..wants the 141_xp toolset...run it via cmd prompt to set the non xp tollset and it errors eventually 9 errors..
Code:
"y:\project64\project64-master\Project64.sln" (default target) (1) ->
"y:\project64\project64-master\Source\RSP\RSP.vcxproj" (default target) (3) ->
(ClCompile target) ->
  Main.cpp(54): fatal error C1083: Cannot open include file: 'Version.h': No such file or directory [y:\project64\proje
ct64-master\Source\RSP\RSP.vcxproj]


"y:\project64\project64-master\Project64.sln" (default target) (1) ->
"y:\project64\project64-master\Source\nragev20\NRage_Input_V2.vcxproj" (default target) (9) ->
  y:\project64\project64-master\source\nragev20\FileAccess.h(28): fatal error C1083: Cannot open include file: 'Version
.h': No such file or directory [y:\project64\project64-master\Source\nragev20\NRage_Input_V2.vcxproj]
  y:\project64\project64-master\source\nragev20\FileAccess.h(28): fatal error C1083: Cannot open include file: 'Version
.h': No such file or directory [y:\project64\project64-master\Source\nragev20\NRage_Input_V2.vcxproj]
  y:\project64\project64-master\source\nragev20\FileAccess.h(28): fatal error C1083: Cannot open include file: 'Version
.h': No such file or directory [y:\project64\project64-master\Source\nragev20\NRage_Input_V2.vcxproj]
  y:\project64\project64-master\source\nragev20\FileAccess.h(28): fatal error C1083: Cannot open include file: 'Version
.h': No such file or directory [y:\project64\project64-master\Source\nragev20\NRage_Input_V2.vcxproj]
  y:\project64\project64-master\source\nragev20\FileAccess.h(28): fatal error C1083: Cannot open include file: 'Version
.h': No such file or directory [y:\project64\project64-master\Source\nragev20\NRage_Input_V2.vcxproj]


"y:\project64\project64-master\Project64.sln" (default target) (1) ->
"y:\project64\project64-master\Source\Project64-core\Project64-core.vcxproj" (default target) (10) ->
  y:\project64\project64-master\source\project64-core\stdafx.h(10): fatal error C1083: Cannot open include file: 'Versi
on.h': No such file or directory [y:\project64\project64-master\Source\Project64-core\Project64-core.vcxproj]


"y:\project64\project64-master\Project64.sln" (default target) (1) ->
"y:\project64\project64-master\Source\Project64-video\Project64-video.vcxproj" (default target) (15) ->
  Main.cpp(18): fatal error C1083: Cannot open include file: 'Version.h': No such file or directory [y:\project64\proje
ct64-master\Source\Project64-video\Project64-video.vcxproj]


"y:\project64\project64-master\Project64.sln" (default target) (1) ->
"y:\project64\project64-master\Source\Project64-audio\Project64-audio.vcxproj" (default target) (16) ->
  AudioMain.cpp(23): fatal error C1083: Cannot open include file: 'Version.h': No such file or directory [y:\project64\
project64-master\Source\Project64-audio\Project64-audio.vcxproj]
 

·
...
Joined
·
374 Posts
I didn't really have much time to try my own build, and I have no incentive to try it out of my workplace.

The support for "???_xp toolset" is broken I think. See #1425 and #1429.

For your build error, look at #1454. You need have 'git' (CLI) in your "Path" environment variable and download the code with it, "Download ZIP" only make the compilation more troublesome.

  1. Simply open your "Developer Command Prompt"
  2. Open your build directory
  3. git clone https://github.com/project64/project64.git
  4. cd project64
  5. msbuild Project64.sln /t:Rebuild /p:Configuration=Release;Platform=Win32
  6. If the compilation ends well, search the setup (dir /s setup*.exe)
  7. Run the installer and generate a portable

That's all.
 

·
...
Joined
·
374 Posts
***EDIT***
May 23rd official build works fine
Portable_Project64_v2.4.0-687-g83b280f7.7z
Code:
Size:  1902933 bytes

CRC32:  78a0b7e1
MD5:  e26d98ae5e0971027a9ee794b2a82ccf
SHA1:  473e60dfb4ccbbcb03eab08ee44886b62671b075
TIGER:  79f4051c8cab078657f7e09eb3a0c45bc3f617a51e959147
SHA256:  c74dfdfef435dd163a80e689b249692b2f040c36d82aebc2a9dcb8a7f47fd0c7
SHA512:  90bbd529573db7311d0f390c18271ad4a66491ca4262408ef023507b64f625a1a0af4e6ea9e537b184f5448a514cf6be141b230386cb0edf4a93572e79350a97
This build is a bit older.

@dpence, would you please provide a savestate?
I can try to bisect the regression next Monday.
 

·
Registered
Joined
·
2,167 Posts
@dpence, would you please provide a savestate?
I can try to bisect the regression next Monday.
any particular game??...conker and donkey kong happen right after loading.. conker on the opening screen where he is sitting on the throne the character geometry is all over the place...same for donkey kong, the little musical thing is ok, but once you hit start it goes crazy
 

·
...
Joined
·
374 Posts
I could not replicate your issues with the default plugin (Jabo) neither with GLideN64 on "PJ64 v2.4.0-692" in three different machines (Win7 x86+GeForce 8400 GS, Win7 x64+Radeon HD 6350 and Win10 x64+Quadro K620). I see many timing problems on DK64 demos (on real N64), but nothing like "character geometry is all over the place".
The closest thing to the ones you describe happens with the pet's head of King K. Rool when the camera is too close, and only happens with Jabo's plugin. But it's within "the normal behavior" in such plugin.

The problems you describe can be caused by a shader cache corruption. Erase the "GLCache" of your driver on "%APPDATA%" and "%LOCALAPPDATA%". And try again...
 
21 - 33 of 33 Posts
Top