Next Generation Emulation banner

I need to tweak my plugins. Sporadic framerate.

916 Views 8 Replies 4 Participants Last post by  Sniperscope
I'm new to the program, and I'm having some issues getting it to stay at, say, a constant of 60 FPS. A FMV will sometimes linger around 30-45 and some random scenes that doesn't look graphic intensive or anything will bog down to the 20s.

System specs:
Athlon XP 2800+ (2.1 ghz)
Windows XP Home Edition
512 MB PC2700 DDR RAM
nVidia GeForce 4 MX Integrated Graphics

Current plugins being used:
Pete's OpenGL Driver 1.75
Eternal SPU Plugin 1.41
ePSXe CDR WNT/W2K core 1.5.2

Any suggestions on what settings to tweak in the OpenGL Driver? Or a new plugin altogether? Or would it have something to do with the sound?
1 - 9 of 9 Posts
You forgot to include the most important part, your current pete's ogl's settings. Without them, we can't help much. Anyway, you should start by making an ISO of the game, and playing from it.
Right. Sorry about that. Already made an ISO, not much luck there. So far all I've really tried are the defaults called "fast" and "nice" and once I took that framerate thing from 200 to 60.. just too many wacky settings. Are there any good custom settings for this?
Let's see. You could start trying these:

Plugin: Pete's OpenGL Driver 1.1.75
Author: Pete Bernert
Card vendor: ATI Technologies Inc.
GFX card: RADEON 9500 x86/SSE2

- 640x480 Fullscreen - NO desktop changing [32 Bit] <-- you could try raising this, if you achieve a decent framerate
- Keep psx aspect ratio: off

- B8G8R8A8 <-- your card should be able to handle it, but use a lower setting if it can't.
- Filtering: 6 <-- same as above
- Hi-Res textures: 0
- VRam size: 128 MBytes

- FPS limitation: on
- Frame skipping: off
- FPS limit: Auto

- Offscreen drawing: 3
- Framebuffer texture: 0
- Framebuffer access: 4
- Alpha multipass: on
- Mask bit: on
- Advanced blending: on

- Scanlines: off
- Line mode: off
- Unfiltered FB: off
- 15 bit FB: off
- Dithering: off
- Screen smoothing: off
- Screen cushion: off
- Game fixes: on [00019000]

About eternal, just, use directsound, spuasync audio out method, smooth mode, a buffer of around 40 (that you should raise if the sound cracks, or lower if it lags), neill's reverb, and whatever irq settings your game might need.

Keep loading from the ISO, i suggest using mooby's cd plugin to load it.
See less See more
Thanks, did everything you said except the Mooby part (that just crashes the program), but it didn't help at all. Still slows down in the same areas. :/
Slow in some areas? Set your colour depth to 16bit, fitering lower to about 3-4, offscreen and frambuffer access to 2.

Mooby crashes? I suggest you run the image from FILE ---> RUN ISO.
Mooby doesn't load ISOs well.

The other suggestions I did and it sent the program all to hell. Now there's tons of afterimages.

Afterimages are gone but it still slows down at the same points. Bleh.
Time to check yoru computer then. Have you searched for virus, spyware, etc? Do you usually defragment your hard drive?

Also, if you don't mind sacrificing graphics, you could try with peops gpu plugin.
Which game does this happen in? If there are several games, in which one is it most noticable? Which type of game, 2D or 3D games? Using OpenGL plugins in 2D games is pretty much a waste of power.

Your video card is integrated, and only a Geforce 4 MX at that (I had that once too, it's bleh at OpenGL performance IMO), so you might want to go with very modest settings. If you get good performance MOST of the time, any adjustment you can make might not help at all, and it would be best to just live with slowdowns when they occur.

Some games have slowdowns in certain areas almost regardless of how powerful your system is, which is why the specific game you have interests me. Breath of Fire IV, for instance, is very slow in many of the cities you visit.
1 - 9 of 9 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.