Next Generation Emulation banner

HELP! I can't run the store copy of ff9 on any emulators

1874 Views 13 Replies 8 Participants Last post by  scottlc
hello I just recently purchased final fantasy 9 for psx to try it on my playstation emulators but whenever I start up any of the 4 ff9 cd's i just get a black screen and the drive reading the cd forever.. these are the proper store cd's and not some dodgy backup or iso.. I took it down the road and tested the cd's on my friends psx 2 and they worked perfectly on it.. so I'm sure its not the cd's being damaged and i'm sure its not my cd rom as any other psx game i've tried in it works and I made an ISO image of the cd and tried that in the emulator which got the same result..

I've tried them in bleem, virtual game station, and ePSXe with pete's graphic/sound/cd plugins and I get the same result everytime.. the game starts to load but it sits on a black screen and keeps reading the CD forever..

Does someone know what the problem is and how i can make this awesome game work?
1 - 7 of 14 Posts
I live in Australia and I think we use pal here..

so my store copies will never work and the onlt way to play them is to make an iso, patch the iso, and then burn it back onto a cd then?
Yep I was just about to say that myself.. we've got the UK pal here.. so I applied the UK patch and all is well!

Thanks for your help everyone.. :)

It turned out that all my problems were because I was fighting a battle on two fronts.. On one front was that the game needed to be patched.. and the other was that everytime I try the game using pete's software plugin the game crashes as soon as I try to start it up.. the only reason I discovered this, was that I switched over to openGL for another game and then went back to my ff9 experiments forgetting that it was still using the OpenGL plugin lol..

I'd like to use the software plugin though.. does anyone offer an answer to why the hell it would work in the opengl but not in the soft.. usually its the other way around as the soft is more compatible so this is rather odd.. has anyone successfully played ff9 using pete's software plugin?
sorry.. its just that the thread had reached the bottom of the forum and I figured no one would ever post in it if it dropped off to the 2nd page. :(

Thanks for the info, I tried to mimic your settings but it still crashed back to windows every time with the software plugin. :(

here's my info:
Config: Pentium3 550e, 256MB RAM, MSI GeForce 2 GTS (using latest Detonator Drivers), SB Vibra 128, 48x CD-ROM, WinXP Professional and Win 98 (crash happens in both)

Like I said before Pete's other plugin's work but the software one crashes eSPXe completely the second the game starts up. The soft plugin works with all the other psx games with no probs and this is the first game I've ever found that doesn't like it.
lol its funny its nearly been 2 years now and the same problem still exists. I'm still yet to ever see FF9 in software mode.

After so many driver updates, ePSXe plugin updates and program updates it still happens in both 98 and XP with the new ePSXe and the latest P.E.Op.S. Soft Driver. But yeah I still got the same P3 550e system I did then though. So sad lol. Can't wait to upgrade at the end of the year and hopefully this problem might go away with a new computer.

So annoying I have zero problems with the soft plugin with any other games. It works perfectly. And FF9 works perfectly using Direct 3D or OpenGL. Yet soon as I dare to use the soft plugin with FF9... BOOM! ePSXe crashes.
Yeah thought I'd drop by to see how things were going in this place.

I didn't even think my old old threads would still be here lol.
1 - 7 of 14 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.