Next Generation Emulation banner

1 - 14 of 14 Posts

·
Resident God
Joined
·
35 Posts
Discussion Starter #1
hello I just recently purchased final fantasy 9 for psx to try it on my playstation emulators but whenever I start up any of the 4 ff9 cd's i just get a black screen and the drive reading the cd forever.. these are the proper store cd's and not some dodgy backup or iso.. I took it down the road and tested the cd's on my friends psx 2 and they worked perfectly on it.. so I'm sure its not the cd's being damaged and i'm sure its not my cd rom as any other psx game i've tried in it works and I made an ISO image of the cd and tried that in the emulator which got the same result..

I've tried them in bleem, virtual game station, and ePSXe with pete's graphic/sound/cd plugins and I get the same result everytime.. the game starts to load but it sits on a black screen and keeps reading the CD forever..

Does someone know what the problem is and how i can make this awesome game work?
 

·
&-)---|--<
Joined
·
8,586 Posts
What country version is it? If it's a Pal version of the game, then you need a patch for the game to work in epsxe.. The NTCS version of FF9 doesn't need a patch to work..

BTW.. What are your system specs and configuration of epsxe?

Find the patch here:
http://www.aldostools.com/patches.html

Or use a search engine like www.google.com and do a search for "psx Patches"..
 

·
Resident God
Joined
·
35 Posts
Discussion Starter #4
I live in Australia and I think we use pal here..

so my store copies will never work and the onlt way to play them is to make an iso, patch the iso, and then burn it back onto a cd then?
 

·
Registered
Joined
·
2,441 Posts
you can use petes cdr plugin to apply a patch to the game "on the fly" thus eliminating the need for an iso. btw, you dont need to burn the patched iso to play anyhow.

but, being in australia, i do not believe that there is a patch out for that version. you can give the UK patch a shot but im not sure if that will work if you dont actually have a UK version.
 

·
Registered
Joined
·
9,506 Posts
The australian one is the same disk as the uk one so it will work ok. The only language version that doesn't work is Italian.
 

·
Resident God
Joined
·
35 Posts
Discussion Starter #7
Yep I was just about to say that myself.. we've got the UK pal here.. so I applied the UK patch and all is well!

Thanks for your help everyone.. :)

It turned out that all my problems were because I was fighting a battle on two fronts.. On one front was that the game needed to be patched.. and the other was that everytime I try the game using pete's software plugin the game crashes as soon as I try to start it up.. the only reason I discovered this, was that I switched over to openGL for another game and then went back to my ff9 experiments forgetting that it was still using the OpenGL plugin lol..

I'd like to use the software plugin though.. does anyone offer an answer to why the hell it would work in the opengl but not in the soft.. usually its the other way around as the soft is more compatible so this is rather odd.. has anyone successfully played ff9 using pete's software plugin?
 

·
Resident God
Joined
·
35 Posts
Discussion Starter #8
bump
 

·
I'm in despair!
Joined
·
3,420 Posts
Originally posted by The Blake
bump
Don't bump posts.

And about the FF9 + Soft plugin, yes it works, as shown in the screenshot below. Might be a problem with your video card drivers.

[]s Badaro

Plugin: P.E.Op.S. Soft Driver 1.1.3
Author: Pete Bernert and the P.E.Op.S. team

Resolution/Color:
- 640x480 Fullscreen - [16 Bit]

Framerate:
- FPS limit: on
- Frame skipping: off
- FPS limit: Auto

Misc:
- Scanlines: disabled
- Game fixes: off [00000000]
 

·
Resident God
Joined
·
35 Posts
Discussion Starter #10
sorry.. its just that the thread had reached the bottom of the forum and I figured no one would ever post in it if it dropped off to the 2nd page. :(

Thanks for the info, I tried to mimic your settings but it still crashed back to windows every time with the software plugin. :(

here's my info:
Config: Pentium3 550e, 256MB RAM, MSI GeForce 2 GTS (using latest Detonator Drivers), SB Vibra 128, 48x CD-ROM, WinXP Professional and Win 98 (crash happens in both)

Like I said before Pete's other plugin's work but the software one crashes eSPXe completely the second the game starts up. The soft plugin works with all the other psx games with no probs and this is the first game I've ever found that doesn't like it.
 

·
Resident God
Joined
·
35 Posts
Discussion Starter #11
lol its funny its nearly been 2 years now and the same problem still exists. I'm still yet to ever see FF9 in software mode.

After so many driver updates, ePSXe plugin updates and program updates it still happens in both 98 and XP with the new ePSXe and the latest P.E.Op.S. Soft Driver. But yeah I still got the same P3 550e system I did then though. So sad lol. Can't wait to upgrade at the end of the year and hopefully this problem might go away with a new computer.

So annoying I have zero problems with the soft plugin with any other games. It works perfectly. And FF9 works perfectly using Direct 3D or OpenGL. Yet soon as I dare to use the soft plugin with FF9... BOOM! ePSXe crashes.
 

·
Resident God
Joined
·
35 Posts
Discussion Starter #13
Yeah thought I'd drop by to see how things were going in this place.

I didn't even think my old old threads would still be here lol.
 

·
Registered
Joined
·
1,577 Posts
ePSXe now supports subchannels. You should enable subchannel caching to play FF9 without patching.
 
1 - 14 of 14 Posts
Top