Next Generation Emulation banner
1 - 3 of 3 Posts

· Just visiting ^_^
Joined
·
8,325 Posts
Discussion Starter · #1 ·
well I have this kinda old 20 HD that I use to transfer large files from the office to my house... well I know thats its a little beat up and when I connect it at my PC at home, it sometimes give this beeping sound continously... but at the office it doesn't do that...

well here's some other info... currently I think my power supply need replacement since I cannot seem to make like 3 HD and a CD ROM running without one of them not being detected... so could this be a reason for that? Or is this HD already having mechanical problem or something?
 

· Registered
Joined
·
2,230 Posts
I'd check the HD using the manufacturer's HD diagnostic utilities available at its respective web site. Search for it and check your HD with this, if the program says everything is fine, take a look at the cables, BIOS options, swap IDE channels, etc.

What's your PSU rated wattage?, How many amps can supply for each voltage rail?
 

· Just visiting ^_^
Joined
·
8,325 Posts
Discussion Starter · #3 ·
Well I think its those standard one that come with your casing... and like what I said earlier, my PSU is having a bit of problem... so I do hope that will be the case that I will have to change it....

guess I have to spend some money here (oh... my christmas saving will be tampered :cry: )
 
1 - 3 of 3 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top