Next Generation Emulation banner
1 - 18 of 18 Posts

·
Registered
Joined
·
10 Posts
Agh - someone recommended that I should use this for my graphics plugin instead of GSoft. So I did - I downloaded it and configured it so taht it was my graphics plugin. *Sigh* nothing ever seems to go right!

I set it as my graphics plugin thingy and an error message pops up that says "GSinit Error: -1"

As a n00b I instinctively went to the legendary Configuration Guide - it said that GSdx9 worked with DirectX 9. So just incase I didn't have that, I downloaded DirectX 9 SDK (What does SDK stand for anyways?) and installed it.

I haven't reistarted my computer yet (do i have to? - maybe that's the problem) but the same error message pops up. What should I do?

Oh, and just as a side question, does anyone know if Resident Evil 4 is playable?

Oh **** sorry I posted this twice - I think I clicked on the post thread command twice!

My bad!
 

·
PCSX2 Coder
Joined
·
10,122 Posts
and you still managed to miss the edit button! please dont double post, ill let you off with the double thread posting, that seemed a genuine mistake.

read the common problems and solutions guide, that may help you
 

·
Registered
Joined
·
218 Posts
after you instal DX 9.0c - I don't know where you got SDK from - you need to restart for it to take effect. I recommend for you to go Start -> Run -> dxdiag and run the tests that are there, namely the graphix ones.

As for possible settings you could use for the emu u can looks at my sig, it has pretty stable settings and I have used them all the time and managed to get into many of the games that I have.

Hope that helps.
 

·
Familiar Face
Joined
·
4,971 Posts
:rotflmao: You didn't install Directx 9, you installed the Software Development Kit for Directx 9. What you downloaded was the software that programmers need to wrte applications that use Directx9.;) If you're running Windows XP, just download Service Pack 2 for it, or go to the Windows update site at: http://windowsupdate.microsoft.com and you'll see it there as well. Service Pack 2 automatically installs DX9.
 

·
Registered
Joined
·
10 Posts
Discussion Starter · #5 ·
lol thanks general plot... i downloaded SDK by accident (that was a really BIG file too... T_T).

Hmmm... I've downloaded Directx9c (i think that's the DirectX update i needed) and I've installed it.

I've also restarted the computer and OMG the same message pops up. "GSinit Error: -1" - WHICH IS VERY ANNOYING!!! I'll do some research on it (google it ^_^), but I don't think i'll get anywhere with this. If i use Gsoft (I think that's what it's called) I don't have this problem. But someone recommended to me that I should use gsdx9 0.8 to get Kindgom Hearts running (which i couldn't do T_T).

I just want to know why this error message pops up T_T. Thanks for help in advance ^^!
 

·
Familiar Face
Joined
·
4,971 Posts
Seungyoun said:
lol thanks general plot... i downloaded SDK by accident (that was a really BIG file too... T_T).

Hmmm... I've downloaded Directx9c (i think that's the DirectX update i needed) and I've installed it.

I've also restarted the computer and OMG the same message pops up. "GSinit Error: -1" - WHICH IS VERY ANNOYING!!! I'll do some research on it (google it ^_^), but I don't think i'll get anywhere with this. If i use Gsoft (I think that's what it's called) I don't have this problem. But someone recommended to me that I should use gsdx9 0.8 to get Kindgom Hearts running (which i couldn't do T_T).

I just want to know why this error message pops up T_T. Thanks for help in advance ^^!
OK, first off, Kingdom Hearts doesn't work with the current release yet.;) You can get to the title screen, and that's about it. As for the error, what video card do you have? If you don't have Pixel Shading support, I imagine you might get that error.;)
 

·
Registered
Joined
·
3,630 Posts
Nope,if he doesnt support pixel shaders the plugin will just work with Fixed pipeline.That error could occur if he's trying to use the SSE2 version of GSdx9 with a processor not supporting SSE2 or using an incompatible gsdx9/pcsx2 combo.
 

·
Registered
Joined
·
10 Posts
Discussion Starter · #8 ·
What is pixel shading support? And how do I c what kind of video card I have (apparently a newbie question T_T).

My speed is around 2000 MHZ (Pretty slow I guess - enough to emulate something?) and the features supported are MMX, SSE, and SSE2.

And uh - how would I know if i have an incompatible gsdx9/pcsx2 combo? Thanks for previous help, and thanks in advance!
 

·
Registered
Joined
·
3,630 Posts
Hm since you have SSE2 that rules out the possibility of being a fault of gsdx9 sse2 version...
By incompatible gsdx9/pcsx2 combo i mean if you dont have the latest release of the 2(eg gsdx9 0.6 and pcsx2 0.8.1 or gsdx9 0.8 with pcsx2 0.7 or older) or if youre using a CVS version of pcsx2(which i dont think so).
That message youre getting is weird..i suggest you try deleting the whole pcsx2 folder and downloading the SSE2 version which should include gsdx9 too(http://www.pcsx2.net/pcsx2download.php?aid=275)
Oh and on a sidenote,no pc to date has the horsepower to emulate the ps2 at decent speeds(we get <5fps in many cases)
 

·
Registered
Joined
·
10 Posts
Discussion Starter · #10 ·
I deleted the pcsx2 folder and downloaded the SSE2 version.
It didn't include gsdx9, but I downloaded that from the pcsx2 site. I configured it - and BAM! Same thing.

I know Kingdom Hearts is only supposed to recah the menu - but I can't even reach that - as mentioned before it crashes T_T. I'm getting Resident Evil 4 from a friend - I want to see if that works ^^.

Any further help would help greatly!!!
 

·
Registered
Joined
·
767 Posts
Seungyoun said:
I deleted the pcsx2 folder and downloaded the SSE2 version.
It didn't include gsdx9, but I downloaded that from the pcsx2 site. I configured it - and BAM! Same thing.
You sure, You configured the GSdx9 Plugin? It maybe because your graphics card doesn't support pixelshading. If it doesn't The error may pop in. But if you select Fixed Pipeline, It should start the Emu without the error. I had the same prob when my graphics card didnt support pixelshading.
 

·
PCSX2 Coder
Joined
·
10,122 Posts
ok i think we can safely assume his graphics card is good enough, and his processor due to the fact X1800's are PCI-Express only, so he would need a P4/AMD 64 chip to use it.


yes you dont want DirectX SDK, thats for developers of games only, just make sure you have this

http://www.microsoft.com/windows/directx/default.aspx?url=/windows/directx/downloads/

to be honest im confused why its not working for you... what colour depth do you have your desktop in? also try making a fresh install of pcsx2 into a different folder like c:\pcsx2 or something, see if it works there.
 
1 - 18 of 18 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top