Next Generation Emulation banner
1 - 20 of 22 Posts

·
No sir, I don't like it.
Joined
·
5,571 Posts
r1549
GSdx: - trying the dx10.1-only "gather" shader instruction for palletized lookups ("8-bit texture" mode), saves 4 instructions which isn´t much but still... (not tested, don´t have ati) - may fix the intel gma "no output" bug (don´t have gma either Razz) - and the usual small code optimizations
Apparently it's a speedhack.
 

·
Registered
Joined
·
1,467 Posts
Wrong quote, masta.g.86 :p

Palletized textures are an attempt to optimize texture sizes and texture data transfer.
It works well on some games, with some graphic cards.
On other games, with different graphic cards, it might be slower though.

All the difference should be in speed though, so just try the option on your game and use what's fastest ;)
 

·
No sir, I don't like it.
Joined
·
5,571 Posts
Wrong quote, masta.g.86 :p
Bah. That's the closest I could get to solving the mystery.:dead:

Palletized textures are an attempt to optimize texture sizes and texture data transfer.
It works well on some games, with some graphic cards.
On other games, with different graphic cards, it might be slower though.

All the difference should be in speed though, so just try the option on your game and use what's fastest ;)
Hmm. So internally, this similar to the "palletized textures" option in older PC games? (mostly around the DX5 - DX6 era) That's what I initially thought, but couldn't find any definitive answers from the devs, until now. Thanks.:)
 

·
┐( ̄ー ̄)┌
Joined
·
2,058 Posts
Wrong quote, masta.g.86 :p

Palletized textures are an attempt to optimize texture sizes and texture data transfer.
It works well on some games, with some graphic cards.
On other games, with different graphic cards, it might be slower though.

All the difference should be in speed though, so just try the option on your game and use what's fastest ;)
on Mana Khemia 2 enabling the 8 bit texture will create some kind of white window background on character portrait. not a big deal though, disabling 8-bit solve this.
just asking if this is a bug or not cause you said the only difference is speed
i'm using ATI 3850 if this'll help
 

·
Registered
Joined
·
1,467 Posts
Well, it's possible that certain upscaling / texture placement issues only show when this option is on (or off!).
You can easily test this by enabling native resolution, and see if it's still doing it.

If so, could I see a screenshot of the issue? :p
 

·
Registered
Joined
·
2,471 Posts
I don't know if this is how this option is suppose to work but I have a lot of texture problems on a lot of games(or maybe all of them)when it's enabled.I do have speed boost on some games but because of those problems,some games are barely playable at some places(KH2 for example)
 

·
┐( ̄ー ̄)┌
Joined
·
2,058 Posts
Well, it's possible that certain upscaling / texture placement issues only show when this option is on (or off!).
You can easily test this by enabling native resolution, and see if it's still doing it.

If so, could I see a screenshot of the issue? :p
okay, here's some of them

i tried using native resolution too but the problem is still there
 

·
Banned
Joined
·
23,263 Posts
does this emulate paletted textures, or enable the GFX hardware support?.... paletted textures hasn't been present on nvidia hardware since Geforce 6......
 

·
Registered
Joined
·
358 Posts
The things is. This option was probably still turned on by default in GSDX, because If I disable it I lost about 30fps while older GSDX without this option is running at same speed as GSDX with this option enabled.
 

·
Banned
Joined
·
23,263 Posts

·
Registered
Joined
·
2,471 Posts
I checked it with a dump, it looks exactly the same here with 8 bit textures on and off.
Also tried it in dx9 and dx10 mode.
So yeah, it could be an ATI only problem..
I have that problem too when 8 bit textures is enabled and I have NVidia.On SW mode is ok.Here's one from KH2(that game is FULL of those problems and it's barely playable on some places,but again on SW mode is ok)
 

·
Registered
Joined
·
2,471 Posts
Again, it works totally fine here.
Are you guys sure you use the latest GSdx build?
I'm using r1650 now but this problem is there since this option appeared.Everything is ok if I don't enable it or enable it and use SW mode but is this how this option is suppose to work?

Tale of the Abyss,Atelier Iris 3 and some more games has some minor problems too if that option is enabled.
 
1 - 20 of 22 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top