Next Generation Emulation banner
1 - 6 of 6 Posts

·
just a regular emufan
Joined
·
138 Posts
Discussion Starter · #1 ·
Hi. I used to run my PAL games on dolphin on revisions r2800 and near that. And I did stop with testing for a little while (before r3000). Now we are ~1000 revisions later around r3800 and I started the testing again but I'm facing two problems with my PAL games. I used to run Resident Evil (gamecube) i.e. with or without XFB enabled without a problem. Now, when I enable XFB, I get a green flickering screen like this one (in the attachment is a wii game, but the green on the screen is like that one) in my PAL games. And when I run Resident Evil i.e. without XFB but on PAL60 (by holding X and B buttons on boot), my screen starts blinking very fast, it can be noticed when I go to the options menu. Such thing doesn't happen with r2800~ in example, it doesn't matter if it's PAL50Hz or PAL60Hz. On older revision like that, It runs just fine on both situations.

Other strange behavior it's about the rendering when I'm running a Wii PAL game at 50Hz. It gets realy choppy, unless I change it to PAL60hz (Mario Galaxy for example). One of the devs said that might have something to do with my monitor being set to 60 Hz and the game updating at 50 Hz. But on older revisions, I never had such behavior with my PAL games in dolphin. And besides, as far as I know, 90% of the LCD monitors in the market doesn't accept a refresh rate of 50Hz. And I didn't change anything in my rig, just so you know.

Now, can someone please tell me what part am I missing in this process? 'cos I realy don't know what is happening. Thank you very much.
 

·
Banned
Joined
·
35,081 Posts
Disable Vsync, or enable triple buffer.

50hz games require an additional buffer to sync the fps to herz if vsync is enabled.
 

·
the emulation youtuber
Joined
·
233 Posts
i have a similar problem. I dont use Real XFB in my GFX settings and in the past dolphin has worked fine but now i just get a full green, blue or yellow screen when the game beigns to run. Do i need to update something or what?? I'm confused on this one.
 

·
just a regular emufan
Joined
·
138 Posts
Discussion Starter · #5 ·
Disable Vsync, or enable triple buffer.

50hz games require an additional buffer to sync the fps to herz if vsync is enabled.
Thanks for the help, Squall. But it doesn't help me at all.:( The vsync was off anyway. Same choppy rendering and same XFB green flickering screen.
60Hz IS YOUR FRIEND
Thanks, but if I wanted run my games at 60Hz, I shouldn't asking for help 'cos it's easy.:p

Dolphin has a bug with XFB/EFB or something, but the devs don't want to mess with it right now, I guess. I guess I have to live with that.:(
 

·
just a regular emufan
Joined
·
138 Posts
Discussion Starter · #6 ·
Sorry for the double post, but it seems that Nolan.Check is trying to get things right on their place with the XFB thing:thumb:. And I thought he had forgotten me.:emb: Shame on me.:p

ps: I did not test yet because my visual studio is in a bad mood.:dead:
 
1 - 6 of 6 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top