Next Generation Emulation banner

1 - 15 of 15 Posts

·
Registered
Joined
·
31 Posts
Discussion Starter #1
From my previous thread (http://forums.ngemu.com/generic-epsxe-queries/118663-keyboard-controls.html), I originally thought it was just my keyboard malfunctioning.

Upon emulating other games with ease, it has come to my attention that it may in fact be the game I am trying to play that is malfunctioning.

Have there been reports of Grandia having issues with keyboard control settings? I'm asking because I haven't found any threads for this game yet as well as I've looked through many FAQs trying to figure out exactly what the problem is.

Any help or tips would be greatly appreciated :3
 

·
God of Douchebagness™
Joined
·
9,826 Posts
have you tried installing the latest drivers for that input device? does it do the same thing with other emulators (not other versions of epsxe)?
 

·
Registered
Joined
·
31 Posts
Discussion Starter #3
The drivers are fine, I just checked that.

I'm currently downloading another emu to see if that is the issue. If that doesn't correct it, what else could I do?

This is a really odd problem =/
 

·
God of Douchebagness™
Joined
·
9,826 Posts
what O/S are you using? is everything up to date (directX, etc.)?
 

·
Registered
Joined
·
31 Posts
Discussion Starter #5
XP SP3 and yeah everything is up to date.

It may just be my new keyboard referring to my previous thread in regards that my old keyboard never had any problems. But I also never tried playing Grandia on my pc with the old keyboard as well so its iffy whether or not its the keyboard's issue. I will give my old keyboard a spin though after I try a new emu.

Thanks for helping me a bunch.
 

·
God of Douchebagness™
Joined
·
9,826 Posts
weird. it works fine with other games and when you run the BIOS right? if you have the game running does it respond to you pressing the esc key to return to the GUI or even other key combinations like alt+tab and all the function keys?
 

·
Registered
Joined
·
31 Posts
Discussion Starter #7 (Edited)
Yeah it responds fine when I press ESC.

Though now that I think about it, I remember having issues with controls when I was testing the BIO and that I couldn't move anywhere with the arrow keys or with the common controls like with Grandia. I'll check up on that right now.

Edit: The bio does not respond to any keyboard stimulus even when pressing F5. Is this a tell-tale sign of why maybe Grandia doesn't work?

But then why would Tales of Destiny work? So much to think about =[
 

·
God of Douchebagness™
Joined
·
9,826 Posts
try mapping just a single button to a random key on your keyboard, leave everything else cleared, and see if anything changes. i suggest you do this to each button, a one-by-one fashion to see if you can get any of them working on their own with no other mappings in place.

edit- in the GUI do run>enable logs, start the game or run the BIOS and see if it detects any problems in the output window.
 

·
Registered
Joined
·
31 Posts
Discussion Starter #9
Just tried the logs but they detected no errors and I tried individual keys but it had no use as well.

I'll be trying my old keyboard in a bit unless there are other things I could try first.
 

·
God of Douchebagness™
Joined
·
9,826 Posts
i can only go with it having to do with your specific keyboard, the controls should respond in the BIOS regardless of the input device being used (just to be 100% sure i mapped everything to my keyboard instead of my controller and it was responsive). i dont have this game so i have no real way of doing that same sort of testing on it myself, someone else might have it though and could look into this issue.
 

·
Registered
Joined
·
31 Posts
Discussion Starter #11
Well thank you for helping me.

I'll check some other methods and emulators and see if it really just is my keyboard.

As for Grandia, if anyone who reads this does own this game or has had issues (or even no issues at all) should post in this thread. It would help me out a lot.
 

·
Banned
Joined
·
23,263 Posts
Install the latest Dx9c bimonthly.
 

·
God of Douchebagness™
Joined
·
9,826 Posts
Well thank you for helping me.

I'll check some other methods and emulators and see if it really just is my keyboard.

As for Grandia, if anyone who reads this does own this game or has had issues (or even no issues at all) should post in this thread. It would help me out a lot.
if anyone manages to reproduce this exact issue i will consider adding it to the FAQ, i cant do it just yet until i have good evidence that it is not just an isolated case though.

for now your best bet is going to be testing it with a different keyboard, depending on what it does it will rule out a significant amount of other possible sources.
 

·
Registered
Joined
·
258 Posts
Well thank you for helping me.
As for Grandia, if anyone who reads this does own this game or has had issues (or even no issues at all) should post in this thread. It would help me out a lot.
Ahh I had to think about it awhile but I do think there are some control issues with Grandia and certain emulators. But it's been so long since I played it I don't remember 100%.

I think my issue was just left and right being screwed up in the camp/status/inventory menu.

Edit:
I do think your problem after checking that other topic is hardware or driver related though.
 

·
Registered
Joined
·
31 Posts
Discussion Starter #15
Alright, I'll double check my drivers and hardware again although I have already.

If that doesn't correct it I'll try my other keyboard when I wake up tomorrow lol. Thank you for helping.
 
1 - 15 of 15 Posts
Top