Next Generation Emulation banner

1 - 6 of 6 Posts

·
Premium Member
Joined
·
821 Posts
Beta Date: 14 04 05
Conditions Tested Under:

Interpreter mode only
GSsoft 16.04.05
BIOS HK1.90
spu2peops 25.12.04
cdvdpeops 29.03.05

In spite of using complete chinese BIOS with ROM2 and EROM, text printed in asian "big fonts" is not displayed.
Against former betas you can see the 3D modeled car at car select screen (screenshot is a "Lister Storm").
After selecting car, PCSX2 crashes logging

UNKNOWN VifCmd: 88
UNKNOWN VifCmd: af
UNKNOWN VifCmd: cd
UNKNOWN VifCmd: 16
UNKNOWN VifCmd: 46
UNPACK 330, 18, UNHANDLED 3
UNKNOWN VifCmd: 8e
UNKNOWN VifCmd: dd
UNKNOWN VifCmd: 4f
UNKNOWN VifCmd: 36
UNKNOWN VifCmd: bf
UNKNOWN VifCmd: df
UNKNOWN VifCmd: 55
UNKNOWN VifCmd: be
UNKNOWN VifCmd: f
UNKNOWN VifCmd: 1f
UNKNOWN VifCmd: 2f
UNKNOWN VifCmd: 8
*PCSX2*: fixme unpack overflow
VIF1 UNPACK: Mode=f, v->size=128, size=128, v->addr=3ff0



Patch used:

gametitle=Gran Turismo 4 NTSC-J China SCAJ30007
//skip Videos
patch=1,EE,00100D84,word,24100001
//Skip Intro
patch=1,EE,00875c44,word,00000000


Status:
Menus
 

·
Premium Member
Joined
·
821 Posts
Discussion Starter #3
Darn, the dog ate the old screenshots - no wait, it must have been "phishes" :eyemove:

config as above, except from:
GSDX9 v0.6 release January 6th, 2005 - D3D and software mode

Screens are flashing like a stroboscope.
On the brand selection screen with loads of textures, these appear with a delay.
Colors of the 3D modeled car are messed up.

With GSDX9 the text printed in big fonts is missing as with GSsoft.
I made another test with "GT4 Prologue China", where the text is displayed correctly. (On the other hand that game shows no bitmaps)
So i guess it's just a specific problem with GT4


"Lord, won't you buy me a Mercedes Benz..." :guitar:
 

·
Premium Member
Joined
·
821 Posts
Discussion Starter #5
Beta Date: 18.07.2005 [VIF fix linuz]
Conditions Tested Under:
release 0.8.1 plugins, except from
GSDX9 0.9 25.07.05

As with PAL version of game "Pre-race-start graphics" and ingame graphics moved again to the "invisible part of VRAM"

Status Menus

<hr>

Beta Date: 17.07.2005 [CVS+IPU SSE2 - Refraction]
Conditions Tested Under:
release 0.8.1 plugins, except from
GSDX9 0.9 25.07.05
GSsoft 0.9 30.05.05

Printed text on menu buttons disappeared (any GS plugin).

GSDX9 25.07.05 goes ingame if you set videomode to either 480p or 1080i, in NTSC mode it crashes.
Ingame it shows pixel junk instead of 3D

GSsoft goes ingame in NTSC mode. Infinite loop before going ingame with progressive scan mode.

Status Ingame
 

·
Premium Member
Joined
·
821 Posts
Discussion Starter #6
Beta Date: 19.08.2005 [Refraction VIF_STAT log 02:57h]
Conditions Tested Under:
release 0.8.1 plugins, except from
GSDX9 0.9 15.08.05
REC OK
VUREC missing HUD ingame

Graphics look exactly as with beta 17.07.05

Status Ingame

<hr>

Beta Date: 19.08.2005 [FBRST] - 21.08.05
Conditions Tested Under:
release 0.8.1 plugins, except from
GSDX9 0.9 15.08.05

Stops at second "legal screen", ie before memory card screen
as seen with misc. former betas 28.05.05-02.07.05

Status Nothing
 
1 - 6 of 6 Posts
Top