Next Generation Emulation banner

1 - 2 of 2 Posts

·
The Nexus of a Crisis, and The Origin of Storms
Joined
·
767 Posts
Discussion Starter #1
Greetings,

Ive been having a bit o trouble with ff9 and epsxe
after 5 or so hours of configuring im still not satisified, although i came darn close several times

there are several issues i would like someone to address for me, maybe i am missing the obvious

first, my system:

AMD athlon-c 1Ghz
256 MB [email protected] (stupid pencil trick:) )
Abit KT7-A RAID
All-In-Wonder Radeon
GameTheater XP
(All my drivers are fully updated, and i use DX8)

Ok, first off, I tried to use Petes D3D...as a general rule thats just about the best plugin out there.

I encountered a very odd error. When I played through Chrono Cross, I was able to set the resolution to 1600X1200 with 4X anti-aliasing, and all goodies except FVP. Except for the last boss fight, it ran exceptionally well. (this was on epsxe 1.2, petes 1.49)

When I tried similiar settings on FF9, I encountered a great deal of slow down. This kinda made sense to me, since it is a seemingly more intensive game. That was when I discovered an odd resolution barrier. 800X600 or below ran fine, but any resolution above that gave me massive slowdowns in the menus and whenever the black mage cast fire (im not very far yet). The wierd thing about it was that none of the other settings mattered, except for color depth.

Now aiw radeons are known not to gain much performance when in 16-bit mode as opposed to 32. Thus I was quite suprised. I could run in 16 bit mode, with most enhancing options disabled, at 1600X1200, though it looked like crap. For some reason I dont understand, I dont seem to be able to achieve 32 bit resolutions above 800X600. It would probably be worth mentioning that the emu ran exactly the same between 1024X768 and 1600X1200.

After playing with the settings for several hours, I finally decided to try petes opengl. I have avoided opengl in the past because it seemed to be much more prone to errors than the DX plug-ins.

Suprisingly, with 32-bit color, 1600X1200, 32-bit textures, enhanced filtering w/o 2D, OD set to 2, frame buffer black, and alpha multipass on I was able to achieve playable almost no frame-loss play rates. This includes my video cards openGL settings set to 4X anti-aliasing, and highest quality isotropic texture filtering.

I thought I had at last discovered a playable setting, when I encountered a most bizarre error. After just a short time of playing, the textures on my screen began to acquire odd color attributes, ie there were color splotches everywhere. This was particularly pronounced after battles. Every now and then the splotches would be "cleaned", only to slowly reappear (albeit different colors in different places).

So I immeadiatly began to play with settings again, and discovered that no matter what the settings were, openGL continued to foul up the polygons textures. I turned off all special openGL features through my video card, and reduced the plug-ins settings to the "fast" default button, all to no avail.

Needless to say, Im a little exasperated. I would play at 800X600, but my card doesnt seem to anti-alais very well at that resolution. And even with dithering, 16-bit color just doesnt look quite as good as 32-bit.

Mainly, I would very much like to hear any ideas about fixing my problem with openGL. If I can get the textures to stop corrupting, then I would have a playable very nice looking game on my hands.

Thanks so much for reading all this!,
TastEPlamsa
 

·
The Nexus of a Crisis, and The Origin of Storms
Joined
·
767 Posts
Discussion Starter #2
Greetings again,

Well, I think I have discovered part of the problem. It would seem that a setting for my video cards alpha-blending slowed it down quite a bit. The setting was "error diffusion dithering". Something other AiW Radeons users might want to take note of.

This reduced the strange slowdowns i was getting on menus, but I still had problems with the simplest of spells in game. On a lark, I tried DX6 plug-in even though i have DX8 installed, and was suprised to see a gain of about 10 or so fps.

Then I enabled full screen flipping, and reduced the resolution to 1280X1024, and I was able to achieve full frames with 4X FSAA on.

Also, I wanted to apologize for my previous post. I have a tendancy to wax poetic without cause sometimes.

Still I would very much like to hear any ideas about my odd problem with openGL...is it due to the plug-in? Has anyone else ever had this problem, with this or previous versions of petes OpenGL?

I would appreciate any and all responses.

Thanks,
TastEPlasma
 
1 - 2 of 2 Posts
Top