Next Generation Emulation banner
1 - 4 of 4 Posts

·
Registered
Joined
·
10 Posts
Discussion Starter · #1 ·
Hi! Tried emulating Persona 4 today but ran into couple of problems, first of all I had some graphical cliches, does that happen to eryone? Secondly speed sometimes dropped to 30fps witch is kinda slow. I have Athlon X2 4300+ if im not mistaken and Geforce 8600gt. I think I should be able to run games just fine with it but I may be wrong. Tried diferent plugins but some error said that my CPU does not support SSE3 and SSE4, it does support SSE2. Could someone give me a good graphics plugin and tips on configuring it to get better fps. Don't care about the graphics much as long as it doesn't have huge cliches.

Thanks in advance!
 

·
No sir, I don't like it.
Joined
·
7,022 Posts
Are you running GSDX in DX10 mode? I run it in DX9 mode (my card doesn't support DX10) and I get some graphical errors here and there. The problems seem to be improper texture blending and Z-fighting. DX10 fixes many of these problems.

As far as your speed goes, that's just the nature of using an Athlon X2 CPU. Intel Core 2 Duos run considerably better. I average 35 - 60 fps.

Turn off all speedhacks and set the cycle rate to 1.5x.

Do not use frame skipping. You can use frame limiting, but frame skipping causes the FMVs and ingame dialog to mess up.

In your graphics settings, set the internal resolution to 'native'.

Other than that, upgrade to a C2D system or just wait for a more optimized version of PCSX2 to roll out. It's improving with each passing day.;)
 

·
Registered
Joined
·
1 Posts
Ah, so the problem is that pscx doesn't support AMD chipsets? Sad. AMD Phenom 9500 here (quadcore) and ran into some severely nasty fps struggles throughout the game, some fights had it drop as low as 5 fps [thank god for save states ><] but it was passable. Average was 40-60 but ya, nasty drops were nasty as all hell.

Does changing it to native really make a difference in performance? Wasn't using skipping anyways, nor speedhacks, didn't know about the cycle rate though.

Side question: During the animated 2d cutscenes, I got some seriously funky graphic effects, tiling or pixeling, I can't even tell. Any clue on how to fix it?
 
1 - 4 of 4 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top