Next Generation Emulation banner

GLslang and framebuffer objects

2130 Views 4 Replies 2 Participants Last post by  fizzman12
I have 2 problems when running Pete's OpenGL2 Driver 2.9:

1. When I try to run custom shaders I always get: missing GLslang extensions error

2. Whatever settings I put, I always get: missing framebuffer object extension error

System Specs:

------------------
System Information
------------------
Time of this report: 9/13/2009, 17:27:08
Machine name:
Operating System: Windows Vista™ Home Premium (6.0, Build 6001) Service Pack 1 (6001.vistasp1_gdr.090302-1506)
Language: English (Regional Setting: English)
System Manufacturer: TOSHIBA
System Model: Satellite L305
BIOS: InsydeH2O Version 1.50
Processor: Intel(R) Pentium(R) Dual CPU T3400 @ 2.16GHz (2 CPUs), ~2.2GHz
Memory: 1916MB RAM
Page File: 1586MB used, 2493MB available
Windows Dir: C:\Windows
DirectX Version: DirectX 10
DX Setup Parameters: Not found
DxDiag Version: 6.00.6001.18000 32bit Unicode

--------------------
DirectX Debug Levels
--------------------
Direct3D: 0/4 (retail)
DirectDraw: 0/4 (retail)
DirectInput: 0/5 (retail)
DirectMusic: 0/5 (retail)
DirectPlay: 0/9 (retail)
DirectSound: 0/5 (retail)
DirectShow: 0/6 (retail)

---------------
Display Devices
---------------
Card name: Mobile Intel(R) 4 Series Express Chipset Family
Manufacturer: Intel Corporation
Chip type: Mobile Intel(R) 4 Series Express Chipset Family
DAC type: Internal
Device Key: Enum\PCI\VEN_8086&DEV_2A42&SUBSYS_FF671179&REV_07
Display Memory: 829 MB
Dedicated Memory: 128 MB
Shared Memory: 701 MB
Current Mode: 1280 x 800 (32 bit) (60Hz)
Monitor: Generic PnP Monitor
Driver Name: igdumdx32.dll,igd10umd32.dll
Driver Version: 7.15.0010.1502 (English)
DDI Version: 10
Driver Attributes: Final Retail
Driver Date/Size: 6/12/2008 19:37:32, 536576 bytes
WHQL Logo'd: Yes
WHQL Date Stamp:
Vendor ID: 0x8086
Device ID: 0x2A42
SubSys ID: 0xFF671179
Revision ID: 0x0007
Revision ID: 0x0007
DDraw Status: Enabled
D3D Status: Enabled
AGP Status: Enabled

Any help would be grateful.
See less See more
1 - 5 of 5 Posts
Your GPU is incapable of properly working with the OpenGL2 plugin.
Your GPU is incapable of properly working with the OpenGL2 plugin.
Really? How come? I looked my card up and it supports 2.0 shading.
Yeah, in theory.

Call up Intel and ask them why their OpenGL ICD is so horrible.
Yeah, in theory.

Call up Intel and ask them why their OpenGL ICD is so horrible.
Lol, ok well tnx anyway.
1 - 5 of 5 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top