Next Generation Emulation banner
1 - 5 of 5 Posts

5 Posts
Discussion Starter · #1 ·
I've been using ePSXe to play Final Fantasy 9, (on three different computers, at that), and only on my computer, the game often runs too fast. YES, I have it set at 60 FPS frame limit, and I DO have frame limit turned on.

Processor: AMD Athlon 64 X2 Dual Core 4000+
Ram: 1918 MB
Vid card: NVIDIA GeForce 6150 LE (512 MB memory)


Plugin: P.E.Op.S. Soft Driver 1.1.17
Author: Pete Bernert and the P.E.Op.S. team

- 800x600 Window mode
Stretch mode: 0
Dither mode: 0

- FPS limit: on
- Frame skipping: off
- FPS limit: 60.0

- Scanlines: disabled
- Game fixes: off [00000000]

I've tried several other settings as well, and it still happens. Also, it didn't happen with the other two computers (both of which are supposed to be inferior to mine)

5 Posts
Discussion Starter · #2 ·
I just found out it's probably because of my dual core processor. I saw this:

You've got a dual core processor. Didn't notice before. You need to modify your ePSXe.exe so it runs all its threads on a single core. Check this link:!+Page&title=Steve's+XP+Games+Corner

Search the page for "hyperthreading". The fix for hyperthreading will also work for multi-core systems.

However, the link is dead. Does anyone know what to do?


"Hey i have a dual core processor as well and i was trying to run FFIX. The easiest way is to do this.

Whenever you open your emulator open up task manager (alt+ctrl+del) then goto the process tab. find the process epsxe.exe, right click on the process and choose set affinity. Once in this menu uncheck the CPU 1 checkbox but leave CPU 0 checked. Click OK and close task manager, now your game should take a little longer to open ut will run at proper speed. !

Have fun and thanks Shendo for the idea."

I found this post too. I have a feeling this is it; anyone have any other solutions, post anyway.

From Love and Limerence
6,584 Posts
Are you using ePSXe 1.7.0, the newest? I thought that version fixed the affinity issue with multi-core CPUs? Mine is set to both cores by default if I check affinity via Windows task manager, and it doesn't run too fast. Neither did it on my old Hyper-threading equipped Pentium 4. I never tried it on my old Athlon X2.

There is a dual core fix for AMD Althon X2 CPUs, and that may be why it differs for you.

That being said, setting affinity would work, but you'd have to either do that every time after you start the program, or use an external program that will always set it for a certain affinity. I'd recommend either searching for the AMD dual core fix, using the latest ePSXe version (if you're already not), or both.

35,081 Posts
Ever thought to check the AMD downloads section on the AMD website?
1 - 5 of 5 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.