Next Generation Emulation banner
1 - 18 of 18 Posts

·
Registered
Joined
·
4,727 Posts
Try using the Frame limiter in Pete's Graphic plugin. xD
 

·
God of Douchebagness™
Joined
·
15,294 Posts
if that doesnt stop the problem we need to know some of your system specs, specifically your processor and video card brand/model names.
 

·
Registered
Joined
·
3 Posts
I am having similar problems. It seems to only happen when I am using any sound plugin other than ePSXe SPU core 1.7.0. I have tried limiting the FPS and that helps to a degree. Also, when I uncheck "Sound enabled," games do not run at all.

Athlon 64 X2 6000+
2GB RAM
Evga GeForce 8800 GTS
ADI AD1988B onboard sound
Win XP Pro
 

·
God of Douchebagness™
Joined
·
15,294 Posts

·
God of Douchebagness™
Joined
·
15,294 Posts
you cant really do that with most games.
 

·
Registered
Joined
·
1 Posts
If you're using ePSXe on a PC like me, the game's super speed is due how the game internally works. Many games on the PS1 were optimized solely for said PS1, meaning the amount of stuff rendered, the distance of view, the number of moving meshes, etc. were all calculated and tested so that the game can run smoothly on one single piece of hardware. The thing about the PS1 is that, unless an hack was implemented to bypass the RAM to a direct access to the CPU, most of the main processes were directed by the 2MB of RAM. Unlike today's PC which handle a giga-ton of data, the PS1 was using the RAM to store the game's immediate data and references data and 512KB VRAM (well, an equivalent) with 1MB as buffer RAM though the GPU to render up to 640×480 pixels. In many cases, the RAM was registered data based on the Disk reader (which also means it was subject to the Disk Reader' speed.)

With ePSXe, you remove most of those kind of data "funnels". If you're playing on iso files, you move from a Disk Reader stream of 150 KB/s to whatever your HDD or SSD (unless limited by ePSXe). You remove the 2MB of RAM to whatever can be used by ePSXe on your system. In fact, you could basically run the PS1 whole game + rendering on your CPU alone if it wasn't for the rendering huddle that ePSXe's video drivers overcomes because even the cheapest PC on sale today has a CPU thousands of time faster and better than what was on the PS1. (The reason why the PS1 was efficient is solely because of the "rules" implemented by Sony for any game on the platform.)

In any cases, originally, lots of game were running at "max available framerate" simply because their framerates was already around the TV regulated framerate between 21 and 24.9 FPS. (Yes, ntsc TVs could reach 29.9 FPS, but the regulation by TV manufacturers were that as long as it's constantly 21 or above, it's all good. 21 being the old satellite TV channels framerate while 24.9 being, back then, the cable TV framerate.)

This is why, sometimes on ntsc TVs, you would have those strange moments where things were slightly faster for a moment, as the framerate reached the TV's capacity of 29.9 FPS.

It was a common thing, back then on console, to lock the framerate to whatever the CPU was able to do because, unlike today, a game on a console was optimized solely for that one console model. With ePSXe, unless you "force" it to limit the capacity of the emulation, that basically translate the original "Up to the limits of the PS1 CPU" to "Up to the limit of the emulator's capacities based on your way-above-a-PS1 device".

The fix I have been using is:
• Config > Video (in my case, I'm using Peter OpenGL2 GPU core 2.0.0)
• "Use FPS Limit" is checked on.
• FPS Limit is set to 60
• Options > CPU Mode > Interpreter (Slow)
(Only the following steps are required on every games.)
• I launch the game
• I press F4 once. This will turn off the Framerate Limiter.
• I press F4 again. This will turn the Framerate Limited back on.

I noticed that ePSXe, in my case, seems to set the framerate limit to half of the value set. This could be due to some kind of VSync or something. (Vsync takes 2 frames, hence drop the framerate by half of the set value.) So when I set the framerate as unlimited, it reaches 80+ FPS, hence FPS-reliant games reaches 2.5x game speed. If I set the FPS to automatic, it set it to 30 (as I set ntsc), but the hidden Vsync drops it to 15, making the game buggy-like slow. Setting it to 60 drops it to a regular 30. The reason why I press F4 twice is because I noticed that, initially, ePSXe ignore the frame limit even if the option is supposed to be on. (I have the same problem with the Analogue for my PS4 controller which requires me to press F5 twice to enable it as, otherwise, the right analogue stick on said controller is not working.)

This might not work for you, but it's what worked for me on my laptop.
 

·
deep-space demon
Duckstation
Joined
·
350 Posts
Hi, I advise against using ePSXe anymore since the project looks to be abandoned. I suggest using Duckstation which is a modern PS1 emulator that is being actively developed.
Just to point it out, this was a 13 year old thread that was necro'd, if you check the date on post #9
 

·
Registered
Joined
·
2 Posts
Most problems with epsxe are user specific bad settings, for more experienced users ePSXe 2.0.2-1 remains the best PC emulator. I suggest you delete config settings by using the windows registry, but if you dont know, I suggest you to use noob friendly slower duckstation
 

·
Registered
Joined
·
1 Posts
Lol. Sorry for my reply but I don't think it all matters now cause that was asked in 2009 and the windows os xp pro.

Maybe that person doesn't play games any more, maybe a game developer

Sent from my SM-T285 using Tapatalk
 
1 - 18 of 18 Posts
Top