Next Generation Emulation banner
1 - 3 of 3 Posts

·
Registered
Joined
·
13 Posts
Discussion Starter · #1 ·
Well, I've been off the DC emulation scene for quite some time. Actually, I only originally picked it up to test whether or not I should buy a few DC games off ebay.

Anyways, my dreamcast broke last month. It stopped reading GD-roms, and it wouldn't even read audio-CD's. So...I guess I'm back ON the emulation scene.

However, I've been having SERIOUS issues with my two favorite games, Sonic Adventure and Sonic Adventure 2.

this is all on version 1.3, as 1.6 just...well, basically didn't work.

I don't have a screenshot of Sonic Adventure, but I get major slowdown at times, and bad audio, as well as various effects showing up as black boxes. Here are my specs:

Windows Vista x32
4 gigs of ram
ATI Radeon X1250
ATI Athlon 2.0 Ghz Dual-core processor

Now the thing is, Sonic Adventure 2 is just unplayable. And yes, I've tried the vista sound fix.

With Sonic adventure 2, with the Chankast 0.2.5 video plugin, I get black covering my screen. It is absolutely playable, and at certain times will cover my entire screen except for my ring counter.

Now with the NullPVR 1.0.0 (august 2008) plugin, the graphics aren't nearly as bad. Many textures go odd colors, usually grey, and when I walk around as sonic, "bands" seem to come flying in different directions, entirely grey. These might have been intended to be his shadow.

This is really frustrating, as I'm having trouble playing my favorite two games, and I'm also upset my dreamcast broke, and I have both original copies sitting right next to me in their original cases. Sigh.
 
1 - 3 of 3 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top