Next Generation Emulation banner

1 - 6 of 6 Posts

·
Registered
Joined
·
10 Posts
Discussion Starter #1
Can anyone help?

So I have two machines:

1) Weak laptop - Pentium B960 with Intel HD 2000 video. Runs on Windows 7. ePSXe runs flawlessly and silky smooth.

2) Gaming PC. Core i7 7700k and Nvidia GTX 1080. Runs on Windows 10. ePSXe has bad framepacing (feels like frame skipping). Especially noticeable in 60 fps games, like Tekken 3. Framerate stays solid 60 fps though, checked via Rivatuner OSD. Same plugins as on the laptop, same settings except window resolution (internal res is the same - standard/low). Tried compatibility settings, tried disabling fullscreen optimizations, tried different vsync settings via Nvidia control panel and in the GPU plugin settings - nothing helped.

How do I fix that? At first I thought it is DWM related, as I have it disabled for on laptop, but after I enabled it, laptop still runs ePSXe smooth. Also there is no way to disable DWM on Windows 10. On gaming PC ePSXe stutters both in windowed and fullscreen modes. Also checked Tekken 3 arcade version via MAME for a comparison - runs fine.
 

·
deep-space demon
Joined
·
349 Posts
Gaming PC. Core i7 7700k and Nvidia GTX 1080. Runs on Windows 10. ePSXe has bad framepacing (feels like frame skipping). Especially noticeable in 60 fps games, like Tekken 3. Framerate stays solid 60 fps though, checked via Rivatuner OSD.
Yeah because the software detects the framerate of the video output, not the game's own framerate on the emulator.

How do I fix that? At first I thought it is DWM related, as I have it disabled for on laptop, but after I enabled it, laptop still runs ePSXe smooth. Also there is no way to disable DWM on Windows 10. On gaming PC ePSXe stutters both in windowed and fullscreen modes. Also checked Tekken 3 arcade version via MAME for a comparison - runs fine.
Copy these settings and you should be good. Adjust as needed.

ePSXe 3d settings.PNG


For graphics card vram type in 1024- the dropdown menu doesn't have 1024 listed.

Also what might help is changing the sound latency to low in the sound settings

Hope this helps
 

·
Registered
Joined
·
2,149 Posts
also make sure options/cpu overclock is set to x1... any other setting will overclock the simulated cpu resulting in choppy play for many games
 

·
Registered
Joined
·
10 Posts
Discussion Starter #4 (Edited)
Hey there! Thanks for the suggestions! Unfortunately none of them did help. To make the things worse, changing threading mode to 2-Threads made the emulator run at 7fps. Weird.
 

·
Registered
Joined
·
2,149 Posts
something to try ... make a new profile on the win 10 machine and try running it from there....(or even boot into the admin profile)... I had an issue running xebra , it was choppy and stuttered like crazy, but ran fine in a new profile... never did resolve it, something installed on that one profile was interfering
 

·
Registered
Joined
·
8 Posts
I haven't found the exact cause of those slowdowns on ePSXe after several months, but it's actually something in the folder where ePSXe was installed or copied. I recently found this solution by myself:
-Get a zip of PSXe executable (download it if necessary).
-Extract the zip file contents into a new location, don't extract it into the same folder where you had installed or copied the ePSXe file that is having slowdowns (can be extracted into another folder in the same route the previous ePSXe installment is located but with a different folder name).
-Copy the content of the following subfolders from the old ePSXe folder into the new one: bios, cheats, plugins, snap and states.
-Test the new installment of ePSXe, it should work as smoothly as desired.
-Erase/wipe/delete the old ePSXe folder.
-Copy the new ePSXe folder into the route the older ePSXe executable had.
-(needed if you have a Windows shortcut to ePSXe) Rename the copied folder with the name the older ePSXe installment had.
And that's all, open ePSXe again and enjoy.
 
1 - 6 of 6 Posts
Top