Next Generation Emulation banner
1 - 9 of 9 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter · #1 · (Edited)
Hi, I've been browsing these forums a lot to help me set up epsxe, and I've managed to get FFVII looking awesome. The one problem I have is some screen tearing. I have a Radeon HD 3650 using Pete's latest plugin.

Apparently if my monitor refresh rate (60hz) matches the framerate (limited to 60fps), it should be fine. I also tried using 59hz, but the framerate ends up at 59.8fps no matter what I set the limit to, which I don't understand. I saw people talking about epsxe's internal limiter causing problems, but pressing F4 just switches between 680fps odd and 59.8fps.

ATI have removed the vsync option in the latest CCC, so is there any way I can make the frame limit an accurate 59 or 60fps?
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #2 · (Edited)
Here are my settings, by the way.

Plugin: Pete's OpenGL2 Driver 2.9
Author: Pete Bernert
Card vendor: ATI Technologies Inc.
GFX card: ATI Radeon HD 3600 Series

Resolution/Color:
- 1920x1200 Fullscreen - NO desktop changing
- Internal X resolution: 2
- Internal Y resolution: 2
- Keep psx aspect ratio: 2
- No render-to-texture: 2

- Filtering: 4
- Hi-Res textures: 0
- TexWin pixel shader: on
- VRam size: 256 MBytes

Framerate:
- FPS limitation: on
- Frame skipping: off
- FPS limit: 60.0

Compatibility:
- Offscreen drawing: 1
- Framebuffer effects: 2
- Framebuffer uploads: 1

Misc:
- Scanlines: off
- Mdec filter: on
- Screen filtering: on
- Shader effects: 5/4
- Flicker-fix border size: 0
- GF4/XP crash fix: off
- Game fixes: on [00000002]

I was just trying different combinations with the internal plugin and Pete's plugin, but it ends up at 59.8fps no matter what I set them to, whether 59 or 120.

Okay, so it turns out that if you press the Home key, it changes to the chosen setting... I was googling for ages, and didn't see this mentioned anywhere. It still didn't solve my problem though.

I've tried just about every combination of settings already, just to see which ones look best, so I guess I'm not going to be able to solve this flickering/tearing problem. It's not terrible, but it's noticeable every few seconds when I'm moving across a scene.
 

·
No sir, I don't like it.
Joined
·
5,571 Posts
The NTSC broadcasting standard is 59.94Hz. It's not an exact 59Hz or 60Hz. It's just easier to call it "60Hz".

I'm not exactly sure why you are getting tearing artifacts, but it is generally attributed to VSync being off. Try forcing VSync ON and turning off all of ePSXe's frame limiters (both the plugin and internal frame limiters).
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #4 ·
It only happens when moving along a screen, not when stationary or during battles, FMVs, etc. It doesn't seem to happen on the world map as much either, just when I'm in town. It's the same with FFVIII and MGS as well. Is this consistent with what you're thinking?

I'm not sure how to even turn on VSync. The ATI Catalyst Control Centre doesn't appear to have the option any longer. It's not possible through any other means is it?
 

·
Banned
Joined
·
23,263 Posts
If you are using the internal SPU plugin, disable frame limiting.
if you are using using Eternal SPU, disable frame limiting and set the spu plugin to SPUAsync:Wait.

CCC still has the vsync option...... its at the very bottom of the advanced settings.
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #6 ·
I attached a picture of the new CCC interface. Is this the one you're using? I saw somebody complaining about VSync being removed in the latest version, and reverting to an older version. I've looked through all the options, but definitely can't see it. I even refered to the help file, and it mentions tabs and menus that don't even exist.

I tried the SPU settings, but it's still not solving the problem. It would really be perfect without the tears, so it's kind of frustrating :(
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #7 ·
Turns out it hasn't been removed. It's under 3D > All > Wait for vertical refresh. You have to set it to Always on. So the term VSync never actually appears... I didn't realise 'All' was even a set of options either, the interface is kind of misleading.

Incidentally, do you have any recommendations for the settings in there? Should I enable adaptive anti-aliasing or triple buffering?
 

·
Banned
Joined
·
23,263 Posts
Actually, antialiasing doesn't require a Zbuffer, it just requires a texture large enough to get a valid colour sample.

However, AA only works on the 1.x plugins as 2.0 renders in such a manner that the AA step is skipped.

also triplebuffering does help improve frame rates, but introduces controller lag.
 
1 - 9 of 9 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top