Next Generation Emulation banner

1 - 7 of 7 Posts

·
Premium Member
Joined
·
5,309 Posts
Discussion Starter · #1 ·
Beta Date: 17 04 05
Conditions Tested Under:

GSdx (SSE2) 0.6 - PS2.0 - Hardware mode [17 04 2005]
P.E.Op.S. SPU2 DSound Driver 1.2 [25 12 2004]
PADwinKeyB Driver 0.8 [12 12 2004]
P.E.Op.S. CDVD Driver 1.2 [29 03 2005]
DEV9null Driver 0.2 [17 12 2004]
USBnull Driver 0.3 [17 12 2004]
FireWireNull Driver 0.4 [27 02 2005]
Europe v01.90(23/06/2003) Console
REC

During the intro sequence, most effects are not displayed, and the following error op_ot_draw() ... timeout, floods the console.

Goes through to the main menu, but select 'new game' and it hangs on the first intro video occasionally showing 'Sub Text' for the video with the following error:

*PCSX2*: warning v->size != size

Requires this patch to get into the intro:

9AAC5309
Code:
gametitle=Final Fantasy X-2 [SLES 51815][PAL-UK]
comment=Skips Sound Initialisation
//skip INIT SOUND
patch=0,EE,00132488,word,00000000
Status
Menus
 

·
Premium Member
Joined
·
5,309 Posts
Discussion Starter · #2 ·
Beta Date: 27 04 05
Conditions Tested Under:

GSdx (SSE2) 0.6 - PS2.0 - Hardware mode [23 04 2005]
P.E.Op.S. SPU2 DSound Driver 1.2 [25 12 2004]
PADwinKeyB Driver 0.8 [12 12 2004]
P.E.Op.S. CDVD Driver 1.2 [20 04 2005]
DEV9null Driver 0.2 [17 12 2004]
USBnull Driver 0.3 [17 12 2004]
FireWireNull Driver 0.4 [27 02 2005]
Europe v01.90(23/06/2003) Console
REC

Same issues as above, though intro, and logo are no longer displayed :( However GSdx and GSsoft both now display the openning move...kind of....high PPF count during it (I assume due to overlayed 'sub text'). Shots taken with GSsoft, however GSdx displays the same. (People who have played the game will recognise it ;) :p )

Requires this patch to get into the intro:

9AAC5309
Code:
gametitle=Final Fantasy X-2 [SLES 51815][PAL-UK]
comment=Skips Sound Initialisation
//skip INIT SOUND
patch=0,EE,00132488,word,00000000
Status
Menus
 

·
Premium Member
Joined
·
5,309 Posts
Discussion Starter · #3 ·
Beta Date: 02 07 2005 [linuz SCII fix 1]
Conditions Tested Under:

GSdx9 (SSE2) 0.9 - win,D3D,PS2.0,LTF [02 07 2005]
PADwinKeyb Driver 0.9 [14 05 2005]
P.E.Op.S CDVD Driver 1.2 - IOCTL,D:\,Thread,1|0,0,0|1,0|0 [14 05 2005]
USBnull Driver 0.4 [14 05 2005]
P.E.Op.S. SPU2 DSound Driver 1.2 - 1,3,0,0|0,0|0,0,0,0 [25 12 2004]
DEV9null Driver 0.3 [14 05 2005]
FWnull Driver 0.4 [16 05 2005]
Europe v01.90(23/06/2003) Console
eeREC | rCache 0 | Console 1 | Patches 1

In order to bypass the mpeg, the following patch is now used, with skip voice / sound.

Code:
gametitle=Final Fantasy X-2 [SLES 51815][PAL-UK]
comment=Various Patch's to get ingame.
//skip "INIT SOUND"
patch=0,EE,00132488,word,00000000
//skip "INIT VOICE"
patch=0,EE,0013249c,word,00000000
//skip InvalidDCache | SyncDCache
//patch=0,EE,0034b170,word,03e00008
//patch=0,EE,0034b174,word,00000000
//skip AC3+PCM start (NOPs whole subroutine)
//patch=0,EE,0017a750,word,00000000
//skip "decode MPEG2"
patch=0,EE,0017a580,word,03e00008
patch=0,EE,0017a584,word,00000000
patch=0,EE,0017a4c8,word,03e00008
patch=0,EE,0017a4cc,word,00000000
Game will randomly 'freeze' in a battle. By freeze, the characters just stand there, the ATB bar will not fill, yet camera etc still moves around...

Same terrain holes bug as FFX.

Menus and all 2D are WAY faster, but lacking effects, and start screen is missing parts. Game can hang on loading a game wtih a DVDread 0 bug again. (So ****ing often, that I didn't get any shots this time around ;) )

Status
Ingame
 

·
Premium Member
Joined
·
5,309 Posts
Discussion Starter · #4 · (Edited)
Beta Date: 10 07 2005 [current CVS]
Conditions Tested Under:

GSdx9 (SSE2) 0.9 - win,D3D,PS2.0,LTF [10 07 2005]
PADwinKeyb Driver 0.9 [14 05 2005]
P.E.Op.S CDVD Driver 1.2 - IOCTL,D:\,Thread,1|0,0,0|1,0|0 [14 05 2005]
USBnull Driver 0.4 [14 05 2005]
P.E.Op.S. SPU2 DSound Driver 1.2 - 1,3,0,0|0,0|0,0,0,0 [25 12 2004]
DEV9null Driver 0.3 [14 05 2005]
FWnull Driver 0.4 [16 05 2005]
Europe v01.90(23/06/2003) Console
eeREC | rCache 0 | Console 1 | Patches 1

Using GSsoft, you can recognise some of the video. GSdx renders poop. Game always locks up (if skipping video) on DVDread 0.

Status
Menus
 

·
Premium Member
Joined
·
5,309 Posts
Discussion Starter · #5 ·
Beta Date: 12 07 2005 [current CVS]
Conditions Tested Under:

GSdx9 (SSE2) 0.9 - win,D3D,PS2.0,LTF [10 07 2005]
PADwinKeyb Driver 0.9 [14 05 2005]
P.E.Op.S CDVD Driver 1.2 - IOCTL,D:\,Thread,1|0,0,0|1,0|0 [14 05 2005]
USBnull Driver 0.4 [14 05 2005]
P.E.Op.S. SPU2 DSound Driver 1.2 - 1,3,0,0|0,0|0,0,0,0 [25 12 2004]
DEV9null Driver 0.3 [14 05 2005]
FWnull Driver 0.4 [16 05 2005]
Europe v01.90(23/06/2003) Console
eeREC | rCache 0 | Console 1 | Patches 1

If I skip videos / voice init / sound init I can get ingame, where it will go into a perminent loop (3D graphics move, but it never progresses). Nice holey syndrome :D

Status
Ingame
 

·
Premium Member
Joined
·
5,309 Posts
Discussion Starter · #6 ·
Beta Date: 18 07 2005 [pcsx2viflinuzFIX1]
Conditions Tested Under:

GSdx9 (SSE2) 0.9 - win,D3D,PS2.0,LTF [10 07 2005]
SSSPSX PAD Plugin 1.6 [25 06 2005]
P.E.Op.S CDVD Driver 1.2 - IOCTL,D:\,Thread,1|0,0,0|1,0|0 [14 05 2005]
USBnull Driver 0.4 [14 05 2005]
P.E.Op.S. SPU2 DSound Driver 1.2 - 1,3,0,0|0,0|0,0,0,0 [25 12 2004]
DEV9null Driver 0.3 [14 05 2005]
FWnull Driver 0.4 [16 05 2005]
Europe v01.90(23/06/2003) Console
eeREC | rCache 0 | Console 1 | Patches 1

Characters are solid again. Thanks to some memcard saves I am able to get ingame even further. But (spu related?) DVDread 0 (normally with some 'wav' information in between reads) stops most areas loading, or will put the game into a perminant loop (could it be due to the patch....but patch is needed to even get this far).

Videos can be skipped thankfully, but obviously are not working.

Battles most of the time can't be completed due to looping (it's like the game is still running, but just forgets to do the next thing, eg animations etc still run, just ATB bars etc never fill).

Terrain has massive holes in it.

So all in all, not the best, but hey these saves prove that ingame is working-ish. Without saves, you can skip the first intro video, and enter the first battle, but due to that 'loop' bug, you will never get past it.

Status
Ingame
 

·
Premium Member
Joined
·
5,309 Posts
Discussion Starter · #7 ·
Beta Date: 03 08 2005 [Refraction Timer]
Conditions Tested Under:

GSdx9 (SSE2) 0.9 - win,D3D,PS2.0,LTF [25 07 2005]
SSSPSX PAD Plugin 1.6 [25 06 2005]
P.E.Op.S CDVD Driver 1.2 - IOCTL,D:\,Thread,1|0,0,0|1,0|0 [14 05 2005]
USBnull Driver 0.4 [14 05 2005]
P.E.Op.S. SPU2 DSound Driver 1.2 - 1,3,0,0|0,0|0,0,0,0 [25 12 2004]
DEV9null Driver 0.3 [14 05 2005]
FWnull Driver 0.4 [16 05 2005]
Europe v01.90(23/06/2003) Console
eeREC | rCache 0 | Console 1 | Patches 1

Patch still needed (note that FFX no longer needs SKIP VOICE / SOUND INIT, but FFX-2 still needs it to even display logo). Characters are solid, game / areas will always load now :D :D :D :D

Still encountering DVDread: 0 , and game will still randomly enter a loop during the first battle. If loading from a save, gameplay is fine, but again battles will loop.

Terrain as holey as ever.

Status
Playable
 
1 - 7 of 7 Posts
Top