Next Generation Emulation banner
1 - 14 of 14 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
Greetings,

I'm sorry this is my first post here but I would be really grateful if anyone can help me.

I have a brand new copy of FF9 for the PSX. I've made disc images and decided to emulate.

The game has run without a problem up until now. I'm early on disc 2 just as you enter Cleyro's trunk the screen goes black to load the next screen and goes no further. I've tried loading from a previous state with no luck.

I'm using ePSXe 1.7 with Pete's latest OpenGL plugin. My drivers are up to date.

I'm just hoping someone has an idea of how I can progress the game?

I appreciate the help. Thanks and nice to meet you all
 

·
Banned
Joined
·
23,263 Posts
rip the game into the CCD/MDF or NRG formats, then mount them using a virtual drive. use SAPUCDR t o read them from the virtual drive.
 

·
From Love and Limerence
Joined
·
6,574 Posts
Not to point any accusations, but to point out what the problem may be, but this is a recurring spot alot of people seem to get stuck on. Nobody ever mentions any special conditions, which leads me to believe there are none. I'm guessing they're all using the same ISO of a badly ripped game (unless this is a troublesome spot under certain conditions, like the Bahamut and Alexandria scene with save states). If so, that's your problem.

Past that, not providing hardware specifications and plug-in configurations doesn't help.

Did you try loading from an in game save (via Moogles), or a save state?
 

·
Banned
Joined
·
23,263 Posts
Converting 1 format to another can introduce read errors.

the internal and plugin reading can also have read issues at times (don't. know. why) But Sapu CDR has always managed to get past black screen issues.
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #5 ·
Thanks for the replies.

I made the ISOs myself using a brand new factory sealed copy. I've tried using the original disc with Sapu's CDROM plugin with the same result. I've also made a second ISO which I've mounted as a virtual drive, again using Sapu's plugin, which did the same as well.

I haven't used a single moogle save as I read they were troublesome with disc changes. So I've only ever used Save States.

Does anyone have any more ideas how I can progress on? Its the only one on the PSX I never completed as a kid :)

Thanks again for the help
 

·
Banned
Joined
·
23,263 Posts
It might be Libcrypt. the PAL copies of FF8 and FF9 use that protection and it isn't compatible with the ISO format, which makes an image archive of the contents of the disk, rather then an image of the disk itself. Thats why i mentioned using different image formats.

It could also be the save states... and no there are no issues with moogle saves with disk changes (not that i've come across)
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #7 ·
Your correct it was something to do with the save state. I loaded the game back up, got to the world map and moogled saved. Restarted the game and loaded the moogle save. I was then able to get past the black loading screen........thankfully.

Should I not be using save states again then?

Thanks for all your help guys really appreciate it.
 

·
Banned
Joined
·
23,263 Posts
You can use save states, but should save to a save point when you decide to quit prior to save stating
 

·
From Love and Limerence
Joined
·
6,574 Posts
So this is another troublesome save state spot and not necessarily an indication of a downloaded ISO then.

Yes, another spot that comes up often where save states cause a freeze is during disc 3 in Alexandria during the card tournament in Treno, so there's at least one more.

As recommended, I use save states for quick loads in case I need to backtrack on that playthrough. I don't use them as my actual saved games. There's no issues with using moogle saves.
 

·
Banned
Joined
·
23,263 Posts
there are 3 or 4 points where the game will freeze using the internal cdr plugin, even on perfect disks. during a scene change.
 

·
From Love and Limerence
Joined
·
6,574 Posts
Ah, well I've always used an ISO (except during testing settings once with another PC), of my perfect condition discs, in fact (used only to make the ISO and originally intended to replace my older copy), so I wouldn't know.
 

·
Banned
Joined
·
23,263 Posts
;) so was i i just prefer an external virtual drive, over the internal image loading.

I'm trying Tas/Linuziso atm
 
1 - 14 of 14 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top