Next Generation Emulation banner

1 - 20 of 36 Posts

·
Registered
Joined
·
111 Posts
Discussion Starter · #1 ·
I'm using Lord Kane's Pete's OpenGL 1.76 recommendation from here:

http://www.lordkane.co.uk/images/FF8-OGL1.png

1) Does setting Framebuffer Textures and Access to 0 kill any interesting effects in the game other than the battle swirl and some screen fading in/out effects? The battle swirl doesn't work correctly with the OpenGL1 plugin but with these 2 set to zero it doesn't look as bad.

2) When I leave certain areas in the game, like Garden, the screen doesn't fade out any more and just stays there, followed by some display corruption and then goes to the world map. Is there any way to get the effect with the plugin?

SPECS: Radeon 9700 Pro, Athlon XP 1800, 512 Ram, Windows XP, Pete's OpenGL 1.76 plugin
 

·
Premium Member
Joined
·
6,341 Posts
If it kills stuff like the swirl and transitions, it's killing anything framebuffer related. You should try using OpenGL2 with that card, although the transitions are screwed in it. If you get the swirls to work, there's flickering health/limit break boxes in battle and if you fix the flickering, the swirls get broken. Other than that, it seems to work very well :).

Edit: I spent a little bit of time fooling around with Pete's OpenGL plugin and I believe I've found the perfect settings for FF8. I'm not sure if it's been posted before though :p.

Plugin: Pete's OpenGL Driver 1.1.76
Author: Pete Bernert
Card vendor: NVIDIA Corporation
GFX card: GeForce 6800 GT/AGP/SSE/3DNOW!

Resolution/Color:
- 640x480 Window mode
[32 Bit]- Keep psx aspect ratio: off

Textures:
- R8G8B8A8
- Filtering: 0
- Hi-Res textures: 0
- VRam size: 256 MBytes

Framerate:
- FPS limitation: on
- Frame skipping: off
- FPS limit: Auto

Compatibility:
- Offscreen drawing: 3
- Framebuffer texture: 2 [highlight](or 1)[/highlight]
- Framebuffer access: 1
- Alpha multipass: on
- Mask bit: on
- Advanced blending: on

Misc:
- Scanlines: off
- Line mode: off
- Unfiltered FB: off
- 15 bit FB: off
- Dithering: off
- Screen smoothing: off
- Screen cushion: off
- Game fixes: off [00000000]

Using those settings, I got nice swirls and no flickering in battle. I just need to try summoning a GF.
 

·
Premium Member
Joined
·
6,341 Posts
I was quite shocked to find out that those settings fixed both the swirl and the various stats in battle, usually it's one of the other that are fixed. I don't recall seeing any other FF8 settings like this but I'll look around throughly before I make any claims to the ultra l33t FF8 settings :p. Good to hear it's working on an ATi card just fine, I was worried that it might not have handled the framebuffer texture setting well (ATi cards aren't too great with framebuffer stuff).
 

·
Classic Games Lover
Joined
·
5,280 Posts
Wow, really awesome settings, n_w95482. They also work perfectly on my GF 2MX, although the music is a bit slow. No flickering during moving between locations and the battle swirl is very cool. GFs work perfectly as well, just look at the pics :)
 

·
Premium Member
bsnes, ePSXe
Joined
·
21,978 Posts
n_w95482 said:
I didn't have AA turned on at the time of testing.
hmm...i'll have to do that testing then, i want to see with texture filtering and AA.....
 

·
Premium Member
Joined
·
6,341 Posts
I wonder how it'll run with 8xS AA turned on :p. I've also made a 30 second video of the settings in case anyone wants it.

Edit: Here's a picture showing the above settings with 8xS AA added as well as texture filtering set to 6. It looks quite nice :). I noticed some framebuffer glitches in the Fire Cavern (some of that weird blackness) but it's nowhere near as bad as before and it seemed to fix itself after a few battles.

 

·
Registered
Joined
·
111 Posts
Discussion Starter · #10 ·
n_w95482 Question: When you are on the world map (like just before you get to the Fire Cavern), if you open your menu and close it again, do you see some display corruption for a second? Just curious if this happens with Geforce cards too.
 

·
Premium Member
Joined
·
6,341 Posts
emusnicker said:
n_w95482 Question: When you are on the world map (like just before you get to the Fire Cavern), if you open your menu and close it again, do you see some display corruption for a second? Just curious if this happens with Geforce cards too.
Yes, I get the corruption as well. Does it look like this on your computer?

 

·
Registered
Joined
·
111 Posts
Discussion Starter · #13 ·
n_w95482 said:
Yes, I get the corruption as well. Does it look like this on your computer?

Yeah. It doesn't seem to happen outside of the worldmap though so I guess it's all good. Seems to be an OpenGL plugin issue.
 

·
Registered
Joined
·
152 Posts
Damn, I spent ages trying to get it to work, I found a near perfect config but not perfect, or close enough to perfection, like this one (apparently, haven't tested yet).
Could it be the update that fixed this, coz I haven't done any testing with the latest updates of the plugins (last OGL I used - 1.75, OGL2 - 2.7).
Anyway, maybe that means OGL2 works well too? I can't test right now, but if no one has, I'll do it sooner or later.
 

·
Registered
Joined
·
111 Posts
Discussion Starter · #15 ·
dutchMasta said:
Could it be the update that fixed this, coz I haven't done any testing with the latest updates of the plugins (last OGL I used - 1.75, OGL2 - 2.7).
Fixes what? The battle swirl?
 

·
Registered
Joined
·
152 Posts
Yeah, the battle swirl, sorry, should've said that.
 

·
Premium Member
Joined
·
6,341 Posts
I tried lowering framebuffer textures from 2 to 1 and it seemed like the corruption when exiting the menu is less severe. I tried one battle and everything seemed to still work okay.
 

·
Registered
Joined
·
111 Posts
Discussion Starter · #18 · (Edited)
One annoying problem I found is that the display corruption (from closing the menu on the world map) sometimes also occurs before/during certain movie sequences in the game (about half of them, like the cutscene at the end of Disc 1 with Squall in the car).

The special game fixes "lazy upload detection" and/or "swap front/back detection" fix this (in the movies), but create other issues. Lazy upload messed up the videos in other ways and swap front/back removes some effects in the game, like fading in/out.
 

·
Registered
Joined
·
6 Posts
I'm trying to run FF8 using ePSXe and Pete's D3D Driver 1.76, Pete's DX6 D3D Driver 1.76, Pete's OpenGL Driver 1.76, and Pete's OpenGL2 Driver 2.7 and none of them work. All of the plugins except for the OpenGL2 driver, run the game at a super fast speed. Also, some show the HP for my characters in battles and some don't. I am using the real NTSC PSX discs to play. I am also trying to use these plugins through a PSX cheater called PSX Emulation Cheater Build 1123.

When I use the settings listed above, the game moves super slow. Any suggestions otherwise?
My system specs are:

WinXP SP2
P4 2.1GHZ
128MB Nvidia Ti4200

If anyone can direct me to a plugin that would be appropriate and fix these problems or know how I can slow down the game, I would really appreciate it. Thanks.
 

·
Premium Member
bsnes, ePSXe
Joined
·
21,978 Posts
just for further noting, please do not make multiple posts about the same thing. i've answered your question in this thread and closed your made thread. to everyone else, please ignore the post in this thread.
 
1 - 20 of 36 Posts
Top