Next Generation Emulation banner

FF9 + Pete's Soft GPU plugin

3463 Views 7 Replies 3 Participants Last post by  sights
Hi, a friend of mine has just completed FF9 on his playstation, so I was FINALLY able to borrow it and give it a go on my pc. While it works great with Pete's OpenGL and D3D GPU plugins, I thought I'd give it a try with Pete's Soft plugin (I've got a soft spot for Pete's Soft plugin - excuse the pun ;) ). When I try it though, it just gave me an "illegal operation" error with the following details:

EPSXE caused an invalid page fault in
module GPUPETESOFT.DLL at 017f:0159452a.
EAX=00000000 CS=017f EIP=0159452a EFLGS=00010202
EBX=015502b8 SS=0187 ESP=00b1fd58 EBP=00000140
ECX=00000140 DS=0187 ESI=00000140 FS=4027
EDX=000001ff ES=0187 EDI=015502b8 GS=0000
Bytes at CS:EIP:
f3 ab 8d 1c b3 8b 74 24 24 03 de 4a 75 de 5f 5e
Stack dump:
00000000 00000280 00071e40 005bfe21 015a9653 00000000 00000140 00000280 005c0020 00000300 02000000 00000003 00071e4c 005b4200 015a8842 0062604c

I thought maybe there was some problem with the intro movie, so I tried to boot the 2nd FF9 disk, but to no avail.
Then I tried Pete's Soft plugin with FF9 on FPSE but the problem persisted. I even tried it on a whole diffirent computer (my old P200) and still got the same result.

This is pretty strange since Pete's Soft plugin was by far the most compatible (being the nearest thing close to real PSX's graphics) with dozens of other games I've tried. Has anyone encountered this kind of problem before ? Any advice ?
1 - 5 of 8 Posts
Oh, I forgot to post my specs, in case it helps :

cpu: P3/800 Mhz
vga: TNT2 Ultra - AGP
ram: 512 MB

I also tried both 1001 and 7502 bios, played with the PAL / NTSC options in the "country" settings, and finally tried switching the resolution of the plugin and my desktop to 16-bit, but it didn't work.
Hmmm !! ...then I guess its one of those "mysterious incompatibility" situations that arise every now and then among PC users ...damn those PCs !!! ...when you think you've got them set up just right, something like this comes up :( That's why I hate it when people refer to PCs as "compatibles" ...not quite compatible now, are they ?

Anyway, thank you Pete, for getting into the trouble to check this problem out :) ...I'll just use your excellent OpenGL GPU plugin with FF9.

If anyone else happens to experience this same (weird) situation, and manages to find a solution, please remember this thread and by all means post it !!!
Yep, both these soft. plugins also crash with an "illegal operation" error. I don't know how they perform in comparison with other games, its the first time I actually use them - I was using Pete's plugins all the time.
Now, before the crash, I haven't noticed anything major to occur ...there is a small pause and then the "crash" :dead:

Oh, its the NTSC version of the game.
This last trick looked like as it may miraculusly do it, but nope, didin't work too... its me and my bad luck I guess :(

Anyhow, thanks for everything Ben :)
1 - 5 of 8 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.