Next Generation Emulation banner

Status
Not open for further replies.
1 - 20 of 24 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter · #1 ·
Hello,

Whenever any monster casts "Thundaga" spell the casting animation starts but then the enemy monster just stops and doesn't finish the spell. The game itself doesn't freeze, but seems to just wait for him to finish the spell which never happens.
Right now I'm stuck at the desert palace boss mob (third disc).

Here's a video about the problem: (You'll need xvid or ffdshow to play)

FF9problem (20mb)

I found a year old thread about the same issue, but no real solution was offered. Except that save the memcard and kill the boss at your friend's house.

I'm using ePSXe 1.5.2 & ISO's of the PAL version.
I'm not using any patches to run the game.
Tried Pete's D3D and OpenGL plugins, neither works.
Open GL2 I can't try since nVidia doesn't support it in their drivers.

Anyways I doubt that this is a graphics plugin problem. The game itself doesn't freeze or anything. It's just like the commands start to hang.

Any help would be appriciated :)
 

·
Classic Games Lover
Joined
·
5,280 Posts
For me it seems that the game can't load the data with Thundaga spell from your ISO. I presume that it may be corrupted or something. Did you try to run the game from CD?
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #4 ·
hushypushy said:
load your save in PSXeven or PCSX
Okay thanks for the tip. I'll try if this helps :)
 

·
Classic Games Lover
Joined
·
5,280 Posts
Hmm, did you make those ISOs with subchannel reading enabled? Maybe that's the case. You could also need ppf file for FF9 PAL.
 

·
Banned
Joined
·
46 Posts
I would like to raise this nearly-dead post and state that I'm having the same problem. However, the game does not crash EVERY time someone tries to cast Thundaga, only most of the times - and it happens for some other skills, too, although less frequently.

I would assume this is due to some effect or another those spells use (lighting would be my guess). Any insight on this matter?
 

·
Registered
Joined
·
1,558 Posts
well it does look like a corrupt iso is to blame. Or maybe a dirty cd. Make sure the cd is clean and free of scratches before making isos.
 

·
Premium Member
bsnes, ePSXe
Joined
·
21,978 Posts
did you follow the advice already said? i.e. use a different emulator, not save states...perhaps using a software plugin?
 

·
Banned
Joined
·
46 Posts
Save states have nothing to do with it, apparently, as I can get it to crash from a memory card save, and to sometimes NOT crash from save states. I've never tried using different emulators; was mostly waiting for Anvirol's input on that matter. I guess we could assume from his silence that his problem has been resolved.

I've seen it crash from CDs 1 and 2 as well, so I would assume that it IS the emulator. I guess I'll be conducting my own experiments on that matter...

Edit
PSXEven gets the same results against dragons casting Thundaga.
Trying PCSX now.

Edit2
...which I couldn't get to work. I guess I'll return to my days of save-state-every-combat-and-reload-if-it-crashes... Ho well.
 

·
Registered
Joined
·
51 Posts
Wow, that looks really irritating IMO. I doubt using 1.6.0 would fix is as it seems (I think) FFIX Disc 3 PAL ISO is corrupted. BTW, the reason I said 1.6.0 wouldn't solve it is because when the ePSXe team developed it, it fixed many things as well as breaking many things at the same time. I would try cleaning the original disc and then ripping it again. Use Delta 2.01, it has ISO-ripping features.
 

·
Premium Member
bsnes, ePSXe
Joined
·
21,978 Posts
have you tried using completely different plugins, to make sure it isnt a plugin problem. by changing out things you can isolate it. so we know that its probably not the emulator (since PSXeven does the same thing). try a different graphics plugin (like software), try a different SPU plugin (pete's dsound, or even the newer 1.5 beta of Eternal), try a different CD plugin....just troubleshoot lik ethat.
 

·
Banned
Joined
·
46 Posts
Plugins? Alright. I've tried (with many configurations and using ePSXe 1.52), the following video drivers:
Pete's OpenGL 1.75
Pete's OpenGL2 2.6
Lewpy's 3dfx/Glide3 GPU 1.40
P.E.Op.S. Soft Driver 1.16 (crashes - had to hard reboot)

All of them (except PEOpS) caused the Thundaga bug.

I tried those sound drivers (Using Pete's OpenGL 1.75 video driver, as it was the most stable in my experience):
ePSXe SPU core 1.5.2.
Eternal SPU Plugin 1.41
Eternal SPU Plugin Lite 1.41
P.E.Op.S. DSound Audio Driver 1.8

None of those plugins could avoid the Thundaga bug either.

If anyone has other options to try, I'll be happy to oblige. In the mean time, I'll keep avoiding Thundaga casters (All hail the Silence spell!)
 

·
Registered
Joined
·
51 Posts
Alright, I know it may not solve your issue, but have you tried updating
the SPU plugin? Or perhaps trying Eternal SPU 1.41? Usually, for some reason, changing things like that can solve the most obscure issues. If you don't have it, I can give it to you.
 

·
Premium Member
bsnes, ePSXe
Joined
·
21,978 Posts
so Peops fixed it eh. seems like all the hw plugins caused problems...so, have you tried changing your graphics drivers? either upgrading or downgrading them.
 

·
Believe in Harmony
Joined
·
172 Posts
hmmm, the software gfx plugin should actually be the most compatible since it doesn't require a high-end graphics card to get excellent visuals. I'm not sure why it should be crashing on you. Definitely try version 1.17 though, that's the newest one.
 

·
Banned
Joined
·
46 Posts
gaijinx : Eternal SPU Plugin 1.41 is in the list of plugins I tried; didn't work either.

hushypushy : Maybe I wasn't quite clear, but peops didn't cause the Thundaga bug because the program actually crashes before I can actually reach that part...

Unknown One : I will try getting the latest software graphic plugin as you suggested. I suspect the crash isn't plugin-related at all, though.
Edit

Tried the latest software plugin, and it still crashes (though I was able to get it back without a hard reboot). It only crashes in full screen mode, apparently, so I tried in windowed mode. I still got the Thundaga bug.

Thanks for the help, everyone. I guess this problem is there, but it does not completely prevent me from playing the game, so I'll just keep going on, I guess...
 

·
Premium Member
bsnes, ePSXe
Joined
·
21,978 Posts
ninor said:
hushypushy : Maybe I wasn't quite clear, but peops didn't cause the Thundaga bug because the program actually crashes before I can actually reach that part...
wow, thats weird. so it crashes at a DIFFERENT part when using Peops? odd...
 

·
Registered
Joined
·
332 Posts
You're at the 3rd disc, does the crash appear in the other discs? I'm pretty sure this is disc-related (remake iso/ clean cd/ use another one).
 

·
Banned
Joined
·
46 Posts
As it was suggested, it was a cd problem. CD 4 works just fine.

On a side note (slight spoiler ahead), beating Kuja at the end of CD 3 was a pain. Not only is he the third boss in a row, but he uses Thundagas like they grew in trees, and no amount of state saving/reloading will prevent that. The only way I found of defeating him (after a few hours of crashing), was to equip everyone with the ability "Auto-Reflect", making him not cast Thundagas, but instead... Flare-star, a non-elemental high-damage all-target spell. And I can't use Curaga either.

I beat him, but it definetely was a difficult experience...
 

·
Premium Member
bsnes, ePSXe
Joined
·
21,978 Posts
hmm, i wonder if this has anything to do with FF9's copy protection features. i know a lot of people have beat FF9 PAL without problems. would you mind posting your PAL version (what country etc or whatever) and the disc SLUS? is it greatest hits? maybe we can isolate the problem to a particular set of discs or game versions....
 
1 - 20 of 24 Posts
Status
Not open for further replies.
Top