Next Generation Emulation banner

1 - 9 of 9 Posts

·
Registered
Joined
·
11 Posts
Discussion Starter · #1 ·
Good day to most of ngemu!
I tried to play FF8 on 3 plugins : pete's D3d, pete's opengl and pete's opengl2 but it has problems on each of them: (In addition to crappy battle transitions in opengl and D3d, but I don't care much about that)
D3D : The game pauses for a few moments when changing screens
opengl : when changing screens, the characters 'blink' while the screen fades : their positions constantly changes between 2 different positions
opengl2 : in battle, the ABS bar (that thingie that determines who goes after who) constantly blinks.

My specs are an nvidia 5200 a ~3 ghz computer and winXP. (oh and I'm using 1.5.2)

Please help! Thanks!
 

·
Premium Member
Joined
·
26,303 Posts
Try the configs on my site.
 

·
Registered
Joined
·
4 Posts
Hey, I just started FF8 using OpenGL2, and the only thing I can really see wrong with it is the same problem he had, the ABS bar constantly blinking when I used your settings. If I change the frame upload from 0 to 1, the ABS bar doesn't blink, but the area around the bars starts spazzing. I can't seem to figure out how to fix that. Also, when changing screens, sometimes the characters will flicker back and forth between positions, but that's probably not fixable.
 

·
Premium Member
Joined
·
26,303 Posts
Is the flickering bar really that big an issue?
I didn't even notice it until you mentioned it to me. I tried playing with some settings, and enabling the special game fixes solves the border problem in 2/2 mode
 

·
Registered
Joined
·
4 Posts
That's weird, because I always have the special game fixes on, and it still does that. The only one you turn on is the "Ignore small framebuffer moves," right? I'm using OpenGL 2.5, I think, if that makes any difference. And no, it really isn't that big of a deal, but I was just wondering since in reality it *shouldn't* do that. There's also a bit of skipping/slowdown in the world map and during long battles when the music skips a beat for no reason (I'm pretty sure my ISOs are near perfect), but some things just can't be helped.
 

·
Premium Member
Joined
·
26,303 Posts
FF8 has a number of issues with it in various forms, and I'm not sure if the settings are perfect (it's not like I played the entire game with them), but 2/2 with hte small FB updates fix should give you a flicked without the oddness around the boxes, correct swirls, but slowdowns at certain points due to FB calls.
Setting it to 3/2 removes the pauses, but messes up the battle swirls and gives fou odd boxes round the ATB gauges

edit: just thought I'd mention: I'm always grateful to find out issues I haven't noticed with my settings. The more feedback I get like this the better.
Of course the people who post about problems which are solved by my configs just piss me off :p
 

·
Registered
Joined
·
4 Posts
Alright, let me try 2/2 with small FB updates and see what happens, although I'm fairly sure that I've tried it before to no avail. And I don't think I've ever gotten correct swirls, but I've accepted that as long as it doesn't cause slowdown (which does occur in some messed up configs).

Edit: Yikes! With the 2/2 and FB, everytime I change screens, everything looks terrible. Half the screen will go black with the other half flickering wildly, and sometimes the screen will be filled with multiple colors. I will investigate further, though. Do you know if Off-Screen Drawing has anything to do with this? I have mine at 1 right now.

Also, in your picture, I know it may seem redundant and obvious to most people, but you don't have the Special Game Fixes box checked, so you might want to check it as not to confuse anyone who is trying to follow your picture 100% by the book.

Last thing, just recently when I mess with the settings, sometimes the text fails to show up in game and everything is just a bunch of black boxes. Even when I revert to your original settings they are still there. It was working just fine yesterday, so I have no idea what this is about. Once, it fixed itself, but then the next time I messed with the settings, it went back to black boxes.

Ah, I believe the black boxes are caused by usage of save states. I've been using a couple save states to test battles and transitions since I'm at a story-based point in the game, and after talking to someone, the text seems to revert to normal. ...............Except that I just tried it with 2/2, and the text remained black even after stepping on a save point to try to reset the text. How frustrating!

I guess that wasn't the last thing, because I forgot to mention that I think save states may mess up the analog input of the game. Many times as I've been checking this stuff out, the analog fails to respond when I use a save state. I'm pretty sure it works fine if I let it load normally, but I can't be perfectly certain.
 

·
Premium Member
Joined
·
26,303 Posts
>Edit: Yikes! With the 2/2 and FB, everytime I change screens, everything looks terrible. Half the screen will go black with the other half flickering wildly, and sometimes the screen will be filled with multiple colors. I will investigate further, though. Do you know if Off-Screen Drawing has anything to do with this? I have mine at 1 right now.

Off the top of my head, no. I suppose I'll need to play a bit more thouroughly to update the settings.

>Also, in your picture, I know it may seem redundant and obvious to most people, but you don't have the Special Game Fixes box checked, so you might want to check it as not to confuse anyone who is trying to follow your picture 100% by the book.

I didn;t have hte game fixes checked as I set it to 3/2 IIRC, and that shouldnt' require the game fix.

As for save states, it's well known, or at least should be, that Save States can muck up games.
 
1 - 9 of 9 Posts
Top