Next Generation Emulation banner
1 - 1 of 1 Posts

·
Premium Member
Joined
·
3,093 Posts
Switch to ePSXe 1.5.2, better for FF games.
 
1 - 1 of 1 Posts
Top