Next Generation Emulation banner
1 - 8 of 8 Posts

·
Registered
Joined
·
603 Posts
Discussion Starter · #1 · (Edited)
[Resolved]FF7 Sound Issues

FF7 works perfectly fine so far, no freezes, no slowness, but one thing that bugs me is the sound effects. They're really 'high-pitched'

I was wondering what the recommended plugin and settings are to make the sound better for that. (Example: The train sounds at the start of the game sound horribly wrong, as well as many other things).

Using epsxe 1.7.0 btw.


NOTE:
The music however is perfectly fine. It's only the sound effects.
 

·
Banned
Joined
·
23,263 Posts
Possibly reverb issues if you are loading a 1.6 state into 1.7.
 

·
Banned
Joined
·
23,263 Posts
that could be why, peops dsound is very out dated.
 

·
Registered
Joined
·
603 Posts
Discussion Starter · #6 ·
Oh I was under the impression that it was the newest/best plugin out right now, because on some download page it said it replaced some old ones or something.. Not entirely sure.

Either way, which do you recommend I should get then instead that might work for it?
 

·
Banned
Joined
·
23,263 Posts
Eternal SPU, or epsxe's internal audio plugin are far better than peops at this point.
 

·
Registered
Joined
·
603 Posts
Discussion Starter · #8 · (Edited)
Eternal SPU 1.5b2 seems to have fixed the sound problems. It sounds much better now, and the weapons actually sound like the real weapons this time. (Cloud's Sword, Tifa's fists, etc).

Thanks for the help :)

Edit:
Btw Squall, I ran into another problem that you might be able to help with:
http://forums.ngemu.com/problems-games/128786-ff7-pec-no-encounter-code.html#post1756386

Totally unrelated to this topic, but yeah, maybe you know why it's happening.
 
1 - 8 of 8 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top