Next Generation Emulation banner
1 - 8 of 8 Posts

· Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
Foreword: In my defense I did extensive "ff7" and "ff7 polygon" searches in this forum and came up empty handed.

Screenshots will most effectively describe my issue:



In shot one you can see the distortion of Cloud and Tifa's faces, and it's especially apparent in Tifa's blouse. More general facial distortion of Cloud in shot two. And then a battle screen, polygon issues still apparent in Cloud's legs. Cutscreens and backgrounds are all perfectly fine.

I've been to the "Need a config, check here first" sticky. I've tried multiple configs with for both Pete's Opengl 1.78 and Pete's Opengl2 2.9, but the problem persists. I've also tried configs posted by people on these forums where they accompanied their posts with screenshots of properly drawn characters... so I guess it's not a config issue?

My system is: ATI Mobility Radeon X1600 (256mb), Duocore, 2gb ram, and I have .iso-ed the disk.

Hope I posted this in the right section in any case, and thank you ahead of time for reading or if you can point out what I might be missing.
 

· Banned
Joined
·
35,081 Posts
search google for PSX LACKS Z-BUFFER.
 

· Banned
Joined
·
35,081 Posts
heh, would've been easier to tell that, if he was playing a decent game :p
 

· Registered
Joined
·
3 Posts
Discussion Starter · #5 ·
Thank you both, Squall and Zedeck.

Should a future search find this, Zedeck's link proved fruitful. Some one suggested using Pete's D3D plugins, which I've switched to from the Opengl plugins, and Cloud and co. are now being drawn correctly. I have the most recent Omega drivers in any case, no idea what any of this has actually changed, but I'm happy with the result.

"...if he was playing a decent game." Hmmm? No love for a classic?
 

· God of Douchebagness™
Joined
·
15,294 Posts
if you install the latest catalyst drivers you should be able to use the OGL plugins again, the problem is a driver-based thing so its pretty simple to fix once you become aware of it.
 

· From Love and Limerence
Joined
·
6,584 Posts
ATi doesn't have the OpenGL support in it's drivers that nVidia has. That's why this happens on ATi cards with certain driver versions. The latest Omega drivers must be based off of a build that still didn't have the better support the recent official drivers do.

P.S. You can choose to retain your current drivers, but Pete's Direct3D plug-ins in ePSXe aren't quite as good as Pete's OpenGL plug-ins, especially the OpenGL2 plug-ins.
 

· Registered
Joined
·
3 Posts
Discussion Starter · #8 ·
ATi doesn't have the OpenGL support in it's drivers that nVidia has. That's why this happens on ATi cards with certain driver versions. The latest Omega drivers must be based off of a build that still didn't have the better support the recent official drivers do.

P.S. You can choose to retain your current drivers, but Pete's Direct3D plug-ins in ePSXe aren't quite as good as Pete's OpenGL plug-ins, especially the OpenGL2 plug-ins.
You appear to be right again, I replaced the Omega drivers for the new Catalyst drivers (a long tedious task with a laptop having to learn how to use Modtools) and now OpenGL2 is also working for me.

The whole issue seems so obvious now, thanks again for straightening me out.
 
1 - 8 of 8 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top