Next Generation Emulation banner
1 - 9 of 9 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
Ok, I've read more FF7 problem threads than you can shake a stick at, and I am at my wits end trying to get this game to play properly.

Problem is sound. Boy, that's a new one isn't it. ;)

Graphics run fine, I can deal without the battle swirl. The battle music slooows down to about half speed, and so does the after-battle menu music. What's odd though is the FPS never drops, ever. It stays locked at 50.

PC specs are as follows:

CPU - P4 2.8ghz
RAM - 1024mb DDR
Video - ATI Radeon 9800 Pro 256mb
Sound - Soundblaster Audigy 2 ZS

Now, I know this is more than enough to play this game. I'm right at the end of Xenogears, and have been playing it without a single error (other than the Deus boss crash which is unavoidable). I'm using ePSXe 1.6.0. Here's the obligatory video/sound config info.

---------------------------------------

Plugin: Pete's OpenGL Driver 1.1.75
Author: Pete Bernert
Card vendor: ATI Technologies Inc.
GFX card: RADEON 9800 Pro x86/SSE2

Resolution/Color:
- 1600x1200 Fullscreen - NO desktop changing [32 Bit]
- Keep psx aspect ratio: off

Textures:
- R8G8B8A8
- Filtering: 6
- Hi-Res textures: 2
- VRam size: 128 MBytes

Framerate:
- FPS limitation: on
- Frame skipping: off
- FPS limit: 50

Compatibility:
- Offscreen drawing: 3
- Framebuffer texture: 2
- Framebuffer access: 3
- Alpha multipass: on
- Mask bit: off
- Advanced blending: off

Misc:
- Scanlines: off
- Line mode: off
- Unfiltered FB: off
- 15 bit FB: off
- Dithering: off
- Screen smoothing: off
- Screen cushion: off
- Game fixes: on [00010001]

------------------------------------------

Eternal SPU Plugin 1.41

Device = DirectSound
Buffer size = 22
Audio out = Thread
Wait for XA buffer is free

Special game fix - Update before accessing register

-------------------------------------------


I am using ISO images, just like I did for Xenogears. Before anyone mentions the superhigh 1600x1200 resolution, I should mention changing it to anything, all the way to 640x480 - full desktop or windowed - does nothing.

Rather than state all the configs I've tested, lets just say I've probably tested nearly 90% of anything ever mentioned on these forums, and I get the very same results. At least the game looks the best at these settings and still has music slowdown.


Ideas? I've been fiddling with this for 4 days now, I just want to play the game, especially since I never played far into it before.
 

·
Registered
Joined
·
2 Posts
Discussion Starter · #3 ·
Ok, odd. 1.5.2 did no better. 1.5.0 is noticably better, but there's a hiccup in the music on where the battle swirl occurs. That I can live with. I hadn't seen anyone recommend 1.5.0, just 1.5.2. Much appreciated! :)

Now, I just have to get these PSX Cheater cheats to work. Yes, I cheat, only minimally though. RPGs are not my forte in the skill department, and a little help here and there makes the experience enjoyable rather than frusrating. :p
 

·
Emulation to the max!
Joined
·
2,560 Posts
try changing your spu plugin to peops it might work better.
 

·
Premium Member
bsnes, ePSXe
Joined
·
21,982 Posts
first of all, 1.5.2 is just fine to use. second, you have the completely wrong special game fixes. all you need is teh FF7 one; turn off the others. lastly, try this:

Compatibility:
- Offscreen drawing: 1
- Framebuffer texture: 3
- Framebuffer access: 2
- Alpha multipass: on
- Mask bit: on
- Advanced blending: on
 

·
Registered
Joined
·
130 Posts
There is something that I don't understand, I am playing FF7 with ePSXe 1.6, I'm in the end of the second CD, and I don't have any problem oO, why I should use the 1.5.2 version?
 

·
Premium Member
bsnes, ePSXe
Joined
·
21,982 Posts
well, ePSXe has some slight timing problems, also, it's known to not like many square games, for unknown reasons.

however, it is my belief that people go way overboard with the "use 1.6.0" thing. honestly i dont know of any problems with FF7 and 1.6.0...

im currently playing FF7 on 1.5.2. i should switch to 1.6.0 just to troubleshoot for bugs. i did it for FF9 :rolleyes:
 

·
Go-player 15 kyu ^^
Joined
·
185 Posts
Eternal SPU Plugin 1.41

Device = DirectSound
Buffer size = 22 (Have you tried to increase the Buffer Size? Low Buffer Size may give you weird noises... I use 25.)
Audio out = Thread
Wait for XA buffer is free (You don't need this...)

Special game fix - Remove the "Update before accessing register." FF7 does not need it, and if you use this you may encounter some hiccups...
 

·
Botta Bing Botta Bang
Joined
·
21 Posts
Hmm... FF7.. I remember playing that on my
p4 2.4 ghz 512 ram geforce2mx system..
800x600 res, 32 bit colour, ran flawless
only problem was no battle swirl, I disbaled it, too slow.
epsxe 1.6.0
=\
 
1 - 9 of 9 Posts
Top