Next Generation Emulation banner

1 - 4 of 4 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
Hello. I'm experiencing a problem playing FF7 (US-NTSC) which I can't seem to find information on anywhere. I suspect the problem to be an SPU issue, but I could certainly be wrong about that. For starters, I'm using epsxe 1.4.0, and I've tried running the game from the beginning using both the CD and an ISO. The problem seems to be that--during the opening mdec--the sound and the video are out of sync (for example, there's supposed to be a cymbal crash when the FF7 logo appears in all its triumphant glory, but it doesn't occur until about 5 seconds after the logo appears). After this, however, I decided that this wasn't quite the problem; the sound is actually playing too slowly (I've played through the game before, and I'm a huge fan of FF music, so I'm 100% sure that it's playing too slowly, for whatever reason).

I've played through a few games now using both epsxe 1.4.0 and 1.2.0, and not once have I encountered this problem. The video plays at normal speed, and I've never had any problems with mdecs (in terms of scratchy/jerky sound or video) before. To confirm my suspicions, I tried the game in version 1.2.0 of epsxe, and came out with the same problem (I used save states to skip the opening, which I've heard causes problems with said version). I tried the game in CVGS, and the music was just fine; correct speed and everything (although, a bit scratchy, as I've never had great success with VGS). The problem here is that I do not want to use VGS to play FF7 (I mainly keep it around for testing purposes), but with epsxe.

Does anyone have any suggestions as to what the problem might be? My system specs are as follows: P3-933mhz, 256mb SDRAM, GeForce2MX, and SBLive! Value. Please see the attached picture for my video plugin settings (using Pete's OpenGL, which I've never had this sort of problem with). As far as SPU settings, I've tried both the internal SPU (which has always worked very well for me) and IORI's latest; neither fixed the problem. Among the settings I've tried turning on and off are: frame skipping, off-screen drawing, FF7 "special game fix" for borders, enable/disable ADPCM/CDROM/XA-mdec/XA-game sound, SPU IRQ hack, accurate CDROM timing, CDROM status...and that's about it. Setting the FPS limit to 67 or so seems to put the music about where it should be, but I'd much rather be able to play the game at 60 "properly" so that the out-of-synchness won't happen again later on. At any rate, I never encountered this problem in FF8, FF9 or Chrono Cross, and would love to play FF7 again on epsxe. Any help would be greatly appreciated. Thanks in advance.
[email protected]
 

·
Premium Member
Joined
·
8,586 Posts
I have experience the exact same thing with FF7.. I stated it in an old thread.. I also enjoy listening to the music which is why I also noticed that the music was playing slower than on a real psx..

Use a framelimit of 70 or 75 not 60... I use 70 when playing FF7 which seems to fix the music playing slow.. I also tried lewpys "old" framecap method.. It does make the music play at the correct speed, but the battles are way too fast.. So try 70 framerate and see if that helps..
 

·
Registered
Joined
·
3 Posts
Discussion Starter #3
Originally posted by fivefeet8
I have experience the exact same thing with FF7.. I stated it in an old thread.. I also enjoy listening to the music which is why I also noticed that the music was playing slower than on a real psx..

Use a framelimit of 70 or 75 not 60... I use 70 when playing FF7 which seems to fix the music playing slow.. I also tried lewpys "old" framecap method.. It does make the music play at the correct speed, but the battles are way too fast.. So try 70 framerate and see if that helps..
Thanks for the reply, as well as the sound advice (sorry; couldn't resist the pun). I'm not sure if I can use a lewpy plugin, as I've got a GeForce card, but I'll definitely look into it, as I'm more than a bit desparate at this point.

As I said, I tried a higher FPS, and it does speed the music up to the correct level, but I was wondering if there was another way to fix the problem (such as speeding up the music through sample rate--or some other option--without speeding up the video). Playing the game as is (higher FPS) would be fine for in-game sequences, but the movies (especially the ending) would move too quickly at a higher framerate, and they'd still be out of sync with the music; this would especially ruin the ending, methinks.

I realize that I'm being very picky here, and I'm sorry about that (ePSXe is certainly one of the best free emus I've ever used, and if it doesn't work to my exact specifications, then I'm in no position to complain), but I'd simply like to know if there is a more desirable solution to my problem here, or if there might ever be one in a future plugin or version of the emu. Thanks again for any more replies.
[email protected]
 

·
Premium Member
Joined
·
8,586 Posts
a future version may fix the timing problem in some games.. So just gotta wait and see.. You could try petes pluggins special game fixes.. enable "pc fps calc and limit".. It seems weird though, but when I play FF7 at 70 fps and the mdecs run, they run correctly and is in sync.. Its just the outworld music and battle tunes that are slow.. But the 70 fps limit seems to fix it for me.. The game does run a little faster but its still very playable.. I haven't had the music lagging in mdecs at 70.. weird.. Maybe when the longer mdecs play I will notice it..
 
1 - 4 of 4 Posts
Top