Next Generation Emulation banner
1 - 7 of 7 Posts

· Registered
Joined
·
5 Posts
Discussion Starter · #1 ·
Hello, I just installed EPSXE and pete's plugins v1.90 ..

the graphics run smooth when maxed out and everything, but at the very beginning, when screen displays SCEA presents .. the screen flickers like crazy. In battles it's fine, but in regular view, the screen dances a lot, and it's so much annoying, all 3d character models keep on changing very fast, and the whole screen seems to be dancing all the time.

I've played the PC version of FF7 about 5 years and it did nothing like that.
 

· No sir, I don't like it.
Joined
·
7,022 Posts
Specifically which graphics plugins are you using? (D3D, OpenGL1, OpenGL2)

Can you be more specific about the screen "shaking"? Is it like a TV channel with bad reception?

The problem with 3D models is normal. The original PS1 hardware doesn't use a Z-buffer to calculate depth properly. PC video cards do use a Z-buffer. The only way to minimize the model warping is to lower your screen resolution or lower your internal resolution if you are using Pete's OpenGL2.
 

· Registered
Joined
·
5 Posts
Discussion Starter · #5 · (Edited)
Specifically which graphics plugins are you using? (D3D, OpenGL1, OpenGL2)

Can you be more specific about the screen "shaking"? Is it like a TV channel with bad reception?

The problem with 3D models is normal. The original PS1 hardware doesn't use a Z-buffer to calculate depth properly. PC video cards do use a Z-buffer. The only way to minimize the model warping is to lower your screen resolution or lower your internal resolution if you are using Pete's OpenGL2.
I am using Pete's OpenGL 2.

And yes, the problem is symbolized by the exact way you put it... it's a model warping. The 3d model abruptly changes each time i move him, resulting in a shaky feel. Perhaps the fact that the 3D model is shaking results into the illusion that the whole screen is shaking.

I'm running on a 1152 * 862 res.

You reckon i should tone it down to 800 * 600 ?

Furthermore, are there any plugins that take care of this Z-buffer problem ?
 

· No sir, I don't like it.
Joined
·
7,022 Posts
I am using Pete's OpenGL 2.

You reckon i should tone it down to 800 * 600 ?
Since you're using OpenGL2, you'll need to adjust the internal X/Y resolution settings to "1" or "0" in the graphics plugin configuration screen. Adjusting the display resolution has limited effect on the OpenGL2 plugin.

Furthermore, are there any plugins that take care of this Z-buffer problem ?
Only Pete's "Soft" GPU. The warping of 3D models simply occurs because of the vast differences in PS1 hardware vs. PC hardware. (specifically the difference in the use of a Z-buffer)

The only solution is to use the P.E.Op.S. "Soft" GPU plugin. It uses your CPU to render everything and doesn't require the use of a Z-buffer. The downside is that your games won't look as "crisp". Some people prefer this plugin regardless, as it is much more faithful in recreating the PS1's original graphics.
 
1 - 7 of 7 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top