Next Generation Emulation banner
1 - 17 of 17 Posts

·
Registered
Joined
·
9 Posts
Discussion Starter · #1 ·
Hey guys was just wondering if I could get some help with a problem that I have on all three of these games. The music and the graphics slows down when i go in battle mode for each of these games.

Here are my configs
Plugin: Pete's D3D Driver 1.1.76
Author: Pete Bernert
GFX card: Mobile Intel(R) 4 Series Express Chipset Family

Resolution/Color:
- 640x480 Window mode

Textures:
- R8G8A8A8
- Filtering: 0
- Hi-Res textures: 0
- VRam size: 0 MBytes

Framerate:
- FPS limit: on
- Frame skipping: off
- FPS limit: Auto

Compatibility:
- Offscreen drawing: 3
- Framebuffer texture: 1
- Framebuffer access: 0
- Alpha multipass: on
- Mask bit: on
- Advanced blending: hardware

Misc:
- Scanlines: off [0]
- Unfiltered FB: off
- Dithering: off
- Screen smoothing: off
- Full vram: off
- Game fixes: off [00000201]

If any other information is needed please say

Thank you for your help in advance
 

·
Registered MSX user
Joined
·
1,625 Posts
What are your other comp specs (CPU, RAM...) ?

Mobile Intel Boards are not really great and those games you've mentioned are quite heavy stuff.

You may not experience any graphics glitches? Still it would be great to use a frontend to make separate configs for different games. Same settings are not optimal for every game. What slows down another may help other game run better (mostly with better quality).

For each of those games, check out Kane's configs first:

Kane's Domain

If you can't gain more speed, use Pete's Soft GPU -plugins for those three games.
 

·
Registered
Joined
·
9 Posts
Discussion Starter · #4 ·
Here are the other informations you needed:
Processor: Intel(R) Pentium(R) Dual CPU T3200 @ 2.00GHz (2 CPUs), ~2.0GHz
Memory: 2006MB RAM

And thank you very much for the suggestions I will try them out
 

·
From Love and Limerence
Joined
·
6,574 Posts
The software plug-ins are CPU bound.

The hardware plug-ins are GPU bound.

I'd wager your onboard GPU should be fine with Pete's OpenGL (1) plug-in, but it seems it isn't? I can't remember correctly how my old onboard Intel Extreme Graphics 2 ran the game (Final Fantasy IX in battle), but I thought it was full speed, and if not, it had to have been pretty close to it. Your onboard GPU is stronger than that one, so I don't know why it's behaving that way. I know I was playing fullscreen though (at the same resolution), which is less taxing, but that laptop obviously has an LCD, so that's not an optimal solution, even if it did work.

Edit: I just noticed you're using the Direct3D plug-in. Have you tried the OpenGL one? With Pete's OpenGL 1.76 plug-in, try 3, 0, and 4 for the compatibility options, and try setting the VRAM your system is reporting allocated to your GPU.
 

·
Registered
Joined
·
9 Posts
Discussion Starter · #7 ·
I tried OpenGL 1.76 before using D3D and retried it now with your setting and its really slow now when im walkin,the loading ,the music and even worse in battle mode but I havent set the VRAM can u help me do that I dont really know how :S
 

·
From Love and Limerence
Joined
·
6,574 Posts
Something odd is going on.

I've tried my Pentium III 933MHz (also an 800MHz one) and GeForce 4 MX440 64MB, a configuration weaker than yours, and it was more than fine with Pete's OpenGL (1) plug-in with these settings.

Plugin: Pete's OpenGL Driver 1.1.76
Author: Pete Bernert
Card vendor: NVIDIA Corporation
GFX card: GeForce4 MX 440 with AGP8X/AGP/SSE

Resolution/Color:
- 640x480 Fullscreen - NO desktop changing [32 Bit]
- Keep psx aspect ratio: on

Textures:
- R8G8B8A8
- Filtering: 0
- Hi-Res textures: 0
- VRam size: 64 MBytes

Framerate:
- FPS limitation: on
- Frame skipping: off
- FPS limit: Auto

Compatibility:
- Offscreen drawing: 3
- Framebuffer texture: 2
- Framebuffer access: 1
- Alpha multipass: on
- Mask bit: on
- Advanced blending: on

Misc:
- Scanlines: off
- Line mode: off
- Unfiltered FB: off
- 15 bit FB: off
- Dithering: off
- Screen smoothing: off
- Screen cushion: off
- Game fixes: on [00000200] (this is the Final Fantasy IX fix only)

Your CPU is much better, and despite it being onboard, your GPU is likely better than that one (unless I'm vastly overestimating that onbaord, but come on, this is a GeForce 4 MX440 here). You have an all around faster system. I don't see why it's performing so badly. Like I said, something odd is going on with your PC.

Try those exact settings, and yes, including using full screen. To find out your GPUs allocated memory, type in "dxdiag" (without the quotes) in the run command, and check the Display tab.

There's probably some certain thing I'm overlooking, because I know for sure that hardware should perform better. It won't do miracles, but it should handle the OpenGL (1) and Direct3D settings at the minimal levels fine.

Oh, and check and make sure the laptop isn't in some mode (via power options, BIOS, or whatnot) to slow the CPU down to save power. It should let it run full speed if the power is needed, but some power schemes and BIOS options are aggressive, so let's check with the basics. Try running CPU-Z alongside ePSXe and make sure the reported speed of it goes up to the 2.0GHz Windows is claiming when the game runs.
 

·
Registered
Joined
·
9 Posts
I think this is my GPU allocated memory if not tell me

Display Memory: 779 MB
Dedicated Memory: 32 MB
Shared Memory: 747 MB
Current Mode: 1280 x 800 (32 bit) (60Hz)

I tried your settings with OpenGL and its really slow but with D3D its runnin really fine (in FF7 and FF9 havent tried Chrono Cross yet) except the music stops for a second in battle mode and more than 1 time. Im using these settings for D3D theyre the same you gave me. And for the power setting i put it in high performance it use to be in Power Saver. And for running CPU-Z I dont know how to do that

Plugin: Pete's D3D Driver 1.1.76
Author: Pete Bernert
GFX card: Mobile Intel(R) 4 Series Express Chipset Family

Resolution/Color:
- 640x480 Window mode

Textures:
- R8G8A8A8
- Filtering: 0
- Hi-Res textures: 0
- VRam size: 64 MBytes

Framerate:
- FPS limit: on
- Frame skipping: off
- FPS limit: Auto

Compatibility:
- Offscreen drawing: 3
- Framebuffer texture: 1
- Framebuffer access: 0
- Alpha multipass: on
- Mask bit: on
- Advanced blending: hardware

Misc:
- Scanlines: off [0]
- Unfiltered FB: off
- Dithering: off
- Screen smoothing: off
- Full vram: off
- Game fixes: on [00000200]

Oh and 1 last thing Im using epsxe 1.5.2 for Chrono Cross and its working really well wit those same settings above but not with 1.7.0
 

·
God of Douchebagness™
Joined
·
9,826 Posts
CPUID

download and run it, then start up epsxe but keep cpu z active in the background the entire time, dont shut it down once you begin using the emulator.

btw stick with the D3d or software plugins, some intel chipsets can have bad OGL performance.
 

·
Registered
Joined
·
562 Posts
Strange, seems you have X4500 (Mobile Intel® 4 Series Express Chipset Family = GM45 or GM43) - it even has Shader Model 4.0 (DirectX 10) and performance little over Geforce 8400 G. IMHO its driver problem, check the newest driver avanible on intel site (here)
 

·
Registered
Joined
·
9 Posts
Discussion Starter · #12 ·
All right I did everything and still it dosent get better in OpenGL but works well in D3D so I guess like you said im gonna stick with D3D just posting my settings one last time to see if theres anything I should change.

Plugin: Pete's D3D Driver 1.1.76
Author: Pete Bernert
GFX card: Mobile Intel(R) 4 Series Express Chipset Family

Resolution/Color:
- 640x480 Window mode

Textures:
- R8G8A8A8
- Filtering: 0
- Hi-Res textures: 0
- VRam size: 64 MBytes

Framerate:
- FPS limit: on
- Frame skipping: off
- FPS limit: Auto

Compatibility:
- Offscreen drawing: 2
- Framebuffer texture: 1
- Framebuffer access: 0
- Alpha multipass: on
- Mask bit: on
- Advanced blending: hardware

Misc:
- Scanlines: off [0]
- Unfiltered FB: off
- Dithering: off
- Screen smoothing: off
- Full vram: off
- Game fixes: on [00000201]

Also the sound problem hasent gone away when the music cuts for a second every like 10 seconds or so is there a way to fix that?
 

·
From Love and Limerence
Joined
·
6,574 Posts
The Direct3D plug-in doesn't render the game correctly, if I remember right. The menu is something it doesn't do right offhand. That being said, it should work for 99.9% of the game just fine.

As for the sound issues, post your sound plug-in and settings.
 

·
Registered
Joined
·
9 Posts
Discussion Starter · #14 · (Edited)
Ok here are my config for Eternal SPU 1.41 plugin

Audio Device: Direct Sound
Buffer Size: 64
Audio out Method: SPUasync
syncMode: Wait

Misc: Show realtime config window:eek:ff
Cache VAG decode: off
Fine Tune [-360-360]: 0
Reverb: Neill`s
Rec option: REG write DMA write

Special Game Fixes: Update before accessing regsiter (FF8,FF9 and some SQUARE games)

Thats pretty much it
 

·
Banned
Joined
·
23,263 Posts
nothing you can do im afraid. the frame buffer access on a integrated graphics chip just sucks.
 

·
From Love and Limerence
Joined
·
6,574 Posts
For the sound, change the syncMode to smooth, and try playing with the buffer size (has always worked at 32 for me).

For the visuals, you'll just have to choose between Direct3D or software rendering.
 

·
Registered
Joined
·
9 Posts
Discussion Starter · #17 ·
All right the sound problem is gone everythings fine now so id like to thank you all for your help I really appreciate your time Thank you very much. Can't wait to replay these games everytime I was getting to the end of them something would happen and I would lose my saves and have to restart all over but anyway thanks you guys
 
1 - 17 of 17 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top