Next Generation Emulation banner

FF7 - can't switch disks

1959 Views 16 Replies 4 Participants Last post by  hushypushy
I'm using epsxe 1.52, after the game prompts to insert disk two, i can't move any further: the disk two is inserted, but it's still only the switch screen (that one with some beautiful pictures) what i see. I've tried all the possible plugins, tried to launch the game both from cd-rom and iso, tried using epsxe 1.60 but nothing helped. Could anyone help?

PS Sorry for my english
Not open for further replies.
1 - 5 of 17 Posts
PS. keep it on ePSXe 1.5.2 just to be on the safe side as well.
well a lot of people are, and it seemed like you werent doing it so....

anywho, at the end of disc 1 it asks you to save. save it to your memory card at that point and close the emulator. insert disc 2, and start up the emulator on disc 2. load your game from there.
you can try PSXeven and PCSX if you'd like.

what CD plugin are you using? is your disc 2 alright, physically?
very strange. are you using a legit store bought version of the game?
well, sir, i am afraid if you did not buy the game not only:

1. no one can guarantee it's safety, sanity, quality, or playability and more importantly...
2. that is against the board's [rules]rules[/rules]. downloading a game is illegal.

this thread is closed for those two reasons. go buy the game.
1 - 5 of 17 Posts
Not open for further replies.