Next Generation Emulation banner
1 - 12 of 12 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter · #1 ·
I'm running Ubuntu 9.0.4, and using Pete's MesaGL 1.78. My copy of Final Fantasy 7 crashes after struggling to show the battle swirl. I don't much care about seeing the swirl, so if anyone has any solutions - especially ones that remove the swirl outright - I'd love to hear them.
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #4 ·
try using peops software plugin?
MesaGL is Peops software, I don't see what you're getting at here unless you mean Peops Soft GPU, which I stopped using because it was slow.

Retrying it... it runs slower, it silences all sound and it still crashes just as the first battle begins.

The crashing can't be a problem with the ISO because I did, under some setting, get it to work fine... provided I minimised during battle scenes. I'd switch to ePSXe but I can't get any sound off it whatsoever.
 

·
Banned
Joined
·
35,081 Posts
then you're missing a dependancy or library.
 

·
Banned
Joined
·
35,081 Posts
pcsx has a known crash on FF7. so either use epsxe or be screwed.
 

·
Whistler
Joined
·
137 Posts
the most important thing - try using a real BIOS instead of the internal HLE bios.
it could also help to use the PCSX-df XVideo plugin, which is usually faster than the PEOPS Soft Plugin.

btw, FF7 never crashed with PCSX on the 3 computers which I have access to (all are different distros of GNU/Linux) :)
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #12 ·
the most important thing - try using a real BIOS instead of the internal HLE bios.
it could also help to use the PCSX-df XVideo plugin, which is usually faster than the PEOPS Soft Plugin.

btw, FF7 never crashed with PCSX on the 3 computers which I have access to (all are different distros of GNU/Linux) :)
Thanks! This fixed the segfault, I haven't had any problems up to the first boss...

have you tried using this one?
pSX emulator
it should work very well imo
pSX emulator - How-To install pSX on Ubuntu AMD64/x86
...because I got up to where Cid becomes your new leader on pSX, using Ubuntu 9.4. I then changed back to 8.10 - unrelated problems - and now pSX won't run even if I kill pulseaudio first.

My only problem now is the sound. If I run PCSX with the default sound plugin "ALSA Sound 1.0.0" everything sounds just a little off, whereas if I run it with Pete's OSS Audio Driver 1.1.9, the music is fine but the sounds in battle are horrible. I haven't touched the settings much, because I think someone might have encountered and fixed this and I don't want to waste my time reinventing the wheel.
 
1 - 12 of 12 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top