Next Generation Emulation banner

1 - 4 of 4 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
hi, i downloaded ePSXe version 2.0.5 but was unable to use the 2 graphics drivers kept crashing on loading so im using Pete's DX6 which seems to play Chrono Cross just fine... except when i play WcW Mayhem it plays the videos but sometimes 95% of the time when it gets to the start menu it will just go into a "black screen" after that, i could hear the sounds and music but visual is unplayable... the 1.7 version of ePSXe has sound issues however 2.0.5 fixed the sound issue... im just having the black screen problem now

i get the black screen sometimes from other games.

(ePSXe version 2.0.5)
Pete's DX6 D 3D Driver 1.77 <video
scph1001 - US <bios
ePSXe SPU core 2.0.0 <sound
ePSXe CDR WNT/W2K core 2.0.0 <cd
 

·
Not a Registered User
Joined
·
1,303 Posts
Would help to post your PC specs so we would know what were working here with.

A black screen can be caused by a plethora of things.
For one a bad copy of the game itself.
For GPU plugins issue, in GPU settings set threading mode to 0 and vram to the number of memory on your GPU, if it's more than 1gb just write 1024.
Under options set CPU overclocking to 1x.
Lastly in BIOS settings disable HLE emulation.
 

·
Not a Registered User
Joined
·
1,303 Posts
i7 7700k cpu
8gb ram other 8gb died
sapphire rx 580 8gb gpu
crucial 525gb ssd
With specs like those you should have no problems running either of the plugins, something has to be wrong with your system, ePSXe configuration or as I mentioned a bad copy of the games you're trying to run.
Post more details if available of the crash you're getting and what games and in what format you're trying to run.

Here's also guides on how to setup ePSXe.

 
1 - 4 of 4 Posts
Top