Next Generation Emulation banner

1 - 20 of 35 Posts

·
I'm sexy and I know it!
Joined
·
4,935 Posts
Discussion Starter #1
Since I got good help on my last problem, I thought I'd give you guys a different problem to work with :)

Thing is, ever since I started on disc 2 on Final Fantasy 8, at the prison, to be precise, the game is really choppy. I opened the task manager to see if something was wrong there, and ePSXe was using 50-60% of my cpu! With my AMD Athlon 64 6000+ (dual core), I don't think it's not that big a deal.
I see that even now when I've exited the emulator, the computer is kinda choppy, but the task manager says that only 5-10% of the cpu and 31% of the physical memory is being used at the moment. The memory usage of the emulator itself is only about 35mb.
Gpu: P.E.Op.S. Soft Driver 1.18 there's also a second one, named "Soft Video Plugin", dunno if it's part of Pete's or not. - Second one from This site.
Spu: P.E.Op.S. Dsound Audio Driver 1.9

Here's a weird fact: The game is only choppy when I run it in window mode (640x480), but if I run it in fullscreen mode, it's totally fine. I used the "nice" setting in the gpu plugin, however I changed the resolution and colour depth for the fullscreen mode.
I tried starting it now in window mode, and it worked fine for 10 seconds while playing, but then it started chopping again.

I had played around with the gpu settings earlier, so I thought it was something wrong there, so I removed all the plugins from the folder and downloaded them again, this time using the default settings. Those are the settings I'm using now.

Any idea why it's suddenly acting up on me?

Yes, I am fully aware that I can play using fullscreen mode, but I do not want to. As I got a 20" (1680x1050native), it's really corny and rather painful to watch, playing in fullscreen mode.

I'll accept any suggestions/explanations on why this only happens in window mode gladly, and any fixes.
Do you think this problem will go away if I use an older version of the emulator (using 1.7 atm)

Total spec for my computer:
Amd Athlon 64 x2 6000+ (dual core)
XFX Geforce 8800GTS 640mb
4gb Corsair Twin2x PC6400 (ddr2)
Asus M2N32-SLI Deluxe
1tb hdd space distributed on 3 drives.
OS: Vista Ultimate64

The emulator is located on the OS-disk, which is a 150gb (43 outta 139gig available) 10krpm Raptor.
Anything I've forgotten? Methinks not, but let me know if there is.
 

·
Banned
Joined
·
23,263 Posts
update the amd dual core driver.
 

·
God of Douchebagness™
Joined
·
9,826 Posts

·
I'm sexy and I know it!
Joined
·
4,935 Posts
Discussion Starter #4
Didn't work :/

Installed it, tried FF8, was still laggy.
Restarted the comp, tried FF8 again, still laggy :(
Granted, I was running World of Warcraft as well after I restarted and tried it, but I've been running CS: Source and World of Warcraft at the same time without noticing any sort of lag.

But thanks for the suggestion though!
Any more?
 

·
Banned
Joined
·
23,263 Posts
emulation isn't a typical game. as it is, opengl utterly dislikes sharing the hardware with another api.
 

·
I'm sexy and I know it!
Joined
·
4,935 Posts
Discussion Starter #6 (Edited)
Okay, I'll try after the raid then.

Nope, still choppy =/
Only got Firefox, Notepad and a few folders open now.

This is really weird.
Like, earlier today I was playing without any problems what so ever.
And I haven't installed/uninstalled anything, nor have I made any major/minor changes to the system.
 

·
God of Douchebagness™
Joined
·
9,826 Posts
have you done any overclocking to your hardware and are your drivers up-to-date?
 

·
Banned
Joined
·
23,263 Posts
ahh :) just saw you're an nvidia user, are you using Forceware 177 or higher? seems nvidia's multithreaded opengl setting is causing issues on epsxe, so download nhancer, then create a profile for epsxe in which opengl multithreading is disabled.

also set prerender limit to 2 :)

use the opengl 2.9 plugin and set it to 1-2-2 and enable gamefix 1 and 2
set internal resolutions to 3 and 2 and enable Pixel shader for psx texture win. and set render mode to 2.
 

·
I'm sexy and I know it!
Joined
·
4,935 Posts
Discussion Starter #11 (Edited)
have you done any overclocking to your hardware and are your drivers up-to-date?
Nope, no overclocking whatsoever.
Drivers are v180.48.

ahh :) just saw you're an nvidia user, are you using Forceware 177 or higher? seems nvidia's multithreaded opengl setting is causing issues on epsxe, so download nhancer, then create a profile for epsxe in which opengl multithreading is disabled.

also set prerender limit to 2 :)
nHancer downloaded and configured now.

use the opengl 2.9 plugin and set it to 1-2-2 and enable gamefix 1 and 2
set internal resolutions to 3 and 2 and enable Pixel shader for psx texture win. and set render mode to 2.
So if I got this right:
Internal X resolution: 2
Internal Y resolution: 3
Stretching Mode: 0
Render Mode: 2

Texture Filtering: 0
Hi-Res textures: 0
Gfx card vram: 640 (set it manually)

Off-Screen drawing: 1
Framebuffer effects: 2
Framebuffer upload: 2

Shader effects: 1

And special game fixes 0x00001 and 0x00002.


Edit: Still choppy after changing to those settings (and nHancer running) =/
Editedit: It seems like after I've had ePSXe run in this "choppy" mode, my desktop is kinda sluggish as well. Like when I type stuff, and minimizing/maximizing windows. This is normally fixed if I restart the computer though.

I just think the whole thing is weird...
I was playing a bit this morning, in fullscreen mode, and it worked perfectly.
I mean, weird in the sense that I was using the exact same settings, I just swapped from window mode to fullscreen.
 

·
God of Douchebagness™
Joined
·
9,826 Posts
you dont have the internal fps limiter and the plugin limiter running at the same time do you?
 

·
Banned
Joined
·
23,263 Posts
my last idea, is that its Vista itself :\

try setting the disable visual themes / dwm compatibility in the exe's properties.
 

·
I'm sexy and I know it!
Joined
·
4,935 Posts
Discussion Starter #14 (Edited)
you dont have the internal fps limiter and the plugin limiter running at the same time do you?
Apparently both was running (when I pressed f4 in game the log said it was disabled, then enabled when I pressed f4 again), but it was the same result either way.
With the gpu plugin fps limiter activated: choppy
With the epsxe fps limiter acivated: choppy
With both fps limiters active: choppy
With No fps limiters active: less choppy, but that's because the game runs faster. Still noticable though.
Was even choppy when I was using the "fast" preset.

Was equally choppy when I tried v1.6 of the emulator.
Going to try v1.5.2 now.

Edit: 1.5.2 didn't work any better...

And disabling the visual themes didn't work either.
Tried compatibility mode for Windows XP (SP2), but no change...

Me no like this :(
 

·
God of Douchebagness™
Joined
·
9,826 Posts
do all games run like this or is it just this one? try manually setting the cpu affinity so its being run on only one core in the task manager and see how it reacts, and do it for all 3 versions if you can.
 

·
I'm sexy and I know it!
Joined
·
4,935 Posts
Discussion Starter #16
Okay, it looks like it's working fine now that I told it to only use 1 core.

And no, this is the only game that does this. And only in window mode.
Fullscreen works like it's supposed to.

Will see if this works more than a few minutes.

Thanks for all the suggestions so far :)
 

·
God of Douchebagness™
Joined
·
9,826 Posts
just so you know, there is a way to set the affinity permanently but its sort of tricky, i can attempt to explain it to you if you feel up to trying it though.

this problem of yours is sort of strange though, im using a dual core myself and i only have to adjust the affinity when im using 1.5.2 or 1.6.0, they fixed the multi-core performance issue in 1.7.0 and the only people who usually get issues with that version now are people using AMD dual cores (and that is fixed by simply using that driver i posted earlier).
 

·
Banned
Joined
·
23,263 Posts
I don't like the hard patch method Jonc :(

However, there is a program called winlauncherXP which works on Vista, that does the same thing :)
 

·
I'm sexy and I know it!
Joined
·
4,935 Posts
Discussion Starter #19
So I've downloaded WinlauncherXP and set ePSXe to only use 1 core.

Plugin: Pete's OpenGL2 Driver 2.9
Author: Pete Bernert
Card vendor: NVIDIA Corporation
GFX card: GeForce 8800 GTS/PCI/SSE2

Resolution/Color:
- 640x480 Window mode
- Internal X resolution: 1
- Internal Y resolution: 1
- Keep psx aspect ratio: off
- No render-to-texture: Ÿ

- Filtering: 0
- Hi-Res textures: 0
- TexWin pixel shader: off
- VRam size: 640 MBytes

Framerate:
- FPS limitation: on
- Frame skipping: off
- FPS limit: Auto

Compatibility:
- Offscreen drawing: 1
- Framebuffer effects: 2
- Framebuffer uploads: 2

Misc:
- Scanlines: off
- Mdec filter: on
- Screen filtering: on
- Shader effects: 1/1
- Flicker-fix border size: 0
- GF4/XP crash fix: off
- Game fixes: on [00000003]
Using the settings listed above, the game is able to play perfectly in window mode, UNTIL I click something else, like this Firefox window, for instance. Then it starts lagging like crazy, and the only way to fix it is by exiting ePSXe and starting a new one.
 

·
God of Douchebagness™
Joined
·
9,826 Posts
this is just the emulator lagging, nothing else? what do you do when you want to move around to another window, do you press esc to bring it back to the GUI or do you alt+tab out?
 
1 - 20 of 35 Posts
Top