Next Generation Emulation banner
1 - 11 of 11 Posts

·
Registered
Joined
·
12 Posts
Discussion Starter · #1 ·
Alright, so I just got Jaunty up and running and gnome back to where I wanted it in record time. I couldn't remember which plugins I used before so I just installed P.E.Op.S. OSS Audio Driver 1.9, but there's no sound. I thought maybe it was because I had Jaunty set to ALSA, but it shouldn't make a difference. It didn't.

I then got the 1.41 Eternal SPU plugin (since it's the one I use in XP) in the plugin folder, and now ePSXe crashes with this output. Not only does it crash, but the open terminal becomes non-responsive too. Kinda annoying.

Code:
libstdc++-libc6.2-2.so.3: cannot open shared object file: No such file or directory
Something's not set up right, because I have libstdc++6 installed. It might be worth mentioning as well that I get a GTK warning when launching ePSXe.

Code:
* Running ePSXe emulator version 1.5.2.

Gtk-WARNING **: Failed to load module "libcanberra-gtk-module.so": 
libcanberra-gtk-module.so: cannot open shared object file: No such file or directory
Now, I don't understand why I get this output because that package is installed as well. This is why I'm lead to believe that something isn't set up right, or ePSXe is looking in the wrong spot.

thanks for the help.
 

·
Registered
Joined
·
1 Posts
Code:
* Running ePSXe emulator version 1.5.2.

Gtk-WARNING **: Failed to load module "libcanberra-gtk-module.so": 
libcanberra-gtk-module.so: cannot open shared object file: No such file or directory
Now, I don't understand why I get this output because that package is installed as well. This is why I'm lead to believe that something isn't set up right, or ePSXe is looking in the wrong spot.

thanks for the help.
My ePSXe installation shows similar warnings. I'm running ePSXe on Jaunty and it complains with
Code:
Gtk-WARNING **: Failed to load module "libcanberra-gtk-module.so": libcanberra-gtk-module.so: cannot open shared object file: No such file or directory

Gtk-WARNING **: Failed to load module "libgail.so": libgail.so: cannot open shared object file: No such file or directory

Gtk-WARNING **: Failed to load module "libatk-bridge.so": libatk-bridge.so: cannot open shared object file: No such file or directory
But all these files are installed on my system. So I tried to point ePSXe to the needed files by setting LD_LIBRARY_PATH to "/usr/lib/gtk-2.0/modules/" (export LD_LIBRARY_PATH=/usr/lib/gtk-2.0/modules/). And when I tried to start it afterwards I got this error:

Code:
line 7: 15851 Segmentation fault
So I set LD_DEBUG to "files" (export LD_DEBUG=files) to get some debugging output and found the following three errors

Code:
/usr/lib/gtk-2.0/modules/libcanberra-gtk-module.so: error: symbol lookup error: undefined symbol: g_module_unload (fatal)

/usr/lib/gtk-2.0/modules/libgail.so: error: symbol lookup error: undefined symbol: g_module_unload (fatal)

/usr/lib/gtk-2.0/modules/libatk-bridge.so: error: symbol lookup error: undefined symbol: g_module_unload (fatal)

And since I don't know anything about this kind of error I googled around and the most interesting solution for fixing these warnings was a post here on the ngemu forums, where someone got rid of a similar warning by recompiling pcsx2: http://forums.ngemu.com/1155745-post7.html .
But I can't try and recompile ePSXe because... erm there's no source available... ;)

I attached the full debug output to this post, and hope it can help the developers to fix these problems.

SilentStar
 

·
Registered
Joined
·
12 Posts
Discussion Starter · #4 ·
EPSXE is up in Jaunty - just no audio

I may be wrong since I haven't used ePSXe for a while on linux but in the past there were problems because the ePSXe is UPX compressed executable.

Try to follow this post maybe it helps.
Thanks for the post. It worked. However, I did not install the beta:
Code:
sudo aptitude install upx-ucl
cd /path/to/epsxe
cp epsxe epsxe_bak
upx -d epsxe
However, on load, ePSXe still gives the same crap about not finding something. Now I just have to get the audio plugin working. Bah! Any thoughts on why I'm not getting sound? I get sound from other apps, and I'm using OSS in the control panel (what else?!). IDK.

Thanks

Still runs faster in Linux vs Win XP. lol Not as pretty, but faster!
 

·
カラム
Joined
·
365 Posts
Well, from what I can see it's complaining because you haven't got those packages. Look in the README for the packages you need to install and install them using Synaptic or APT in the terminal emulator.
 

·
Registered
Joined
·
1 Posts
I found the solution for the libcanberra-gtk problem from ubuntuforum. We have to unset the GTK_MODULES environment variable before running epsxe. Issue this command to unset the GTK_MODULES environment variable :
$ unset GTK_MODULES
 
1 - 11 of 11 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top